Strange AC adaptor recognition problem on Panasonic Toughbook CF-71

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I'm having a very strange problem with a Panasonic Toughbook CF-71
laptop that I have, and I'm wondering if anyone has ever seen anything
like it or has any insight.

A little while ago my AC adaptor went bad.  It didn't die suddenly, but
rather seemed to slowly lose it's ability to charge/run the laptop for
extended periods of time.  I verified this with a voltage/amperage
meter and found that the AC adaptor's voltage and/or amperage were
dropping or behaving erratically.  Ordered a new adaptor, and it seems
to work fine.

But now there's a problem...

I think that laptop or the battery "adapted" to the lower voltage of
the old AC adaptor.  The laptop now thinks the adaptor is plugged in
whenever the battery is inserted.  It runs on the battery, but you get
the blinking red "battery confused" light.  It will also run on the AC
adaptor, but the battery will not charge.  To get the battery to
charge, you have to connect the AC adaptor, remove the battery, and
reinsert it.  Sometimes you have to do this a few times.

I've tried messing with the battery to no avail.  I cracked it open,
shorted the reset pin of the battery's charge indicator chip, and
drained the batteries 100% using a computer case fan as a load.  (My
intent was to fully "reboot" the battery.)  I then recharged the
battery and the problem persists.  So my current guess is that the
laptop is the problem.  The laptop has "learned" the voltage of the old
dying adaptor, and since that voltage was close to the voltage of the
battery it now can't tell the two apart.  ... or at least that's my

So does anyone know how I might reset the laptop's ACPI/power
management brains and get it to forget this information?  Or, is there
some way I can recalibrate it?  I know a bit about electronics, so I'm
comfortable hacking hardware.



Re: Strange AC adaptor recognition problem on Panasonic Toughbook CF-71 wrote:
Quoted text here. Click to load it

Do you know how old the battery is?
First thing I would do is shut off the notebook and unplug the AC
Adapter from the wall and the notebook then remove the battery. Let
everything cool to room temperature so you can be certain that the over
heat protection is not causing the problem.
Next connect the battery then the AC Adapter to the notebook followed
to the wall outlet and let it sit for a minimum of four hours.
After the four hours boot the computer and check the charge status of
the battery.  Is it drained or partially drained then your battery is
most likely approaching the end of life.  If it is 70 to 100% charged
then run it down and see how long the battery lasts.  If it drops down
in minutes then the high percentage was a false reading as can occur at
the end of life.
If the battery shows a very low reading but still lasts for an hour or
more then the battery's gauge is reading incorrectly.  Normally that
can be corrected through a series of charging and discharging.  If it
can not then the battery is probably either defective or depleted.

Best regards,


Re: Strange AC adaptor recognition problem on Panasonic Toughbook CF-71 wrote:
Quoted text here. Click to load it

The battery is pretty new and works fine.  I've already tried
discharging and recharging to no avail.  I'm pretty sure the battery is
good and is not the problem.

Re: Strange AC adaptor recognition problem on Panasonic Toughbook CF-71 wrote:
Quoted text here. Click to load it

The laptop contains a switchmode power supply designed to operate off a
certain input voltage. Running a SMPS in an undervoltage condition
causes larger-than-expected currents in the input side.

If this machine has the DC/DC converter on a separate board I would
replace that as your first step. Troubleshooting this at the component
level is not feasible.

Site Timeline