Sony Vio won't boot up...

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Greetings all,

  I have a Sony Vio Model PCG-GRV670. Its about 2 years old. It will not
boot at all. Get it to turn on, fans come on and then nothing. Its like it
is not getting to the BIOS to start it up. I located the 2 memory chips and
swapped them (thinking that if there was a bad section in one of them I
would be able to get "thru" the start-up). NO luck with that. Now I am
trying to get to the CPU and reseat it, hoping that "Chip-Creep" has
loosened the connection that I need. I have a good, charged battery and have
removed all of the externally connected USB devices.

   1. Any Idea how/where to get into the CPU?

   2. Next move...?



  PS: I am trying the Sony web site also...

Re: Sony Vio won't boot up...

Quoted text here. Click to load it

The GRV series is susceptible to two solder trace faults that will fail
the laptop.  First is fractured traces in the RAM slots.  These first
show up as missing RAM.  Second is fractured traces in the video chip
circuitry.  This chip is opposite the ram slots.  Both faults probably
result from thermal cycling.  In any event, these can sometimes be
repaired, but are not a user repair.  Check the posting in this forum
for additional:


Re: Sony Vio won't boot up...

You are barking up what is probably a dead tree.  The chances that
reseating the CPU will help are probably near zero (as were the chances
that swapping the memory chips would help).  Most likely, you have a
motherboard problem whose only resolution will be to replace the
motherboard.  Given how drastic that is, the one other thing I'd look at
would be the CMOS battery on or connected to the motherboard.  There are
a few laptops that won't start if this battery dies (note, this is the
exception and even this is a long-shot, but compared to changing a
motherboard .......)

Bill Pelka wrote:

Quoted text here. Click to load it

Site Timeline