Resurecting a Presario M2000?

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Hi all,

I have a Compaq Presario M2000 laptop that
was sitting for a couple of weeks.  It worked
before I let it sit.  I plugged in
the adapter and pushed the power button and
NOTHING, no lights, no beeps nothing.  So
I removed the battery and put it back in and
tried again, nothing.  Then I took the battery
out and tried to fire it up, nothing.  Do laptops
just go dead for no reason?  Does this one
need the battery to complete the curcuit and
fire up?  I have the feeling that even if I try a
new battery I will get the same result.  Any
ideas?  bad switch, bad adapter anything
else?  Is this a common occurance for this


Re: Resurecting a Presario M2000?

First of all it's a good idea to start at the beginning-:

Is the power adapter OK, have you tired waggling the lead just prior to
it going in the plug end where it's moulded, looking for a broken wire
where it goes into the plug... waggle the actual plug as well to see if
it's not a loose connection on the socket itself, these are common
faults with all the pushing and pulling.

If need be try another power unit or at least try it on another unit
this will prove that it's ok or not.

These are the first steps I'd be looking at myself, it's pointless
blaming the laptop if the power unit isn't working.


Re: Resurecting a Presario M2000?

Quoted text here. Click to load it

Your laptop have hareware problem. Even you buy the new battery is the
same, so if you need to repair, send your laptop to

Site Timeline