Power Troubles

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I got an Acer Aspire 300 for graduation last June and I haven't had
any real
problems with it until about two months ago.  When I plug it
in it won't charge.
 I check to make sure that it's in the wall.  My
power cord has a green light on
to show that it is, in fact, plugged
in.  But when I put the cord into my
computer it seems like it
doesn't recognize that I have it plugged in.

I can jiggle it around a bit and it'll be fine, but if I move
it then the power
will go out and as of last Thursday I haven't been
able to get it to charge

I don't know what the problem is.  Does it seem like I need to buy a
power cord, a new battery, or is there another problem?

Re: Power Troubles

If you got it last June it's still under warranty, let Acer fix it.

clogger432 wrote:

Quoted text here. Click to load it

Re: Power Troubles

clogger432 wrote:
Quoted text here. Click to load it


Just based on what you posted, it sounds like the solder joint on the
power connector (inside the laptop) might be bad.  If it was having an
intermittent problem with the connector before, "jiggling it around"
probably made the problem worse, to the point that the solder joint
might have a gap now.

How long was the warranty on the machine?  If it was a year, and you got
it last June, it might still be in warranty?


Re: Power Troubles

Thanks a lot.  I was thinking that it might have something to do with
that but I was hearing so many different things from people who don't
know what they're talking about that I was rather confused.  Your
solutions sound like the best though so I guess I'll send it back in
to Acer.

Site Timeline