Power but no Boot

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Got an Acer Aspire 7520 that for some reason won't boot even to post. when
the power button is pushed, power come on but nothing more.  the power
button / hard drive light / power indicator light and wifi light all flash
but then I can't turn the laptop off ... only by removing the battery. the
things I have tried are a donor had drive and memory with no success. any
advice / help would by welcome

Hazard County
United Kingdom

Re: Power but no Boot

In an earlier contribution to this discussion,

Quoted text here. Click to load it

Sounds like a problem with the BIOS, but I don't know how to fix it - other
than by replacing the motherboard, which is a bit drastic!
Email address maintained for newsgroup use only, and not regularly
monitored.. Messages sent to it may not be read for several weeks.

Re: Power but no Boot

Roger Mills typed on Mon, 10 Aug 2009 23:00:52 +0100:
Quoted text here. Click to load it

Yes it does. In some circles, we call this as a bricked computer. There
are some things to try though on some models.

1) Turn off the laptop, remove the AC and the main battery, hold down
the power button for 30 seconds. Now try to boot the machine.

2) Some laptops has a reset button through a tiny hole. A bent paperclip
works well to reset it. Do the very same as #1, but while holding down
the power button for 30 seconds or more, also hold down the reset

3) Some motherboards has two pads which you can short out. You have to
know where they are in your model if they exists. And you need to follow
the same idea as #1 and #2.

4) Some BIOS protects the code to reload the BIOS. Thus if the BIOS
somehow gets trashed, this reload code may be still active. Most of the
time you need the BIOS code on a FDD and some will accept the BIOS code
on an USB flash drive formatted as FAT. And usually when you turn it on,
you have to hit a hotkey like F12, F1 or something. Then the BIOS will
be reprogrammed.

On another note, for the first time on one of my EeePCs... I shutdown
and everything went fine. I turned it on and it started normally but
Windows 2000 booted and the screen went blank and no disk lights either
(very unusual). Forced shutdown (holding the power button down for 10
seconds). Restarted and I had your problem. Power lights up, WiFi lites,
no POST screen (no display at all) or anything. Applied #2 and all is
well again. And I am using it now.

Windows 2000 SP4 (5.00.2195)
Asus EEE PC 701G4 ~ 2GB RAM ~ 16GB-SDHC

Re: Power but no Boot

The problem probably IS the motherboard (not the bios, but the
motherboard).  I talked to a technician at a firm I use in Miami that
actually does component repairs of motherboards (the cost is typically
$80 to $100, plus shipping, and they can't always fix the problem).  The
usual problem is that either the Southbridge (part of the chipset) burns
up and dies (from overheating) or that BGA (ball grid array) connections
of the chipset (northbridge or southbridge) to the motherboard fail.
Fixing any of these requires a BGA workstation that can unsolder /
remove / replace the chipset chips.  It's a $20,000 workstation,
typically.  Other things can happen, but these are the most common
things that they see in dead motherboards that have no physical damage.

Roger Mills wrote:
Quoted text here. Click to load it

Re: Power but no Boot

This is a very common problem.  The solution is either very simple
(usually bad memory or the memory has become improperly seated in the
socket) or the motherboard is bad (horrifically expensive; usually means
a whole new motherboard).  Since you have tried the memory .....

Ivor wrote:
Quoted text here. Click to load it

Site Timeline