Lost USB

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Acer laptop with OEM Vista Basic. Recently it lost the ability to work with
any plug in USB device. We reformatted and reinstalled Vista. Same problem.

Hardware manager looks perfect until you plug in a USB device. It detects
the functioning device but reports that it is not functioning. Any
suggestions? Friend lost receipt from Staples on a cash purchase so he has
no warranty service for the 6 month old unit.

Re: Lost USB

Richard typed on Tue, 4 Mar 2008 08:41:40 -0500:
Quoted text here. Click to load it

Sounds like a bad connection on the motherboard to me. I don't know what
to say about the lost receipt. Acer should know when the laptop was
manufactured and adjust accordingly.


Re: Lost USB

Quoted text here. Click to load it

I'm having the same sort of issue with my less than 1 year old Acer.
It has not lost the total ability to work with USB (yet) but it does
occasionally decide to not work and cause the device to need to be
plugged in. Vista also keeps telling me that I have more USB ports
than I do, and that the device would work faster if I plugged it into
a USB 2.0 port...except I've tried them all and it gives me the same
message on all of them. I agree with the other poster, it sounds like
bad connections on the motherboard and they'll have to replace the

Good luck with Acer technical support. I've had to send my laptop to
them for other motherboard related issues multiple times, and they
have been nothing short of a disaster.

Re: Lost USB

Quoted text here. Click to load it

In a USB2 system, it should tell you that you have twice as many ports than
physical connectors (though not all the physical ports may be brought out to

In your case, it sounds as though the high speed USB system if faulty in
some way.  Either the high speed root port or root hub or maybe even
something wrong with the driver.

Site Timeline