Intel 4965agn PCIe + weird WiFi slowness

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
This is totally new and weird, with too many variables for my pea brain.

Have a home network that runs fine -
DSL line with Linksys BEFSX41 router

Wifi is only 802.11b using an old Linksys WAP11 access point...
several XP laptops, desktops, Tivo, WET11 bridge + xbox360 all run fine

ok - new to the mix -
a Sony Vaio laptop with the Intel 4965AGN internal WiFi card.
This laptop is running Vista...

SO - fire it up and test a few things....
    Speakeasy speed tests
    Pingplotter tests

Weird #1 - rampup or TCP sliding window ?
Speakeasy - on one download test
    it showed starting 100k then ramped up to 2400k
    repeated tests just showed the same ramp-up to 2400k
Just turned off the WiFi, and plugged in an ethernet cable
    consistently at 2400k download - no ramp-up

Weird #2 - Pingplotter
using Pingplotter and also having a couple other WiFi laptops running PP
had them all ping one of our remote server sites.
All the other laptops - had no errors, no packet loss, etc
The Sony had from 3% up to 25% packet loss... almost like a repeating cycle.
Again - disabled the WiFi and plugged in the cable.... no errors - all good

SO - since both the WiFi and the ethernet cable have to go thru the same TCP/IP
it can't really be anything new that MS totally changed in the stack (they did
totally change it)
and it must be something strictly related to the WiFi world ???

Ideas ??

Re: Intel 4965agn PCIe + weird WiFi slowness

Quoted text here. Click to load it
Quoted text here. Click to load it
ok - more weirdness -
I had already :
    in the protocol screen, unchecked IPv6
    in the adapter properties, Disabled N-mode, Enabled B/G mode

then - for grins, tried just Enabled B mode
Ran the PingPlotter - no errors !
ok - control case - go back Enable B/G mode
Ran PP again... expecting errors... BUT - NO Errors !

hmmm -  rebooted, running PP now, and NO errors.
So, I'm not sure what changed, as the packet loss testing was for the past week,
and now, all of a sudden, on this single Vista laptop - it WORKS !

Re: Intel 4965agn PCIe + weird WiFi slowness = power saving mode

well - I think I found the problem....
I had the Sony Vaio upstairs,
running PingPlotter in the background all morning while it was charging....
    NO errors or lost packets.

I unplugged it, and brought it downstairs to the family....
things were a little sluggish on the net,
so I looked at PingPlotter - LOST PACKETS again.
hmmmm - what's different ??

DING !!!! - the power saving mode

Click on the Vista battery icon and go look at all the power settings.

There is one area of Advanced Settings where it kinda looks like Device Manager
with lots of "+" boxes to expand.
One of the "+" boxes was for the Wireless Adapter ->
    currently set for Medium Power Saving

hmmm -
Changed to Max Performance vs Max or Medium Power saving
and BINGO - no lost packets.

I'm guessing that maybe the WiFi card was being powered down between Pings,
and was maybe loosing the initial sends/replies... I don't know exactly
BUT - now, I am using the same battery profile for "max battery"
only with the Wireless Adapter now set to Max Performance to keep it powered

Quoted text here. Click to load it

Re: Intel 4965agn PCIe + weird WiFi slowness = power saving mode

P.Schuman typed on Thu, 13 Sep 2007 13:06:01 -0500:
Quoted text here. Click to load it

Good show Schuman! :D


Re: Intel 4965agn PCIe + weird WiFi slowness = power saving mode

Quoted text here. Click to load it

I saw something similar with a Gateway laptop that uses a Realtek
chip on mini-PCI card for wireless.  While web browsing, it would often
fail to load a page or part of a page, yet refreshing would generally
get the data.  All other machines in the house were having no problems
while using the same access point and cable modem.

As soon as I disabled power saving (via the Realtek utility), the
dropped packets went away.

To be fair to Gateway, they don't provide any visible way to enable
power saving and get the system in that state.  I had disabled the
wretched Microsoft "zero config" wireless connection manager and
installed Realtek's utility in its place, and that's where I found the
power saving option, tried changing it, and then forgot about it for a


Re: Intel 4965agn PCIe + weird WiFi slowness = power saving mode

Dave Martindale typed on Fri, 14 Sep 2007 15:08:18 +0000:
Quoted text here. Click to load it

Wow that is weird. I have two HP ADM desktops (the same model) that one
quit working from any wireless card or the Ethernet built in to the
motherboard. Swapped drives and cards between them and then both quit
working with the network. Tried at least three different wireless cards
and it is a no go.

The only thing that makes sense is the original wireless card went bad
and had taken something out on both motherboards. I don't know. I
scrapped one for parts and the other works with HomePNA USB believe it
or not. That and the dialup modem are the only things I can get to work
to get Internet access on these two.


Site Timeline