Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I just purchased a used IBM 375XD which seems to be working properly.
The battery in it was old and I replaced it with a new one. My problem
is that I charged the new battery for 18 hours and the light stated
that the battery was charged. I start the computer on battery and
nothing happens. It doesn't start. Then I plug the AC cord in and it
boots up but the battery light turns from green to amber almost
immediately. I can't find if anything is turned off or what the
problem might be. Can anyone help?

Re: IBM 375XD

First check battery connection with laptop. Second if it possible check
battery cells (if they in property state - charged or no). It should have
something about 3,7V per one cell. If there is everything good. You schould
look for some electronic damage on battery. If battery is good maybe charger
it's damaged (that electronics in laptop).
Sorry for my english :D

Re: IBM 375XD

On Fri, 15 Jul 2005 21:40:14 -0700, wrote:

Quoted text here. Click to load it
do you not mean 365XD???

Re: IBM 375XD

On Mon, 18 Jul 2005 20:47:47 GMT, (MG)

Quoted text here. Click to load it

If he DOES mean 365XD then well, I have one of those that I've owned
since it was new, and that sounds exactly like the problem I have with
old batteries. I think that he just got a worthless old battery
someone sold him as "new". If you can, just get that battery exchanged
for a good one.
Charlie Hoffpauir

Site Timeline