Gericom Laptop DVD will not eject

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I purchased a Gericom Ego laptop from Aldi in the UK in December 2004.
All was going well until a couple of months ago when I tried to install
Suse Linux from a boot DVD. The install failed when trying to 'mount'
the CD drive. My only option was to restart the machine...

Following this, the internal DVD drive failed to work correctly.

Windows still recognised the DVD drive as the D: drive and displays all
the correct driver details. However, I could not eject the DVD drive by
pressing the eject button or through right-click eject in Explorer. The
only way I can open the drive is via the manual eject on the drive
itself. Even so, Windows fails to recognise the presence of a disc when

I therefore sent the laptop away to Gericom, only to have it return
with a replacement drive that still doesn't work (i.e. the drive still
fails to eject and read DVDs)

I need the laptop for work at the moment so I don't want to send it off
for repair again. Is there any way I can try and fix the drive myself?
Or are there any procedures I could go through to narrow down what the
problem is?



Re: Gericom Laptop DVD will not eject wrote:

Quoted text here. Click to load it
I certainly don't know what to do. I would probably remove the DVD in
the device manager, reboot, and let Windows re-install it.

Site Timeline