Fujitsu C series 2010C Notebook

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

I have read some previous postings regarding this topic - however,
still can't
solve my problem!!  I added more memory to my Fujitsu
2010C laptop.  I had to
lift the keyboard to do this.  I had
difficulty getting to keyboard off -
possibly damaged it at the
bottom edge??  Is this possible??
After installing
the memory, a few keys do not work - the s, t, 7 , `
=, /, and the comma
key...and either the CTRL or ALT CTRL
ALT DELETE doesn't work either.
I have look at the motherboard where
the ribbon attaches to it.  I have read
your past postings on how to
remove this connection from the motherboard - but I
still cannot
figure out how to move this connection.  I have tried reinstalling
the driver several times.  I have tried blowing/cleaning under the
everything.  I have taken it apart and tried checking all
the connections...but
the same keys don't work each time.  I'm afraid
to work with the motherboard
connector - that I might break something
on the board.
I recently ordered a new
keyboard and want to install it myself....but
want more information on the
motherboard connector.  Can someone give
me some information on how to do this??
 Or maybe some other options
to try to get these keys to work??

Site Timeline