Flash Drive Doesn't show up in Exporer

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I just restored the XP pro OS in my Thinkpad R40 from the (onboard HDD)
restore file system, and now I can't get any flash drives to show up in
Explorer, which I use for moving files around.  Everything else works
perfectly: both USB ports work for other devices, all three flash drives
(different kinds and sizes) work fine on other machines, and the computer
can access the flash drive from Control PanelAdmin tools/Computer
Management, etc. but it just won't show up in the Explorer window.  Device
manager shows it as working properly.  I have Adobe Elements 3 installed and
when I plug the drive in, the program fires up and starts scanning any image
files on the flash drive.  The external drive icon shows up in the Task Bar.
Everything works fine except Explorer, and even that worked fine before the
OS restore.

I've tried going into Device Mgr and uninstalling the driver, allowing it
reinstall after a reboot, but still no listing in Explorer.  When I do this,
I get the expected messages that the drive is installed and working
properly.  It appears that the problem lies with Explorer, not anywhere
else.  I would re-install Explorer, but I don't know how (I don't see an
Explorer option in Windows Components Wizard).

I'm at my wits end on this.  Any ideas on how to fix this?

  - Magnusfarce

Re: Flash Drive Doesn't show up in Exporer

try updating XP.

Quoted text here. Click to load it

Re: Flash Drive Doesn't show up in Exporer

I did that as part of the OS restore.  Not every little update, of course,
but most.  Is there a specific update you had in mind?

  - Magnusfarce

Quoted text here. Click to load it

Re: Flash Drive Doesn't show up in Exporer

I have the same problem when I plug a flashdrive in a Toshiba.   I have
to reboot after I plug it in for it to show up in Explorer, unless, of
course it is already plugged in before I boot up.


Site Timeline