Corrupt laptop BIOS?

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Hi all,
I have a Tiny (rebranded Mitac 8375 from what I can figure out) laptop
about 3 years old - Tiny having gone bust for the second time, but
immaterial anyway as I'm living in Nepal so am about as qualified as
anyone else here to fiddle with it! Had been
having a few problems with powering it on if I had to hold the power
button down to switch it off (in some circumstances) - it wouldn't
power on again unless I would take out the main battery and put it in
again. Didn't think much of it as it was an easy workaround and only
happened occasionally.

Main problem started after I had put in a new main battery (old one
was only lasting 20-30 mins) - it charged up fine and I powered off
for the night. Next day wouldn't boot - hanging during or even before
POST - only way to power off was 5s on power button, main battery out,
main battery in - made no difference whether I used old or new
battery. I usually get just a blank screen with a flashing cursor and
keyboard seems unresponsive - caps lock/num lock (most of the time)
don't do anything, although if you put a cd in, the led comes on for a
bit. I have taken the HD out and only one SODIMM (of the two that were
in it), and have taken out the miniPCI wireless card to replace it
with a handy card which displays the POST codes, and have been trying
to get it to boot off CD.

Sometimes I have managed to get it through POST and start to boot off
CD but usually fails and displays garbage on the screen. The
diagnostic card doesn't seem to display consistent codes and in any
case I'm having trouble figuring out what they mean as they're not one
of the main providers (Insyde MobilePro Bios 4.00.01 v1.07). Other
thing is that if I try to go into the Bios setup by pressing F2, it
tells me that it "can't open resource module. Press a key to continue"
and when I do it hangs again with just the flashing cursor.

Hence my feeling that the Bios is corrupt - I hope to be able to
download a Bios file from the Mitac web site (
and burn onto a bootable CD (don't have a floppy), but I'm not
convinced that I'll be able to boot that far. A second opinion would
be appreciated to help me decide whether it's worth trying to source a
replacement mobo on ebay or just to give up on it and salvage (and
hopefully sell) what I can from it.

Thanks for any advice,

Note: to email me, replace the first part of the email address (before
the @) with my username (adrianwb).

Re: Corrupt laptop BIOS?

adrianwb wrote:
Quoted text here. Click to load it

I'm gonna get flamed for being an idiot, but here's my story.

The compaq Aero 4/33 laptop has a design flaw that lets the bios chip's
write line float.  A large number of these machines ended up with corrupt
bios'.  Symptoms were similar to what you describe.

Theory is that the degraded chip won't read at speed any more, so
POST hangs.  If it ever booted, it seemed to run fine.
The chip plugged in, so you could pull it out, read it in
an EPROM programmer and write it back.  That fixed it until next time.
I fixed several that way.

You could download the BIOS programming software and bits.  If you could
ever get it to boot, you could use the flash program to reprogram
the chip in the machine.

Turns out that for this machine, you could put it in the fridge
overnight.  That changed the chip characteristics just enough to
get it to boot.  If you had everything ready and didn't dawdle,
you could get it reflashed before it warmed up.

I published this several times in the Aero newsgroup and was flamed
by everybody...well everybody except those who tried it and fixed
their machines.

YMMV, it's a completely different system.  And DO NOT put it in
the freezer, or you'll risk damage to the display.

What have you got to lose?

Return address is VALID!
Bunch-O-Stuff Forsale Here:

Site Timeline