Compaq Evo N1020V startup power

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Hoping someone may have seen this problem or have some suggestions as to try
and repair it.

My Compaq Evo notebook does not power up. When I press the on button , the
green 'on' led lights up and the HDD starts spinning as normal, but it
doesn't boot up the bios and simply shuts itself off again within about 5
seconds. I have 2 power supplies and 2 batteries and I have tested all of
them to confirm they're not at fault. I removed the HDD briefly to backup
the data and it's working fine. The local repair shop, without dismantling
it, suggested it might be a mainboard, cpu or power inverter that's failed.
Unfortunately an attempt to repair it will be over half way to the cost of a
basic new notebook with no guarantee it will solve the problem.

While I'm already resigned to upgrading to a new notebook, I just thought
I'd ask if anyone has has this happen or for any suggestions that might get
the old girl running again.

Thanks for any help...


Re: Compaq Evo N1020V startup power

Quoted text here. Click to load it

You can more or less guarantee it will solve the problem, given your
description. At any rate, once the shop has it in, they can tell you for
sure if it's the power supply component or the whole mainboard that needs
replacing (or the cpu).

A crucial question is "what made it go that way". Did you do anything?


Re: Compaq Evo N1020V startup power

What was the outcome of this?
My N1020v is doing almost the same thing.
Power led comes on, HDD led comes on for a second, then nothing.
After a few attempts (5-30 minutes of constant trying) it will boot
Did you just replace the laptop?

Site Timeline