Compaq Armada E500 won't fully recognize new HDD

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I just had a moderately used Compaq Armada E500 handed to me by my uncle
this weekend. "Celery" 600, 256-MB RAM, DVD, 10-GB, 8-MB ATI Mobility
AGP video, TV out, new battery... Not bad! Aside from a few minor
cosmetic glitches and a broken lid latch, it SEEMED to be okay... until
booted up and started testing it... "Head banging" and read errors
galore! Scandisk confirmed the worst: a few dozen bad blocks, and new
ones kept cropping up each time I ran scandisk. NOT a good sign.
Clearly, the 10-GB Hitachi was on its last breath.

Now, as luck would have it, I had an "empty" 10-GB IBM Travelstar
waiting in the wings (it used to be in my Thinkpad 600e, where a 20-GB
Toshiba now resides). After consulting with a few "maintenance"
documents (pdf) from Compaq/HP's site, I immedietaly effected the HDD
switch and then booted from a Win98 diskette to perform the requisite
FDISK, something I've done before without a hitch with three previous
laptops, including my current TP600. Well dagnabbit, The laptop only
recognizes 7.5-GB of the drive--that's a full 2-GB unaccounted for. Now,
at first I thought maybe the laptop needed a BIOS flash, so I did that,
and tried again... Still 7.5-GB. Maybe the drive itself was screwy? I
mean, I hadn't checked it in months. So I put the drive in my TP600 (via
an Ultrabay adapter)--result: recognized correctly at 10-GB (FDISK lists
9.5-GB). Just to be 100% sure, I tried the drive in my desktop (via
laptop2desktop adapter and HDD rack). Same deal; all 10 Gigs accounted
for. Clearly, there's something wrong with this Armada laptop... Either
that or I'm missing some key installation step(s) particular to this
line of Compaqs. I even did the HDD swap with the battery removed, and
that didn't help.

I peeped into the laptop's BIOS (if you can call it that), and there
isn't much in there in the way of configurablity (not that I expected to
find anything). I also did a bit of Googling and I couldn't find any
reference to problems even remotely similar to this one. Any ideas? Is
there some hidden "clear" switch or jumper the needs to be tripped?


Re: Compaq Armada E500 won't fully recognize new HDD

EM wrote:
Quoted text here. Click to load it
i seem to recall from way back that there is a 8gb limit for fat16, or
something there abouts.

Site Timeline