Clevo M670SRU

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I've been given one of these that is dead.

When you press the power button the power light flashes green once and
that's it. No fans, no disk, no screen, nothing.

With a charger plugged in the battery light shows green i.e. it
thinks the battery is fully charged.

Checked the battery with a meter and it looks good.

I guess it's either a power supply fault or something dragging one of
the power rails down.

I'd like to get it going, but although I've built and repaired lots
of desktops I lack experience with laptops.

Any advice would be welcome.

Re: Clevo M670SRU

nick typed on Fri, 8 Jan 2010 18:13:17 +0000 (UTC):
Quoted text here. Click to load it

Hi Nick! It is the same as a desktop. Start pulling devices out, like
the hard drive, optical drive, memory, WiFi, etc. With any luck, it will
be one of them.

Say does it act the same running from the battery alone? Did you also
try running it on AC with the battery removed?

Is there a reset hole anywhere? Careful, if it has a built-in mic, don't
use a paperclip in the mic hole. As you would puncher the mic. And
pressing the reset is usually done without AC and the battery. Press on
hold and also press and hole the power button for 30 seconds or so. Then
give it a shot.

If all of this fails... it is either the AC adapter or the motherboard
most likely.

Gateway M465e ('06 era) - Windows XP SP3

Re: Clevo M670SRU

Hi Bill, thanks for your useful reply.  Please see update below.

BillW50 wrote:
Quoted text here. Click to load it
Well it turned out that the hard disk was U/S, but I think there's a
charging problem.

Quoted text here. Click to load it
Yes.  It won't run on AC with the battery removed, perhaps because I
don't have the right adapter.  Tried to run it from a bench supply good
for 15V at 4A, or 19V at 1A.

Quoted text here. Click to load it
Can't find any reset.  The only reset mentioned in the manual is the one
for the BIOS settings.

Quoted text here. Click to load it
Agree.  Before I invest in a proper adapter here's what I did today.
Since the battery wouldn't charge in situ charged the battery
externally from the bench supply; about 1A for 3 hours. Refitted the
battery and the machine went through POST and then tried to boot;
that's how I found the hard disk was U/S.

Rebooted from an Ubuntu CD and everything worked.  Plugged in the bench
supply and the machine was drawing about 3.5A, but none of it was going
into the battery.  The charge LED was off, so I think the bench supply
was doing most of the work and the battery was making up the difference.
It ran over 5 hours like this.

Shut down the machine, but the charge LED stayed off.  Ran the battery
right down, then plugged in the bench supply.  The charge LED then comes
on after 10 seconds or so, but the current drawn is <100mA so it will
never charge.  How can the laptop know about the type of charger, other
than by sensing the voltage?

Bottom line is that the battery appears to be in reasonable shape, but I
can't charge it in the laptop.  When the machine is on it won't
charge from the bench supply, perhaps because it all needs more than 4A.
When the machine is off ditto because there's only a tiny amount of
current being drawn from the supply, probably none of it going to the

Do you think an adapter with the right ratings will help, or that
there's something wrong with the charging circuit inside?


Re: Clevo M670SRU

nick typed on Sun, 10 Jan 2010 21:32:33 +0000 (UTC):
Quoted text here. Click to load it

Hi Nick! Laptops if the supply voltage is too low or if it figures out
that the supply just doesn't have enough current. They will often refuse
to charge the battery, but work fine otherwise. So that could be what is
going on here. Charging the battery is often half of the total draw
while the laptop is on.

Why the charge light only comes on for about 10 seconds and a draw of
100ma is interesting. It could be the laptop is unhappy about the
voltage and waits 10 seconds before giving up. Although it could decide
something is wrong with the battery too. So I would keep this in mind as

Otherwise you are on the right track. I am assuming the 3.5 amp draw was
at 15v, eh? I don't know what the original one put out, but 19v at 3.5
amps is very common. My docking station has a supply of 19v at 6.3 amps.
Overkill for what I use it for. Although it supports much beefier
laptops than mine.

And you say you are charging the battery on the bench. Have you charged
lithiums before? As if you overcharge them or charge them too fast, they
will explode. It is usually recommended if you charge them without
safety circuits, to place them in some sort of metal container. Thus if
it does burst into flames, it shouldn't catch anything else on fire.
Plus don't throw water on it if it does. As I believe that only makes it

Gateway M465e ('06 era) - Windows XP SP3

Re: Clevo M670SRU

BillW50 wrote:

Hi Bill,

thank you for another great post.

today I am lashing up a 19V supply from 3 desktop supplies to see what
gives.  Anyway please see comments below.


PS: Is your email attached to this post good?  If so I'll take this
thread off the group, if that's OK with you.

Quoted text here. Click to load it
The adapter rating for this laptop is 19V at 4.74A i.e. 90W.
Presumably the adapter would be capable of running the laptop
and charging a completely  discharged battery.  So the current
split is probably 2.5A for the laptop, and 2A for the battery.  It's a
4Ah battery so the initial charge current would be C/2 which makes

Quoted text here. Click to load it
Not quite.  When you plug in the adapter the charge light is initially
off.  After about 10-12 seconds it come on (amber) and stays on for as
long as the adapter is plugged in.

Quoted text here. Click to load it
Yes 3.5A at 15V.  Been looking at adapters on ebay.  Thought I might
invest in a 19V 6.3A one so there's a bit of spare capacity.

Quoted text here. Click to load it
Yes I have done this before.  Thanks for the warnings though.

Re: Clevo M670SRU

Somewhere on teh intarwebs nick wrote:
Quoted text here. Click to load it

Clevo isn't a brand that I'm aware of, they're probably not imported into
this country. However a cursory Google tells me that model is a fairly new
one? Core2Duo CPU? All I can say is that some laptops are very smart. I have
two different size power adapters that fit this ThinkPad T60, a 65W and a
90W, both 20V.

The Lenovo Power Manager utility recognises which adapter is attached and,
if the battery is charging, adjusts the projected time to completeion
accordingly. Perhaps your machine is querying the power supply for a signal
and isn't getting one? I've heard that some newer laptops won't accept a
multi-voltage, multi-tip adapter such as I have as it doesn't 'identify
itself' as being genuine. (I'm sure I read that somewhere...)

"Give a man a fire and he's warm for the day. But set fire to him and he's
warm for the rest of his life." Terry Pratchet, 'Jingo'.

Re: Clevo M670SRU

~misfit~ wrote:


Quoted text here. Click to load it

Made in Taiwan

Rebadged and marketed in the US and EU under various names.

Yep, it's a Core2Duo, 2GB DDR2, 17" screen.  I though it was worth

Interesting that the ThinkPad knows which adapter is connected.  Dell
use an extra wire in the cable between the adapter and the laptop.
Perhaps the ThinkPad does something similar.

Quoted text here. Click to load it

I've had a close look at the power connector on the back of the laptop,
and there's only the plain old tip and sleeve, so no third wire there.

Hard to see how the laptop can know much about the adapter over 2 wires
except the voltage.

The battery is a different matter though.  Quite prepared to believe
that the battery is part of the problem.

But the laptop doesn't power up off the adapter with the battery
removed, so either the adapter isn't man enough or there's a fault in
the laptop.

The battery won't charge in the laptop, so I'm inclined to think the
charging circuit in the laptop is hosed.


Re: Clevo M670SRU

Somewhere on teh intarwebs nick wrote:
Quoted text here. Click to load it

Hey there,

It sure sounds like it is.

Quoted text here. Click to load it

Well bugger me! I have a Dell Latitude D610 here and had previously noticed
the thinness of the 'centre electrode' of the adapter and though it odd. On
checking it I see that there's a sleeve connector on both the outside and
inside of the plug. I just pulled out my spare T60 ThinkPad (65W) adapter
and it's the same (although the centre 'sensor wire' pin is a bit more
robust so I hadn't looked twice at it before.

You learn something new every day. (Especially when you get to my age and
you're forgetting things as fast as you learn them. <g>)

Quoted text here. Click to load it

Ahh, ok, so that's not it then. Worth a shot.

Quoted text here. Click to load it

Yup, although I wouldn't be surprised if there is a way.....

Quoted text here. Click to load it

That does sound like a reasonable assumption. (Some batteries, like this T60
for instance, have a 'CPU' in the battery as well as the one in the carging
circuit that controlls the charge rate etc.)

Good luck Nick.

"Give a man a fire and he's warm for the day. But set fire to him and he's
warm for the rest of his life." Terry Pratchet, 'Jingo'.

Re: Clevo M670SRU

Hi Bill

I put a desktop PC supply 12v (@13A) in series with the bench
supply set to 7v with a 4A max capability.  Measured the total output as
19.0v on a DVM.

Fitted the discharged battery into the laptop, Plugged in the power
supply and turned it on.

No change.

After about 12 seconds the charge light comes on amber but <100mA
is supplied to the laptop.

Laptop will not power up.  Power light blinks green once. That's all.

Would have thought the lash up supply would at least be capable of
charging the battery with the laptop switched off.

Removed battery.

Laptop still will not power up.  Power light blinks green once.  That's

Strange thing is that when I charge the battery externally and then
boot the machine with the power supply plugged in, it then takes ~3.5A
once the computer has started, presumably from the battery.  Although
the battery discharges eventually, all that current must be going
somewhere.  The load fluctuates as the CD is accessed, so I guess it's
powering the computer.

Do you still think it's worth buying a 19v 4.74A adapter (only 0.74A
more capability than my lash up)?

Or perhaps the circuitry between the power jack and the battery is up
the creek?


Re: Clevo M670SRU

nick typed on Mon, 11 Jan 2010 13:39:19 +0000 (UTC):
Quoted text here. Click to load it

Hi Nick! Ill be in and out today. And my email is good except you need
to change the KOM part to COM. Chat at you later.

Asus EEE PC 702G8 ~ 2GB RAM ~ 16GB-SDHC
Windows XP SP2

Site Timeline