Bizarre battery misbehaviour

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

I've just got myself a several-years-old Compaq Evo N400c from a friend. He
replaced the battery about a year ago, and says it always worked fine for
him. However, now the battery will only discharge to around 80% before the
laptop shuts off and will not restart until connected to the mains. It runs
fine connected to the mains with the battery in (at one stage I had 48
hours of uptime on it running on mains), and the problem appears in Windows
or Linux.

I have tried recalibrating the battery using both the Windows utility and
the BIOS options, but they both abort the calibration when it discharges to
around 80%. The HP/Compaq diagnostics program reports an "Unknown error
0,1,1". I left the battery discharged, out of the machine overnight, and,
on reinserting it, it charged up, but when it got to 100%, instead of
shutting off, it would just charge for a few seconds, then stop, and keep
on doing that until I removed the battery and replaced it.

The battery appears to be in good condition - it says there is about 2 hours
remaining at 100% and it lasts about 15-20 minutes before it cuts off at
around 80%, so I think the cells are fine, but I've got no idea what could
be wrong.

Ideas anyone?


Site Timeline