Asus M70VM-X1 BIOS stopping it working?

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

I tried installing an XP driver in Vista 'cos someone said it worked
and started getting constant "USB device not recognised" messages
(plural) even when i disconnected the Canon N1220 scanner.

So I restarted the computer and now this formerly working computer
wont get past the BIOS screen, showing ASUS in centre screen!  I can
esc into a POST Message which says it is initialising its USB
controllers but it wont get past that stage whatever I do.

The computer has an AMI bios 209 dated 04/22/09 and on the ASUS site
there is no newer BIOS though the 209 on the Asus site (for a similar
computer) is dated a few months later than the 209 which is already on
the computer.

To me this looks like a bios problem, at least at the moment;    and I
am now used to ASUS not having the latest drivers on their site. When
I got this computer the trackpad and NIC didnt work, wouldnt update
using the lousy ASUS driver update utility and wouldnt work until I
went to the Synaptics site and got the real latest drivers. The NIC
also wouldnt work until I had identified that the ASUS hardware
identification driver utility was identifying the NIC wrongly and
wouldnt work until I had taken the NIC cover off and got the name off
the card itself, (booted into a linux CD to cross-check) and obtained
the driver myself again.

Anyone got any ideas on how to identify an updated BIOS which will
work with this computer and which may flash from a CD please? I am
possibly faintly aware that there is a V224 BIOS out there on some
come-on pay-for-drivers site, which may or may not exist?  Or do I
just download whatever I find on some American Megatrends site and it
it is wrong, it wont install?

Site Timeline