AGP status disabled

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

I own a Thinkpad R50e 1834-NFG, with specs below:

Original description: P M 705, 256MB RAM, 40GB 4200rpm HDD, 15
XGA(1024x768) TFT LCD, Intel Extreme, 24x24x24x/8x CD-RW/DVD, Intel
802.11b/g wireless(MPCI), Modem(CDC), 10/100 Ethernet(LOM), 6 cell
Li-Ion battery, WinXP Home

my problem is that this thinkpad cannot "see" AGP.
see here:

as you can see agp is totally disabled (seems not existant), I've
tried nearly *everything* from modifying PCI IRQs to open up intel
..inf files, from formatting with 2000/xp to respect driver
installation order correctly, no way.
Intel's .inf supports agp, as we can see:

; **    Filename:  852.INF
; **    Abstract:  Windows* XP INF File for
; **           82852/82855 GM/GME/PM/GMV Memory Controller Hub

- under [INTEL_SYS]

- after
; AGP filters that sit on top of PCI



- under [Strings]
PCI\VEN_8086&DEV_3581.DeviceDesc="Intel(R) 82852/82855 GM/GME/PM/GMV
Processor to AGP Controller - 3581"

but simply this peripheral doesn't show up.
video card is a shared memory one, 64mb, and I've 512mb.

I've latest os upgrades, latest bios (2.02), latest embedded
controller update, latest directx, latest drivers, even tried with
those from ibm and intel, no luck..
what's wrong here? thanks in advance.


Site Timeline