Acer TravelMate TrackPoint not moving

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

Hi all,

An Acer TravelMate 6593g TrackPoint issue is getting a touch annoying.
I have spent numerous hours, probably days all together, trying to get
working. It just doesn't move. Not sure if TrackPoint is the Acer
term to use,
but at least on ThinkPads these are called exactly that.

This particular
TravelMate model has a Synaptics TouchPad and the
TrackPoint. Most of the time,
the TouchPad works just fine (when I
haven't messed up with its installation
also while trying to recover the
TrackPoint). And it follows the Fn+F7 pattern
to turn it off and on.

Despite of my Googling, I'm not finding any references
of anybody else
having this same issue. Nor drivers or any setup packages for
TrackPoint. It's like it didn't exist.

I'm running XP Pro SP3 with pretty
much all the recent updates
installed. Tried booting with Win7/Vista install
CDs, there on the
installer first screens TouchPad works but TrackPoint doesn't.
this mean it's a HW issue or that the installers don't load the
appropriate drivers?

A colleague of mine has exact same laptop and the
TrackPoint works for
him. Devices and software installations are about the same.
I'm running
VMware Workstation and many other apps that we might blame for this.

Basically I'm not sure if this is a hardware thing or not. Can't recall
sure if the TrackPoint ever worked after last XP-reinstallation.
Acer recovery
partition is gone, so cannot do the factory restore magic.
This particular
machine has been back to Acer repairs a couple of times
already, it arrived DOA
and most external connector ports died a few
months later (ethernet, dvi etc.
ports failed on the laptop body, but
worked through ezDock). Since that last
trip it's been pretty much
functional. Another one for the TrackPoint? Please

Anybody have the same problem? Any clues? Help greatly appreciated.


Re: Acer TravelMate TrackPoint not moving

It's most likely that the trackpoint itself is bad, or the connection
from the trackpoint (which is part of the keyboard) to the motherboard.
  This is NOT likely to be a software issue.

I'd follow the process to remove or at least lift the keyboard and
inspect the connection from the keyboard to the motherboard.  Normally
this is a "flex cable" (a flat ribbon cable) going into a "ZIF" (zero
insertion force) socket.  BE SURE that you know how to work the socket
before actually inserting or removing the flex cable.  Sometimes the
keyboard and trackpoint are in one cable, sometimes they are in two
separate cables (which may go into either the same zif socket or two
different zif sockets).

tonttu wrote:
Quoted text here. Click to load it

Site Timeline