Acer notebook DVDRW suddenly not working

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I have an Acer Aspire series 1680 notebook with an internal Slimtype
DVDRW SOSW-852S. I was using the drive without any problems for nine
months. One day, I was watching VCD in it and then it suddenly
wouldn't work in the middle of the video. After that, it won't read
nor write any kind of CD anymore. The Windows OS can still see it and
shows it as without any problems. I tried using a bootable CD in it to
check if it is the Windows driver but the CD won't boot either. So it
looks like a hardware problem.

I disabled the Windows hardware profile of the DVDRW drive. After
several days, I enabled it again and tried reading a DVD video on it.
It suddenly worked and set the region settings to the DVDCD's region
(region 3). Before, it never does this but this time, it
automatically set its region setting to the DVD's region.

When I tried reading other DVD videos from the same region, some
worked, some didn't. I tried reading DVD softwares, it can't read it.
I tried reading VCDs and software CDs but it can't read it either. It
could just read some DVDs from region 3.

So what's the problem here? Initially it seems its a hardware problem.
Then after sometime of being disabled then enabled, it seems to be a
software problem.

Please help! Getting it fixed from the service center is too expensive
for me.

Re: Acer notebook DVDRW suddenly not working

bobha wrote:
Quoted text here. Click to load it

It has failed. Replace it.

Alternatively, you can use a standard drive in an external enclosure,
either USB2 or Firewire, depending on what the laptop supports. has the drives and enclosures.  There are also external
drives preassembled in an enclosure also.


Site Timeline