svg image misbehavior on IE?

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

Hello. On one webpage I just worked out, I use svg (by using <object>)
for browser that supports svg (firefox), and give an <img> inside of
<object> as a fallback for IE.

The page looks differently between Fx and IE.

On Fx it's the correct look.

On IE, the object block should faile (IE don't suport svg)
<object type="image/svg+xml" width="310" height="70"
style="float: left; background-color: white"
data=" " >
<img src=""
alt="Real Softservice Logo" />

However, the browser does not correctly fallback. If I replace the
above <object> section with this
<img src=""
style="float: left; background-color: white"
alt="Real Softservice Logo" />

Then for IE the page look OK.

Question: for IE if svg is not understood, codesnip1 and codesnip2
should look the same, now they are not.
Is it possible to make IE render the page correctly, without having to
fall back to not to use svg at all? (for that particular page there is
no lose if I completely don't use svg, but I am just curious if it's
possible to still using svg, e.g. in case we used an animated logo and
then we wish to preserve the svg movie for browsers that supports it)

Re: svg image misbehavior on IE?

Wed, 11 Oct 2006 02:14:35 -0700Zhang Weiwuд

Quoted text here. Click to load it

This problem is cross-posted on comp.infosystems.www.authoring.stylesheet
and Spartanicus kindly answered it. It seems this is more of a css
question then HTML question, so I posted in the wrong group.

The workaround to this IE issue is to wrap a div around <object> tag and
apply style to <div> instead.

Site Timeline