hyperlinks to jpeg image fail on new server

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I have many webpages with thumbnail pictures.
Each thumbnail is a hyperlink to a large picture.
The HTML code is similar to this:
[a href="full/full01.jpg"][img src="thumb/thumb01.jpg"][/a]

Now this worked okay on my old server. I got a new webhost,
and now when somebody clicks on thumbnail, they do not get
the full-size image. Whether you use IE, Mozilla or whatever,
same problem. Everything else seems okay on new server.
e.g. the images in IMG tag display always.
When I click on a thumbnail and get a browser window lacking
the image, I tried page info. It shows type=image/jpeg and
the size in bytes and pixels. In fact all the properties are
the same as when I loaded the image from the old server
successfully. The browser options are set to load all images.
Actually I found one picture out of about 300 that did
display when I clicked on thumbnail. I can't see anything
different about HTML or the JPEG for this successful loner.
So could there be something misconfigured on my new server
that stops hyperlinked images from working?
If I type URL of the image into the browser (for old server)
then I saw the image.  But when I type in the URL for the
new server, it returns a page which is simply one line of
text being the URL I gave, instead of the image, e.g.

Re: hyperlinks to jpeg image fail on new server

Scripsit J(ohn|ane) Doe:

Quoted text here. Click to load it

You have grossly invalid syntax.
<blink><marquee><font size="7">If your excuse for a newsreader
interprets HTML markup in Usenet messages, get a real newsreader.

Quoted text here. Click to load it

Why does a forged name and an IP address instead of a domain name make
me suspicious? I guess it's just my twenty years or so with networking.

Anyway, longish babbling followed by the purported URL of an image, not
an HTML document, suggests that you cannot be helped (and you surely
don't deserve help).

Jukka K. Korpela ("Yucca")

Re: hyperlinks to jpeg image fail on new server

J(ohn|ane) Doe schreef:
Quoted text here. Click to load it

Maybe you have to many dots in your images.names.


Re: hyperlinks to jpeg image fail on new server

Rob Waaijenberg wrote:
Quoted text here. Click to load it

That would not matter, ypou could call the image
if you wish, "." are valid in a URL and the web does not use "extensions"

To OP, the problem with at least the above "No.149.jpg" is that it is
corrupted. You need to upload new copies...

Take care,


Re: hyperlinks to jpeg image fail on new server

Quoted text here. Click to load it
Quoted text here. Click to load it

I think the actual image files are corrupted. I tried retrieving
No.149.jpg and got the file OK.

But if I try to open it with display or the Gimp, I get an error message
about a "Bogus marker length".

On casual inspection with a binary editor it does look roughly like a
jpg file-- it says "JFIF" and "Adobe" near the top.

It may be that somewhere along the line something thought it was a text
file and converted "line-endings" from LF to CRLF or vice versa. This is
a good way to mess up a binary file. The one image that worked might
have been lucky not to have any line-endings in it, or only in places
where they didn't matter.

What are you using to upload to the server? If it's ftp, you need to
make sure the "binary" option is set.

Site Timeline