Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I have a problem that crops up on my computer on occasion.
I just tried to change the name of some files and I get the option to:

And even when I select ALL AS ADMIN, I am unable to change the name of
the file.
Can anyone tell me why this happens?  Or how to fix it?

I had a laptop destroyed in an MVA.  I took the HD out and installed
it as an external HD on my desktop.   Now, anytime I access the Hard
drive and I want to manipulate a file I have to select All As
Administrator.  Is there someway I can change the access on the HD and
do it once and have the change take?   When the HD was in the laptop I
never  had this problem.   Any advice on this issue would be most
appreciated.  I'd like to know why it dos this and how to fix it.

Also, on external HD, I have some audio files stored.
The HD is made by Western Digital and I ran their software check on
the HD and it passed all test.  Most of the audio files work fine but
on some of the files, when I try to access them with VLC I get the
following ERROR MESSAGE:

File reading failed:
VLC could not open the file "L:\E=Books    (AUDIO)  MOVE TO H
Drive\Sort & Move To H Drive\Carol Berg\Carol Berg - Flesh and
Spirit\Flesh and Spirit 01-17.mp3" (Bad file descriptor).
Your input can't be opened:
VLC is unable to open the MRL
Check the log for details.

There are never any logs in the Log Dir so that is of no help.  I have
tried other PROGRAMS to run the file but no luck.   Is there anything
you can recommend to help me trouble shoot this to see if it is the
file vs the drive?  I have pretty much reached the limit of my
troubleshooting ability with this issue so any assistance would be
greatly appreciated.  

Roy B


Roy Baldone wrote:
Quoted text here. Click to load it

It's got to be an omen, when two questions take me
back to the same reference on the same day...


     The following reserved characters:

     < (less than)
     > (greater than)
     : (colon)
     " (double quote)
     / (forward slash)
     \ (backslash)
     | (vertical bar or pipe)
     ? (question mark)
     * (asterisk)

L:\E=Books (AUDIO) MOVE TO H Drive\Sort & Move To H Drive\Carol Berg\Carol Berg - Flesh and
Spirit\Flesh and Spirit 01-17.mp3

When a file name has spaces in it, and you issue a command from the
command line, you place quotes around the whole path to it.

    vlc "Flesh and Spirit 01-17.mp3"

You do that, to prevent it from being interpreted as command
line options being passed to VLC, instead of a file name.

I generally try to avoid as many unnecessary punctuation types
as possible. I'm comfortable using - and _ in a file name.
I don't mind using spaces, knowing that later I'll need to
use double quote characters to "insulate" them on the command line.
But you won't find me using "&" in a file name, as that is a disaster.
The "&" is used to fork things, depending on OS used, and it
makes it a lot harder to construct a command. For example,
depending on OS, I might have to do something like this.

    VLC Sort/&Move.mp3

in order to turn the ampersand into a "literal" instance, and
to prevent the command line from stealing it.

I'm not particularly a lover of () in file names either.
As some OSes will interpret that as an attempt to separate
something. You really need to "trim down the character set"
and curb your enthusiasm a bit. In your mind, it may make
things less readable, but it also avoids sticky situations later.

So using my rules of "less is more", your file name becomes

L:\E-Books AUDIO MOVE TO H Drive\Sort and Move To H Drive\Carol Berg\Carol Berg - Flesh and
Spirit\Flesh and Spirit 01-17.mp3

Now, there's almost no way that can foul up :-)
If I'm in Command Prompt, I'll still need the double qoutes
around the whole path

    vlc "L:\E-Books AUDIO MOVE TO H Drive\Sort and Move To H Drive\Carol Berg\Carol Berg - Flesh and
Spirit\Flesh and Spirit 01-17.mp3"

and it should open. At least, the "bad file descriptor" isn't the
normal file permissions error. The tool is having some trouble
getting the file system to accept the request. It's also possible
something is wrong with the file system itself (material for
CHKDSK to repair).


Ownership is another thing.

Files have ownership and permission bits. It is possible to
do "Properties" on each level of folder in the path name.

Within a Properties dialog, it should also be possible to
repair what is messed up. Or, you resort to more powerful
commands, commands with recursive options, to correct
an entire tree of files and folders.


     itsmine.cmd     [file contains the following two lines]

     takeown /f %1 /r /d y
     icacls %1 /grant administrators:F /t


     itsmine "L:\E-Books AUDIO MOVE TO H Drive\"

Or alternatively, you can add the capability to your
right-click context menu. Each of these downloads
(there are two of them), is a ".reg" file. You
right-click the file, and the word "Merge" should
appear in your context menu. "Merging" the file
installs it. Changing the file name extension to include
.txt on the end of the filename, allows you to conveniently
edit the file, and have a look at the construction. Inside,
you should find references to "takeown" and "icacls".
The third download I did not mention here, is an alternative
version that leaves a black command prompt window up on the
screen, with the details of what was just done. I don't
consider that adds too much value, as the recipient of this
method, should generally be looking at the form of the
commands held inside it, anyway.






After you "merge" the first of those files, a "TakeOwn" entry
should be available in the right-click context menu. If
you use Nirsoft ShellExView, it's possible it will also
list the new entry that has been created. If you need
to remove the feature at a future date, that's when the
second .reg file comes into usage. If you "Merge" the second
file (right-click the file, select "Merge"), then the TakeOwn
entry gets removed from the right-click menu. You generally
tend to download both the installer and uninstaller for these
tweaks, when you find them, so you have "full control".

The uninstaller file in that case, removes either of the
installer files. There are three files total on that page.
Two are installers. One is for removal. I would take
one installer and one remover and store in my collection
of tools.

Now, with the installation details out of the way, some rules.

1) *Don't* apply that to the entire C: drive. While the
    temptation is there to "turn the computer into Win98",
    you could break something needed for Windows Update or
    for the installation of a Service Pack.

2) *Don't* apply that to the Program Files folder. The Program Files
    folder is owned by TrustedInstaller. The Windows folder is owned
    by the same owner. TrustedInstaller is a service and not a user
    account. You cannot log in as TrustedInstaller. You cannot
    set a password on TrustedInstaller. It runs as a service and
    it does maintenance on privileged locations on C:. And as far
    as Program Files is concerned, a program storing a preferences file
    in there, isn't actually getting to store the file in that
    exact location. The file actually ends up in a Roaming folder,
    and you're being tricked into thinking it is actually in Program

And as you move NTFS partitions, from one computer to another, its
possible a different SID (Security ID) is being used to mark
ownership of the files. Which could account for funny behavior.
If moving MP3 files between computers, you could use Windows File
Sharing, or you could use a FAT32 USB flash stick (sneaker-net).
The FAT32 USB flash has no permissions model, so it's a way
of "sanitizing" ownership. When the file is copied to the
second computer, the copy operation will assign your current
ownership, which will probably keep you happy on that computer.

So the things I would try, would include -

1) Removing punctuation characters of an ill-defined nature.
    There is a reserved character set. There are additional characters
    that cause grief on various command line invocations (require insulation
    or the usage of literal character insertion, to work). Try to cut
    down on the ampersands, question marks, parenthesis. Use a hyphen or
    underscore as separators. You can use spaces if you want, remembering
    to use double-quote characters when passing the path to a program
    on the command line.

2) Files have ownership ("Ray" or "Administrator"), as well
    as rights (read, write, modify, list or whatever). If improperly
    set, you may be prompted for administrator privileges (because the
    software thinks you want to override ownership). Or, you will
    just get an error 5 or an Access Denied. For example, attempts
    to access C:\System Volume Information, should give you an example
    of Access Denied. Using the TakeOwn shortcut is suitable for
    user data areas, but avoid trampling on system areas, the Windows
    folder, System32 folder, Program Files folder, and so on.

    If you see a "Read Only" bit on a folder, it does not mean Read Only.
    Do not mis-interpret a permissions problem, as being caused by that.
    The Read Only bit, when present on a *folder*, is there to indicate
    to the file manager, that the folder has "appearance customization".
    For example, your Music folder does not list the default file type
    and date. It adds new columns with headers like "Genre", to the
    columns. It attempts to add contextual information suited to music
    collectors (or at least, that's what some designer at Microsoft thinks).
    Attempts to clear the Read Only bit on a folder, will likely fail.
    And it's because they didn't put a flag in the design, for the purpose
    they wanted, so they "overloaded" the meaning. A "Read Only" indication
    on a file, might prevent it from being written to. But on a folder,
    as far as the user is concerned, the Read Only flag isn't something
    a user need modify or pay attention to.

When a command says "As Administrator", that's a subtle hint that
you don't own the file. And the software is tempting you to override
the permissions. If you start running your storage that way,
you'll be seeing that option, forever... You'll be playing Whack-A-Mole.
TakeOwn can be used to cause L: contents to belong to you,
but I might apply it to individual folders on L: first, until I was
comfortable with the outcome. For example, I don't really
want to change the permissions on L:\System Volume Information.
That's not my intention, when using TakeOwn. You can certainly
try applying it to all of L: if you want, but *please* don't
do that to all of C:. I'm not sure there is any script that
can put the permissions back. I understand the Macintosh has
some sort of permissions repair script, which applies reasonable
defaults to system and owner areas of a file system, but if such
a thing exists for Windows, it would probably do more damage
than good.

Just by me examining the contents (not changing) C:\System Volume Information,
I managed to trash my Windows 7 C: drive so bad, it could not
boot and it could not be repaired (used all three automatic
repair attempts). I had to restore from a backup image. It is
for this reason, that I recommend some caution with respect to
System Volume Information folders. I don't really know what I broke,
but I also know that I didn't change anything. I was being careful,
or so I thought. When that folder says "Access Denied", that's
a hint you should stay out of there. If I knew what
damaged it, I'd tell you :-)

Have fun,

Site Timeline