Trying to clone Lenovo Thinkpad R61i hard drive - cloned drive doesn't boot?

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I'm using Norton Ghost 2003 to clone an 80 gb sata hard drive (source)
to a 160 gb drive (destination) with both drives connected to a standard
desktop PC that boots Ghost from a floppy.

The source drive is from a Lenovo (IBM) Thinkpad R61i laptop.  The drive
is formatted as NTFS - the OS being XP.

I've cloned dozens if not hundreds of drives with various operating
systems using Ghost - and have never used more than the standard default
settings, and they've never failed to boot.  But then those were pretty
much all desktop systems.

So the first cloned copy I made did not boot.  The laptop just sat there
with a blank screen with the cursor flashing in the upper left-hand

Apparently there is something about the master boot record in these
thinkpads that is non-standard  - something about them being 4 sectors
instead of 1.

I did find something about using the -ib setting in Ghost:


The master boot record on affected systems is comprised of 4 sectors, as
opposed to the single sector expected by Norton Ghost. Since the boot is
dependent on coding contained in all 4 sectors, the system hangs when it
attempts to boot to the incomplete master boot record. A "signature
failure" error message may also be displayed.

Affected configurations

This symptom apples to any NetVista, ThinkCentre and ThinkPad system
using the WinPE Rescue and Recovery partition; as opposed to the PARTIES
partition used on NetVista, ThinkCentre and ThinkPad systems prior to


The Ghost documentation provides the solution. Use the -IB switch when
invoking Ghost from the command line or within a batch file. This should
be done on both the image creation. The command line syntax is, C:\>

So the second clone I made using the IB switch (which I did not invoke
via the command line but set it through the GUI after ghost was up and


The image boot switch copies the entire boot track, including the boot
sector, when creating a disk image file or copying disk-to-disk. Use
this switch when installed applications, such as boot-time utilities,
use the boot track to store information. By default, Norton Ghost copies
only the boot sector, and does not copy the remainder of the boot track.
You cannot perform partition-to-partition or partition-to-image
functions with the -ib switch

Using that option, the partitions were resized on the destination (as
they were using the default options).

The drive still did not boot.

I then tried again, using the -id setting:


The image disk switch is similar to -ia (image all), but also copies the
boot track, as in -ib (image boot), extended partition tables, and
unpartitioned space on the disk. When looking at an image with -id, you
see the unpartitioned space and extended partitions in the list of
partitions. The -id switch is primarily used by law enforcement agencies
that require forensic images.

When Norton Ghost restores from an -id image, it relocates partitions to
cylinder boundaries and adjusts partition tables accordingly. Head,
sector, and cylinder information in partition tables is adjusted to
match the geometry of the destination disk.  Partitions are not
resizeable. You will need an identical or larger disk than the original.

Norton Ghost does not wipe the destination disk when restoring from an
-id image. Geometry differences between disks may leave tracks on the
destination disk with their previous contents. Use the -ia (image all)
switch instead of the -id switch when copying partition-to-partition  or
partition-to-image. An individual partition can be restored from an
image created with  -id.

The partitions on the destination drive was not resized using this

The cloned drive still did not boot.

So has anyone successfully cloned a drive from a Lenovo / Thinkpad?  
What is so magic about them?

PS:  The destination drive I was using was originally formatted as
FAT32, and had a bootable installation of DOS on it (DOS 7.1).  The
laptop DID boot into DOS just fine.

Re: Trying to clone Lenovo Thinkpad R61i hard drive - cloned drive doesn't boot?

PC Guy wrote:
Quoted text here. Click to load it

This is why they invented "dd".

To start, run "dd --list" to get an overview of the labeling scheme.

Copy all of the first disk in Disk Management, to the
second disk in Disk Management. By not specifying a block size
and a count field, this command runs at 13MB/sec. If specifying
a block size and count field, the command runs 39MB/sec (3X faster).
The arithmetic product of block size and count, equals the byte count
of your smaller 80GB drive. That ensures it all gets copied. Those
numbers are not arbitrary, and you use factorization to select
good values. Disk drives only accept commands up to a certain size, and
I limit block size ("bs") value to 256KB or so. That's large
enough to encourage efficiency.

dd if=\?\Device\Harddisk0\Partition0 if=\?\Device\Harddisk1\Partition0

In any case, without working up a sweat, you can use the command
without blocksize and count, and it'll still work. It will just
be a bit slower. In my example, the "input file" device should be
smaller than the "output file" device, so no sectors get lost.
My 80GB drive would be "if" and the 160GB drive would be "of".

That tool screws up a bit with USB flash keys. It still doesn't
detect the end of a flash key properly. So if a flash key is the
source, then you definitely want to craft "bs" and "count" parameters.

For Windows 7, remember to elevate ("Run as Administrator") to
the Command Prompt window, so the "dd" program can work.

The purpose of the program, is to copy disks no matter what
goofy format they may have. Being a block level copy program,
it just doesn't care. And obviously, if you attempt to
copy something with "open" files, the results will be
unpredictable. The program will not necessarily allow
you to copy any old partition in Windows, but for a couple
of whole disks which are not the Windows disk, I think the
above sample command will work fine.

Since your Windows (OS) disk could be the first disk, the command
might be referring to the second and third hard drives. Double
check Disk Management, to make absolutely sure you don't
copy over top of the wrong drive. This command has to safeguards
of any sort.

dd if=\?\Device\Harddisk1\Partition0 if=\?\Device\Harddisk2\Partition0

If the disks have sector errors, that program is not hardened
like ddrescue. In which case, you'd use ddrescue instead. The
first read/write error that the Windows port of "dd" sees, it'll


Re: Trying to clone Lenovo Thinkpad R61i hard drive - cloned drive doesn't boot?

Paul wrote:
Quoted text here. Click to load it

I take it that "dd" was not written specifically to address the quirks
that need to be dealt with when cloning a Lenovo/IBM laptop hard drive?

Is DD known to successfully clone Lenovo/IBM laptop hard drives?
Can DD run from a floppy or CD?

I like to clone drives by connecting destination and source drives to a
PC that has booted *something* from either a CD or floppy.

Re: Trying to clone Lenovo Thinkpad R61i hard drive - cloned drive doesn't boot?

PC Guy wrote:
Quoted text here. Click to load it

You need to check to see if the drive is bootable. IOW; is flagged as  
bootable to the BIOS. So get a copy of G-Parted, have your disc  
connected to the PC with the real bootable drive, boot from the linux  
with G-Parted on it, read both drives, and post the results.
Easy peasy lemon squeezy.

    _____  ____  ____ __ /\_/\ __      _ ______   _____
   / __/ |/ / / / / // // . . \ \ |\ | / __ \ \  \  __\
  _\ \/    / /_/ / _  / \     / \ \| \| \ \_\ \ \__\  _\
/___/_/|_/\____/_//_/   \_@_/   \__|\__|\____/\____\_\

Re: Trying to clone Lenovo Thinkpad R61i hard drive - cloned drive doesn't boot?

PC Guy wrote:
Quoted text here. Click to load it

Please do the copy and get back to us.

In the time it takes to transfer the 80GB to the 160GB,
you could be done and tested by now. And then you'd
have something to curse about, if it didn't work.


There is no possible way this can screw up, short of
the disk having a Host Protected Area. You can use
a tool in Linux to test for that. Or, you can use
your noggin, do "dd --list" and verify the 80GB
drive has slightly more than 80,000,000,000 bytes.
They make the drives just slightly bigger than the
decimal equivalent of that number. If you saw
78,123,456,789 as a size from "dd --list", then the
drive bears further examination. Manufacturers are
very careful to make the drives the right size,
due to a class action suit some years ago.

Host Protected Area causes problems for a lot of tools,
and this is not a shortcoming on the part of "dd". On
my current computer, the SATA ports are blocked by the
BIOS, and I cannot do HPA operations on it (to remove
an HPA). Fortunately, the IDE port on my motherboard,
a JMicron, the BIOS designer for the code for that
chip, didn't lock out HPA. By using an IDE to SATA
adapter, I have successfully added and removed a SATA
HPA with my motherboard. In Linux, you can only do
one "HPA operation" per reboot, so it's *really* annoying

So do the "dd --list", and check the size of the 80GB
drive first. The number reported should be larger
than 80,000,000,000. And you want the destination
drive to be bigger than the source. If you needed to
copy the 160GB to the 80GB, that would take
some partition resizing as the first step.

There are definitely some funny disk drives out
there, so please don't go looking for a 528 byte
sector drive, connect it to the computer, and tell
me the program doesn't work. Yes, if you connect
a '54 Fargo to this project, it'll fail. For
decently new components, this should work just
fine. I use "dd" all the time.

On some OEM computers, the purpose of the HPA
is to have five primary partitions on the disk.
The BIOS "multiplexes" these, on demand. When
the user selects "Factory Restore", the BIOS
disables the HPA, modifies the sector 0 partition
table, and the recovery partition magically appears.
The door is closed somehow, perhaps on the next
regular boot. When the HPA is re-enabled, the
hidden partition is no longer accessible to the
computer. The HPA in that case, is used to hide
stuff from the user. It takes a bit of work,
if you're into forensics, to actually capture
the whole disk. And that's why if an HPA is
present on the disk, you might miss a recovery
partition. Not too many companies still use this.
And the HPA trap doors in the BIOS (lockout)
exists so malware can't hold you hostage (by
hiding the entire disk). I could be locked
out of my IDE drive, because it doesn't have
the trap door on it (if you execute one HPA
command, you can't execute any more after
that). All the BIOS has to do, is issue one
HPA-command-set command to the drive, to close
the door and stop OS level manipulation. And
my SATA ports are set up to do that.

Have fun,

Re: Trying to clone Lenovo Thinkpad R61i hard drive - cloned drive doesn't boot?

Paul wrote:

Quoted text here. Click to load it

So to re-cap:

Original hard drive from Lenovo R61i Thinkpad laptop (80 gb, sata,
Hitachi) and a slightly used 160 gb Samsung sata hard drive (both 2.5"
form-factor) are connected to the sata ports on the motherboard of a
generic desktop PC (Intel Q965 / ICH8DO chipset) with 6 on-board sata

Norton Ghost 2003 booted from floppy, disk-to-disk clone attempted using
default and then -ib and then -id options for a total of 3 clone
attempts, none of which booted when the cloned drive was inserted back
into the laptop.

Next, I tried Acronis True Image Server (circa 2005) from Hiren's Boot
CD v 8.7.  Told it to do an exact copy (no partition re-size).  Clone
did not boot.  Next tried Acronis True Image Home 2010.  Clone did not

Next, booted Gparted 0.8.0 CD, used DD command -> and the clone DID boot
the laptop into XP.

Approx. copy speed was 13.1 mb/sec.  80 gb copied in about 101 minutes.

What a pile of horse-shit.  Why or how on earth do these disk-cloning
tools fail to recognize the disk structure of one of the most ubiquitous
line of laptops and properly clone them is a crock of shit.  

So during this process a tangent issue came up.

The desktop PC in question did not want to boot from the sata CD-rom
drive unless I set the sata ports in the bios from AHCI to IDE
emulation.  Even if I booted DOS 7.1 from a floppy with all necessary
CD-rom parts (mscdex, cdrom.sys) the cd drive was not detected if the
sata ports were set to ahci.

WTF garbage is that?

Re: Trying to clone Lenovo Thinkpad R61i hard drive - cloned drive doesn't boot?

PC Guy wrote:


Quoted text here. Click to load it

It could be a BIOS-specific issue.

My laptop uses an Insyde-branded BIOS (they're a new company
of some sort), and it boots from the CDROM in AHCI mode. And
it's not a UEFI BIOS either, just a legacy one.

Desktop chipsets typically split their ports on the
Southbridge in two groups. There are two separate
controllers. When the chips SKU is a "cheap one",
the port 5 and 6 are not connected to the outside world.

    1,2,3,4 <--- Should support everything

    5,6     <--- Can be some weirdness in options here

You might check and see if another port choice makes
a difference. Load them up, starting from 1.


As a workaround, buy a motherboard with a Southbridge,
as well as at least one more storage controller chip.
On my system, I got a Southbridge (six ports), plus
a JMicron IDE chip. And the difference that makes is
important, in terms of flexibility. That way, I can
use different modes on the two chips, and have the
best of both worlds.

When I needed to perform HPA surgery, I was shocked
to find the Southbridge wouldn't do HPA (which is actually
a typical response), while the second chip would. And
that made all the difference.

If I'd had only the 6 port Southbridge on the motherboard to
work with, I wouldn't have had any fun playing with
HPA setups.

Even adding a PCI storage card, could give you enough options
to do whatever you wanted. Run IDE where necessary, and
run AHCI for the rest. Storage cards have a BIOS chip
on them, and the Extended INT 0x13 code in there, is
what the BIOS uses to boot from the card. It seems
a couple Promise cards, the flash memory is inside the
main chip, and so no separate flash device is visible.
Most other cards, you check for a BIOS chip, before you
buy the card (as it's proof it boots).


Booting from CD drive in AHCI mode (was: Trying to clone Lenovo Thinkpad R61i hard drive...)

Paul wrote:
Quoted text here. Click to load it

Everything I've seen during web-searching for the past 1/2 hour
indicates that it's really not possible to boot an otherwise bootable CD
in a sata optical drive when the BIOS has the drive's sata port
configured as AHCI mode.

In every place where I've seen someone "solve" this problem, they did so
by changing the mode from AHCI to IDE.

There is something I intend to check, which is booting DOS from a floppy
with ahci.sys in the config.sys.

ahci.sys can be found inside this:  sp39596.exe

Which can be downloaded from here:

Quoted text here. Click to load it

Funny you should mention that.

The desktop motherboard I was using has 6 sata ports, arranged as a
cluster (2 x 3) with no spacing between them.  So when plugging devices
into them, without getting a magnifying glass and a diagram of the board
layout I have no idea what each connector is.  When you have just a
single hard drive and cd drive, it usually doesn't matter anyways.

So during this cloning excercise, I happen to have the cd drive
connected to port-1 master (that's how it came up with ahci turned
off).  I had the 160gb destination drive connected to either port 3 or 4
and the 80 gb source connected to port 6.

But in that configuration, the computer took a long time to POST, and
ultimately didn't boot from the CD.  My first change was to unplug the
160 gb destination from port-3/4 and move it to port 5.  So the two hard
drives were connected to the last 2 ports (5 & 6) and it ran quickly
through the post and booted from the cd just fine.

So perhaps all previous cloning attempts left the boot record of the 160
gb drive in a weird state that was problematic for the bios when the
drive was connected to ports 3/4, but moving the drive to port 5/6 made
the bios happy for some reason.  So I left the drives connected there
and booted the G-parted cd and used DD to copy the 80 gb drive (hda) to
the 160gb drive (hdb).

One final note - the bios of the Thinkpad has the sata ports configured
as ahci, so both the original 80 gb drive (and now the 160 gb clone
drive) can boot correctly using that setting, which must mean that XP is
using an ahci driver.

Re: Booting from CD drive in AHCI mode (was: Trying to clone Lenovo Thinkpad R61i hard drive...)

I wrote:
Quoted text here. Click to load it

Although ahci.sys did seem to load and function correctly, it did not
allow CD-rom access from DOS:

AHCI Sata driver for dos
release 1.1 @D15e:0
2008 Intel corp

sata 8000FA00 index port D410 data port D414
Capabilities E320FFC5 HBA version 10100
Ports implimented 3F

Port 0 unknown, status = 20
Port 1 unknown, status = 11
Port 2 unknown, status = 11
Port 3 unknown, status = 11
Port 4 unknown, status = 20
Port 5 unknown, status = 11

No devices detected

Anyone know what those ahci sata port status codes mean?

So yes, the CD drive was connected to port 0, and the 80 gb drive from
the Lenovo/Thinkpad was connected to port 4.  

Are all sata optical drives created equal, or are some usable under ahci
- and others aren't?

Strange about this ahci bullshit:  I have 3 choices in the bios for sata
configuration (not for each port, but for all sata ports):  IDE, Raid or
AHCI.  When I select AHCI, I never see any POST stuff when the system
boots.  Is that normal?

Re: Booting from CD drive in AHCI mode

PC Guy wrote:
Quoted text here. Click to load it

Some CD drives were notorious for having proprietarty drivers. Panasonic  
comes to mind...try and get a dos driver from the manufacturers website?

    _____  ____  ____ __ /\_/\ __      _ ______   _____
   / __/ |/ / / / / // // . . \ \ |\ | / __ \ \  \  __\
  _\ \/    / /_/ / _  / \     / \ \| \| \ \_\ \ \__\  _\
/___/_/|_/\____/_//_/   \_@_/   \__|\__|\____/\____\_\

Re: Trying to clone Lenovo Thinkpad R61i hard drive - cloned drive doesn't boot?

PC Guy wrote:
Quoted text here. Click to load it

Yer welcome. Next time dont fuck around with Norton etc. G-Parted is the  
only decent partitioning tool around. Plus FREE!

    _____  ____  ____ __ /\_/\ __      _ ______   _____
   / __/ |/ / / / / // // . . \ \ |\ | / __ \ \  \  __\
  _\ \/    / /_/ / _  / \     / \ \| \| \ \_\ \ \__\  _\
/___/_/|_/\____/_//_/   \_@_/   \__|\__|\____/\____\_\

Re: Trying to clone Lenovo Thinkpad R61i hard drive - cloned drivedoesn't boot?

hwf wrote:
Quoted text here. Click to load it

Yea, but it's GUI partion editor doesn't seem to include an easy
disk-cloning interface.  I had to use the plain-old unix DD command to
accomplish what I wanted.

The G-parted UI probably would have fallen flat on it's face and
incorrectly dealt with the non-standard Thinkpad master boot record I
was dealing with.

Re: Trying to clone Lenovo Thinkpad R61i hard drive - cloned drivedoesn't boot?

PC Guy wrote:
Quoted text here. Click to load it could have used the GParted-Clonezilla live cd.

Quoted text here. Click to load it

Sure, why not.

-- ||
    _____  ____  ____ __ /\_/\ __      _ ______   _____
   / __/ |/ / / / / // // . . \ \ |\ | / __ \ \  \  __\
  _\ \/    / /_/ / _  / \     / \ \| \| \ \_\ \ \__\  _\
/___/_/|_/\____/_//_/   \_@_/   \__|\__|\____/\____\_\

Re: Trying to clone Lenovo Thinkpad R61i hard drive - cloned drive doesn't boot?

PC Guy wrote:

Quoted text here. Click to load it

Oh look, the nymshifter wants help.

Site Timeline