SATA drive installed, IDE not detected

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I just built a new computer and I'm having a problem getting the
secondary drive to be detected in the BIOS.

Here are the components:
Gigabyte GA-8I945PL-G motherboard
M/B Rev: Rev 1
BIOS Ver: F6
Intel P4 3.2GHz
1 Hitachi 160 GB SATA hard drive (primary drive) connected to SATA0 (C:
and D: partitions - WinXP on C:)
1 Hitachi Deskstar 7K250 160 GB IDE hard drive (secondary drive)
connected to IDE2 (jumpered to master)
1 Emprex DVD writer connected to IDE1

BIOS configuration:
Standard CMOS Features:
IDE Channel 0 Master [SATA drive]
IDE Channel 0 Slave [None]
IDE Channel 2 Master [None]
IDE Channel 2 Slave [DVD R/W]

Advanced BIOS Features:
First Boot Device Hard Drive; Second Boot Device CDROM;

Integrated Peripherals:
On Chip Primary PCI IDE Enabled;
On Chip Secondary PCI IDE Enabled;
x PATA IDE - Ch.1 Master/Slave (not editable)
SATA Port 0/2 - Ch.0 Master/Slave (not editable)
SATA Port 1/3 - Ch.3 Master/Slave (not editable)
On Chip SATA Mode Auto; Onboard H/W GigaRAID Disabled

When in this configuration the computer boots normally (presumably
because the secondary drive is not detected).
When I change the BIOS to IDE Channel 0 Master to Manual, On Chip SATA
Mode to Combined and Enable the GigaRAID Function to ATA here's what
I get:

Standard CMOS Features:
IDE Channel 0 Master [SATA drive]
IDE Channel 0 Slave [None]
IDE Channel 2 Master [None]
IDE Channel 2 Slave [None]

Integrated Peripherals:
PATA IDE - Ch.1 Master/Slave (editable)
SATA Port 0/2 - Ch.0 Master/Slave (not editable)
SATA Port 1/3 - Disable (not editable)
On Chip SATA Mode - Combined
Onboard H/W GigaRAID - Enabled
GigaRAID Function - ATA

The computer tries to detect the IDE drives for about 30 seconds, gets
to the where Windows would normally load and stops.  When I reboot and
go into the BIOS both hard drives are available in the Boot Order with
the SATA first but I can't boot from either drive.

I emailed Gigabyte's Tech Support and they said I needed the IT 8212
Raid controller driver, but after reading posts on this and other
forums it seems like I have to install it before the Windows
installation.  Is this correct?  Is there another way to install the
RAID controller now that I have WinXP loaded?  I'm not against
reformatting my drive, but that's several hours reloading
Do I really need the controller driver, or is it something else?

Gigabyte also said the controller driver is on the disk that came with
the motherboard, but I didn't see it.  I searched the Gigabyte
website and found "motherboard_driver_raid_ite_8212_win.exe"
which seems to be some kind of application.  When I extract the file
there is one folder called ITE_RAID with three sub-folders
(Application, Drivers, Linux).  Does anybody know what this is/does?  I
don't want to run it since I have a stable system running only the
SATA drive.

Also, I don't have an internal floppy drive, but I do have a USB
floppy drive.  If I have to reinstall Windows to install the controller
driver (using F6 to install the Third Party RAID controllers), will I
be able to use the USB floppy drive?

Here's some background on the secondary drive (not sure if it's
relevant, but...)
It was the only drive on an ECS K7VTA3 motherboard with an AMD 2800+
processor and is partitioned into C: (with WinXP) and D: drives.  I had
planned to use it as the only drive on this (Gigabyte) motherboard,
however when I installed it I got an "NTLDR is missing" error
(probably because it was going from an AMD processor to an Intel
processor).  When I put it back on the K7VTA3 I got a "DISK BOOT
Windows CD and tried a repair, but I didn't know what I was doing,
gave up, and went out and bought the SATA drive.

Thanks in advance for your help.

Re: SATA drive installed, IDE not detected

Quoted text here. Click to load it

Your Southbridge has four SATA ports and one IDE port, controlling
up to six devices. The ITE 8212 has two IDE ports, for a total
of four hard drives.

The best config, is any bootable IDE hard drive goes on IDE1
(which is the Southbridge hosted IDE port). If you have an IDE
optical drive, it should also go on IDE1 with the hard drive.
This is because the IT8212 has a poor add-in BIOS in most
motherboard BIOS files, and has tiny issues, like being
unable to boot from an optical on the 8212, unless the bootable
CD is loaded inside the optical drive, before you define the
boot order in the BIOS. That means the IT8212 is best used
for hard drives as a rule, unless you like to fight with your

The main BIOS screen should be showing room for six drives on
the screen. The Southbridge has two modes, known on other
motherboards as "Enhanced" (up to six drives on Southbridge,
bootable with no driver needed in WinXP or Win2K), or the other
mode is called "Compatible" (up to four drives of six possible,
meaning two drive positions are unusable, and no driver needed
for Win98/WinME plus any later OS). It sounds like you are in
the compatible mode, and only four drive positions are available.

On your motherboard, they are called "Enhanced" and "Combined".
"Enhanced" is the setting you should be using, and then six
drives will be visible. WinXP and Win2K have built-in drivers
suitable for working with the storage subsystem in the PCI
address space (something Win98/ME would not understand). The
"Combined" setting maps the storage subsystem into the I/O
space, and an older I/O address space driver works there,
as available in Win98 or WinME.

As for the unbootable drives, at this point I think I would
try a repair install on one of your drives. Whether the ITE
IT8212 controller is in IDE mode or RAID mode, it will need
an F6 installed driver. The Southbridge only needs a RAID
driver, if you are doing a "RAID Ready" install of one or
more disks (a precursor to doing a migration from a single
drive to some kind of RAID configuration). If you ever plan
on booting a RAID array on the Southbridge, then F6 installing
the RAID driver as part of a repair install now would help.
Initially, the RAID driver can work with one disk. Of
course, the BIOS has to be set up accordingly, selecting
either an IDE mode or a RAID mode, as appropriate for the
driver you are trying to install. If you have no plans
for RAID, then no driver is needed on the Southbridge.

On-Chip Primary PCI IDE [Enabled]
On-Chip SATA Mode [Auto]        <----- Try Enhanced for WinXP
PATA IDE Set to Ch.1 Master/Slave
SATA Port 0/2 Set to Ch.2 Master/Slave
SATA Port 1/3 Set to Ch.3 Master/Slave
USB Controller [Enabled]
USB 2.0 Controller [Enabled]
USB Keyboard Support [Disabled]
USB Mouse Support [Disabled]
Azalia Codec [Auto]
Onboard H/W GigaRAID [Enabled]  <----- Enabled to use IT8212
GigaRAID Function [RAID]        <----- Set to ATA for non-RAID
Onboard H/W LAN [Enabled]
Onboard LAN Boot ROM [Disabled]
Onboard Serial Port 1 [3F8/IRQ4]
i-Lock [Enabled]
Onboard Parallel Port [378/IRQ7]
Parallel Port Mode [SPP]
x ECP Mode Use DMA 3


Re: SATA drive installed, IDE not detected


Thanks for replying.
I tried your solution above and here's what I got:

With On-Chip SATA Mode set to Enhanced
x PATA IDE - Ch.0 Master/Slave (not editable)
SATA Port 0/2 - Ch.2 Master/Slave (not editable)
SATA Port 1/3 - Ch.3 Master/Slave (not editable)
As you can see channel 1 is not available.  I'm assuming the x before
PATA IDE means that channel 1 is detected but not available.

With On-Chip SATA Mode set to Combined
PATA IDE - Ch.0 Master/Slave (editable)
SATA Port 0/2 - Disable (not editable)
SATA Port 1/3 - Ch.1 Master/Slave (not editable)
In this configuration SATA Port 0/2 has been disabled.  Also, maybe I
wrote it down wrong earlier, but I'm pretty sure SATA Port1/3 was
disabled yesterday, not SATA Port 0/2 as you see here.  Should I change
the PATA IDE to something other than channel 0?

With On-Chip SATA Mode set to Auto (and the computer boots normally)
x PATA IDE - Ch.1 Master/Slave (not editable)
SATA Port 0/2 - Ch.0 Master/Slave (not editable)
SATA Port 1/3 - Ch.3 Master/Slave (not editable)
Here channel 2 is not available.

As you can see none of my configurations match the one in your reply.
You also said to enable the Onboard H/W GigaRAID to use the IT8212
controller driver.  Will installing the IT8212 make channels 1, 2, and
3 available?

Thanks again for your help.

Re: SATA drive installed, IDE not detected

Quoted text here. Click to load it

The way the BIOS screen works, is it treats the Southbridge separate
from any RAID chips like the IT8212.

The screen we are talking about here, shows the status of the
six possible disks on the Southbridge. In Combined mode, as
predicted, only four of the six possible disks can be used.
Combined must disable two of the disks, because on old computers
the Southbridge only had four drives, and "Combined" is trying to
provide an operating mode that supports old OSes and what those
OSes knew about.

I don't understand what the "Ch.0" means in Gigabyte's
terminology. The info on the left, the "SATA Port 0/2" makes
sense, because that is the kind of info printed on the motherboard
next to the connectors.

I expect "Auto" is the same as "Enhanced". I'm not sure how
the BIOS would be able to determine that the user was booting
from a legacy OS, so the "Auto" setting seems kinda dumb, unless
it actually examines the disk to see whether Win98 is on there.
And you just don't code a BIOS to care about the OS type.

If the computer is booting, then that is a positive sign :-)

I would plug the IDE hard drive and the IDE optical into
IDE1. Set one drive to master and the other to slave. Both
should show up in the BIOS window. (Putting the optical on
IDE1 is so the Southbridge is used for the optical disk.
The IT8212 historically is not a good place for the optical,
although according to ITE it should be. I don't know who
dropped the ball, whether the motherboards are using an
older ITE provided BIOS module for the IT8212, or ITE did not
test their stuff thoroughly.)

The SATA drive, I would connect to whatever Southbridge port
you can manage to get recognized.

You'll have to bear with me here, because the way the BIOS works
is different on your board, than on the board I use with an ICH5.
But they are still the same technical issues, in terms of whether
we are using the Intel I/O space hosted option or the PCI address
space option for a disk interface.

On an Asus board, you would have "Enhanced" and there was a separate
(in fact bogus) setting, for the drives. Of the three drive settings
they offered to go along with "Enhanced", two settings caused the
drives to run at less than their optimal disk transfer speed. Thus
only the "Enhanced" plus "SATA" setting worked well. But in that
case, all six possible disk drives were always supported.

In the equivalent of "Combined", you could disable the IDE cable,
or you could disable one pair of SATA ports or the other pair of
SATA ports. It could be that your "Ch.0" notation has something to
do with this, or at least the enumeration of the drives that
results. The end result, is there are three possible combinations
of four drives that could work in the equivalent of the "Combined"

So, I'm afraid I cannot shed more light on your problem of why
the SATA drive is not showing up. Your SATA ports are 3Gb/sec
capable, so it is not a jumpering problem on the drive. Sometimes
certain drives have problems being detected, but this is something
that Maxtor support will not be too helpful about (like if you ask
for a firmware upgrade to get the drive working). Testing the drive
on another computer would help, to eliminate a drive interface

If you want some background reading, this document explains how
the Intel Southbridges have managed to support disks without needing
to F6 install a driver. This document is for a chip (ICH5) that
has two PATA cables and a pair of SATA disks. Your Southbridge
is ICH7, and has one PATA cable, and two pairs of SATA disks. But
the issues are exactly the same, and there are three "logical
chains" of disks in both cases. All you would need to do, is
relabel the diagrams to make this doc applicable to your chip.

For a separate RAID controller, there are two aspects to the BIOS
screen. If you don't enter the BIOS, the IT8212 will have a
detection phase, if the chip has been enabled. With the
IT8212 enabled, the BIOS will take extra time, waiting for
the drives on the IT8212 to become ready. Then the BIOS will
extract the I.D. info from the drives and display it on the
screen (showing up to four entries). If the chip was in a
RAID mode, it might describe the disks as "arrays", according
to how you set them up.

To set up the disks, you have to "enter" the RAID BIOS by pressing
a special key combo. The RAID BIOS is only "armed" if you put the
IT8212 into "RAID" mode in a previous session in the BIOS. Then
when you press the special key combo, the RAID BIOS screen will
appear. This is the screen that allows you to set up RAID 0
or RAID 1 arrays. The RAID BIOS screen commands the writing
of meta data (the reserved sector) on each disk, so in the
future, the controller knows the disks are in an array, and
which disk is which.

If the IT8212 is in vanilla ATA mode, then only the detection
phase should be working. Then, your hard drives (or opticals
if you are brave enough to use them on the IT8212) would be

So the IT8212 is handled separately from the screen used to
show the six disks on the Southbridge. The detection phase
only happens once you exit from the BIOS setup screens.

I took a look on the BIOS page, and I don't see mention of any
bug fixes for disk problems.

I don't know how else I can help you.

Are we basically arguing about a Maxtor that simply is not
being detected ? Like the motherboard works and all, but the
drive or cabling doesn't ?


Re: SATA drive installed, IDE not detected

Exactly,  the SATA drive boots normally when I have the BIOS set to
On-Chip SATA Mode [Auto].  But when I set it to either Enhanced or
Combined it doesn't boot.

I installed the IDE drive, jumpered as slave, in another case with a
different IDE drive, jumpered as master with WinXP, and it failed to
boot again.  So maybe it's a hardware problem.

Thanks again for your help.

Site Timeline