New Epox MB - why is my SATA drive so slow??

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
My Asrock Dual-Sata mamaboard bit the dust. Just replaced it with an Epox
EP-9U1697GLI (Socket 939 with AMD 3200+ Venice). Had to do a repair install of
XP to get things working again (with lots of driver installs of course.)

My Sata disk is a Hitachi Deskstar T7K250. I used FreshDevice for a hard disk
benchmark and was amazed at what happened: the read and write performance both
show about HALF the values for when it was in the Asrock - the performance is
now the equivalent of an old 5400 rpm drive!

The drive was already configured for Sata 3.0 using the Hitachi driver disk and
I double checked it after the new mb install. The Device Manager ULI Sata
Controller shows 3.0 GB/s and Enable Native Command Queue has been enabled.

I gotta be missing something because this board usually has excellent reviews in
the performance arena.

Any ideas where to look next?

Thanks -


Re: New Epox MB - why is my SATA drive so slow??

Quoted text here. Click to load it

Yeah, where to start looking is FreshDiagnose (orig. post misleading, Fresh
Devices is the developer)!

I ran HDTach, got very respectable results (186 Mb/s burst speed, avg read 52
Mb/s). Using the internal benchmark (Device Manager, Sata controller properties,
ULi settings, Test speed) gave similar results.


Re: New Epox MB - why is my SATA drive so slow??

zach wrote:
Quoted text here. Click to load it
Well done zach!

So FreshDiagnose isn't to be trusted here it seems.
Hope the rest of the job goes smoothly.

Graham W PGM-FI page updated, Graphics Tutorial
WIMBORNE Wessex Astro Society's Website
Dorset UK  Info, Meeting Dates, Sites & Maps
Change 'news' to 'sewn' in my Reply address to avoid my spam filter.

Site Timeline