New Audigy 2 and sound problems

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I got a new Audigy 2 from Creative, I tried the original driver from the
disc first and it worked fine.  Then I messed with all the settings and I
REALLY feel they need to do a redux so it functions flawlessly and is
UI friendly, I think it's rediculous as it is.  Completely unstable, as far
as actual sound goes.  The sounds just gets all messed up.

THEN I tried installing the "updates" from their site, and I get a message
that there is no sound card installed, of all things... anyone perfected the

SO... I uninstalled all Creative drivers and installed that BETA one that is
fully OpenAL for gamers, the one working now.  However...

when listening to live365 (which I pay for) or cable TV (ATI card) I get
very very little sound in right channels (using Logitech z560 4.1).  There
doesn't seem to be any realistic reason this is going on, but in the devise
manager there shows a problem:

"Other devises:  Multimedia audio Controller"
Location:  PCI bus 0, device 31, function 5, The drivers for this device
are not installed. (Code 28)  ...  and, drivers are unknown.

What can I do to correct all this?

not my site: /

WinXP sp2
Abit IS7 / 865PE chipset mobo
Intel P4 2.60C/HT, Thermalright XP-90 cooler, 92MM 57 CFM Panaflo
1GB kingston PC3200 dual channel RAM with heat spreaders
ATI X800XL AGP, Thermalright V-1 cooler with two fans
Maxtor 80GB /8MB IDE, Abit Serillel SATA adapter to board
Maxtor 40GB /2MB IDE to board IDE
Coolmax CR-550B (550 watts, single 140MM fan)

Re: New Audigy 2 and sound problems


Quoted text here. Click to load it

Clean all sound drivers out. Get the prog called nasty file remover
and have it clean out creative stuff. Once you are sure you have
purged your system of all soundcard drivers start the install from the
cdrom, select custom install and install the bare drivers only. Go to
creative website and use the autoupdater to update your drivers. You
should be good then.

Re: New Audigy 2 and sound problems

Quoted text here. Click to load it

I got it fixed all cool and good but THANKS for the reply to help!

not my site: /

Site Timeline