memory problem???

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I had a computer go into a pattern of restarts to the boot choice
screen but from there it could not go into safe mode and would
just reboot.  I pulled the harddrive and put it in another system
and did a chkdsk /f on it and fixed several problems.  Then it
worked fine.  I decided on a lark just to run memtest to see if
maybe a bad memory stick was the problem.  I got hundreds of
errors in a very short time.  That shocked me since the Kingston
sticks (2 - 512mb sticks) had been totally reliable for 3 months.

So I pulled one stick to find the bad one.  Again, errors right away.
So I swapped sticks just to make sure.  Again, hundreds of errors
right away.

So I stuck in two other sticks I have had.  Again, hundreds of errors.

What the heck!!!  So I pulled the memtest cd and started normally.
It starts fine and looks fine.

What could be doing this??

Thanks much!!!!

system spec's:   XP on ASUS A8N32-SLI with eVGA 7800GT
and AMD 64 X2  4400+ and Zalman P4 fan.  The mem sticks
are Kingston PC3200 400MHZ CL2.5 DDR

Re: memory problem???

On Tue, 3 Apr 2007 21:00:37 -0400, "jake"

Quoted text here. Click to load it

At this point it looks like you might have to do a lot of
checking of files, there could be significant corruption of
data, even OS files if you'd written (or moved, like
defragging the drive) any after the point the memory went

Had you ever checked the memory though?  Has anything
changed since then, hardware-wise?

Quoted text here. Click to load it

Since we don't yet know for certain if any memory had been
error free, it's a bit harder to advise.  Perhaps it was
barely stable when new and that slim margin is now gone.  I
assume you are running at the bios defaults?  If not, try
clearing CMOS, and check Asus website for any potential bios
updates that might address such a problem.

You might also try manually setting slower memory timings
(larger numbers), or first, a notch or two higher voltage,
especially if the memory is rated at higher voltage than the
board is using.

Quoted text here. Click to load it

What power supply?
What was the other memory?

Try temporarily underclocking by lowering FSB (and leaving
memory bus at same ratio, so it is then underclocked too),
and see if the errors persist.

Re: memory problem???

jake wrote:
Quoted text here. Click to load it

Memtest86+ makes some assumptions about the allocation of RAM.
The following is copied from the "Readme" file that accompanies
the memtest86 source code download package

*********** from the Readme ************

6) Memory Sizing
The BIOS in modern PC's will often reserve several sections of memory for
it's use and also to communicate information to the operating system (ie.
ACPI tables).  It is just as important to test these reserved memory blocks
as it is for the remainder of memory.  For proper operation all of memory
needs to function properly regardless of what the eventual use is.  For
this reason Memtest86 has been designed to test as much memory as is

However, safely and reliably detecting all of the available memory has been
problematic.  Versions of Memtest86 prior to v2.9 would probe to find where
memory is. This works for the vast majority of motherboards but is not 100%
reliable. Sometimes the memory size is incorrect and worse probing the wrong
places can in some cases cause the test to hang or crash.

Starting in version 2.9 alternative methods are available for determining the
memory size. By default the test attempts to get the memory size from the
BIOS using the "e820" method.  With "e820" the BIOS provides a table of memory
segments and identifies what they will be used for.  By default Memtest86
will test all of the ram marked as available and also the area reserved for
the ACPI tables.  This is safe since the test does not use the ACPI tables
and the "e820" specifications state that this memory may be reused after the
tables have been copied.  Although this is a safe default some memory will
not be tested.

Two additional options are available through online configuration options.
The first option (BIOS-All) also uses the "e820" method to obtain a memory
map.  However, when this option is selected all of the reserved memory
segments are tested, regardless of what their intended use is.  The only
exception is memory segments that begin above 3gb.  Testing has shown that
these segments are typically not safe to test.  The BIOS-All option is more
thorough but could be unstable with some motherboards.

The second option for memory sizing is the traditional "Probe" method.
This is a very thorough but not entirely safe method.  In the majority of
cases the BIOS-All and Probe methods will return the same memory map.

For older BIOS's that do not support the "e820" method there are two
additional methods (e801 and e88) for getting the memory size from the
BIOS.  These methods only provide the amount of extended memory that is
available, not a memory table.  When the e801 and e88 methods are used
the BIOS-All option will not be available.

The MemMap field on the display shows what memory size method is in use.
Also the RsvdMem field shows how much memory is reserved and is not being

If there is some disagreement between the BIOS use of memory, and memtest86
while it is testing, you might see errors. You might suspect something like
that, if the listed memory locations with errors, were limited to a small
range of addresses.

If, on the other hand, memory errors are spread all over the
address space, you'd have to come up with some other theory.

Another possible source of pollution, would be if some peripheral
device decided to DMA transfer to system memory, when it was not
authorized to do so. A defective chip could do something like that.
You might go into the BIOS, disables bits of hardware in the BIOS,
then run memtest86 and see if the memory situation improves. You
might find some device, that when enabled or disabled, affects
the memtest86 test results.

So you do have a few experiments you can run. And there is no
guarantee that you'll be able to figure out what is defective.

As Kony suggested, you can try changing memory timing, and see if
that helps. Memory timing or the Vdimm voltage can both affect
memtest86 test results, as can accidental or intentional overclocking.
You might see a fairly random distribution of defective memory
addresses with stuff like that.


possible source of problem

I did try unsuccessfully many times to install an older wacom
tablet.  It is connected via serial port.  I tried all three downloads
for that model but none worked.  I researched the problem and
found that others have had difficulty with this older model tablet.

Could that have caused the problem?

I will try to answer the questions tomorrow.  Right now I am
running Spinrite test just to check out the harddrive (Western
Digital Raptor 74G).

The PS is a 600 watt Xion.

Thanks for this help and ideas.  Is there another memory test
that you recommend?

Thanks again!!

Re: possible source of problem

jake wrote:
Quoted text here. Click to load it

I don't know too much about this one, but it is an alternative
to using memtest.


Re: possible source of problem

a flock of green cheek conures squawk out:

Quoted text here. Click to load it

The power supply for tablet working?


Re: possible source of problem

Quoted text here. Click to load it

Yes, and it works to a certain extent - just not perfectly.

Re: possible source of problem

finger to keyboard and composed:

Quoted text here. Click to load it

Model number?

Quoted text here. Click to load it

Try to narrow down the problem to hardware or software by running a
comms program such as HyperTerminal. Better still, I recommend Telix
for DOS, or Xtalk. You may need to choose a debug mode to be able to
see binary data.

- Franc Zabkar
Please remove one 'i' from my address when replying by email.

Site Timeline