interesting tale of a memory fault

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View


I thought you might be interested in a recent saga.. I've put together
a new PC in the last 2 months using an Asus A8V-E Deluxe motherboard,
AMD 64 3500+ and 2 sticks of Crucial Ballistix 512Mb non-ECC,
unbuffered, DDR400 memory.

Everything went together fine, system up and running, Windows XP
installed, harddrives (2X SATA 80Gb Diamondmax 9) partitioned as needed
etc. Suse Linux 9.2 64 bit version installed via ftp as well, no

I used the machine like this for a few days then started having
problems with web access in suse linux. I couldn't get any internet
access, ping anything etc. even though eth0 seemed to be correctly
configuring via DCHP. I really started to pull my hair out over this!
WinXP was fine all along.

As a last resort, I decided to try and reinstall suse 9.2 today. So I
booted from the mini-installation CD and as it tried to load the Kernel
(for installation) into a RAMDISK, it failed with 'crc error'. Oh
dear... I started to suspect faulty RAM, and ran memtest-86 on each
stick of crucial 512Mb in turn. Lo and behold, one of them had loads of
errors at 3 different address locations. I am now getting a replacement
from my supplier. Suse linux is fine! (although currently running at
512Mb rather than 1Gb)

How weird is that? Has anyone else had a similar experience!?

The worrying thing is that the fault may have developed since putting
everything together, because at first everything was fine. Is there any
reason to suspect any problem other than dodgy memory? I was running in
dual channel (128 bit) mode with one stick of memory in each channel.

Would appreciate any feedback or similar experiences.


Re: interesting tale of a memory fault

Quoted text here. Click to load it

Yes, quite frequently.

It's usual to test the memory before installing any OS ;-)


Re: interesting tale of a memory fault

Fair enough, I just think it strange that it all worked fine at first
(in fact, I installed linux over ftp) and then problems started
happening. now, I don't know if the memory was broken from the start,
but if it wasn't I'm worried... I haven't been poking around inside, so
I hope everything is set up ok. The bios voltages look ok (Vdimm is

Also, Crucial is a very good brand so I am surprised on that front..

Re: interesting tale of a memory fault

Dave wrote:
Quoted text here. Click to load it
i've seen bad memory...
even with the best name brands...

btw: even though memtest86 is pretty much the "standard" memory tester...
i;ve also found the microsoft memory test utility pretty helpful

Re: interesting tale of a memory fault

Suddenly, without warning, Dave exclaimed (3/23/2005 4:07 PM):
Quoted text here. Click to load it
I've had bad Crucial memory as well.  Didn't fail immediately; if I
remember correctly it was a couple of months down the road - once, of
course, it was out of warranty.


Site Timeline