definite power to motherboard, but its not powering up

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I got a new Abit Kn8 motherboard with an Athlon 64 3200, socket 939,
and just installed it in the case, attached all the cables, etc.  The
main problem is when i hit the power supply on nothing happens.  The
CPU fan does not come on, the peripherals do not power up and the big
fan on the power supply does not even come on.  BUT, an LED on the
motherboard that shows if it has power does come on and stays on as
long as the power is on, then turns off appropriately when i turn off
the power supply.  So obviously its getting power, but will not power
up.  Ive tried unplugging every non-essential peripheral device except
for the pci-express graphics card because theres no integrated video.
I also just tried unplugging the pci-express to try that out but still
no luck. The heatsink and cpu was installed by techs so i assume their
fine and the ram was also installed by the company i bought the
motherboard from so im thinking theres no compatibility issue.

I have the 20 pin power connected, the 4 pin one and the auxilary one
they recommend if im using pci-express stuff.  On a side note the main
power connector on the motherboard is a 24 pin one but my powersupply
is only 20 pins.  But the motherboard manual says that it is fully
compatible with 20 pin connectors and theres no problem using them, so
i dont think thats it.

Its been a couple years since i made my own system so im thinking
theres something thats probably obvious that im missing here and
forgetting to do.  Anyone have some ideas?

Re: definite power to motherboard, but its not powering up

Yup it was something very obvious.  I dont know if its true for all
motherboards but with trial and error i found out the kn8 has to not
only have the normal power supplies and such plugged in,, but you need
the case to mb jumper that sets the power to on or off also plugged in.

I was not aware of this.

Site Timeline