Asus PC-DL confusion

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Hi, I'm having no luck so far getting in touch with ASUS techsupport,
so I thought I might as well post this here to see if anyone had any
ideas. Thanks!

Product Type: Motherboard
Product Model: PC-DL Deluxe

Motherboard Revision: 1.05
Motherboard BIOS Revision: Unknown (mobo won't POST)

VGA Card Vendor: Diamond
VGA Card Model: Stealth 3D 2000 Pro (PCI)
VGA Card Chipset: Unknown
VGA Card Driver: N/A (card only used for test)

CPU Vendor: 2x Intel Xeon
CPU Type: Socket 603 (1x SL4WY, 1x SL5TD)
CPU Speed: 1.5 GHz

Memory Vendor: Samsung
Memory Model: PC2100R-25331-Z DDR ECC
Memory Capacity: 2x 256Mb

Problem Description:
Motherboard won't POST. Audio message either relays "System failed CPU
test" (with either of the Xeons in CPU1 socket, or both CPUs in both
sockets), or "CPU Not installed" with either in CPU2, or none

I have tried running with nothing plugged in except the two power
connectors (8 pin and 24 pin), the power switch jumper, speakers (for
monitoring BIOS messages), and the CPU/heatsink/heatsink fan. This is
with the whole thing sat on its anti-static bag, and no heatsink
retaining brackets installed (heatsink held on with gentle force).

The PSU I am using is a brand new 420W "Tagan TG420-U01" (the only SSI
PSU at my disposal). The heatsinks are "Akasa AK-680CU"s and the
thermal paste is Arctic Silver Ceramique Thermal compound.

As shown, the CPUs are 1.5GHz Xeons - a SL4WY and a SL5TD. The Asus CPU
support tool at only lists speeds as
far down as 1.8 Ghz for the PC-DL, but then the tool doesn't seem to
have socket 603 processors in the database at all. I was lead to
believe that a socket 603 1.5GHz Xeon would be forward compatible with
a socket 604 board (and I have elsewhere seen listings that the PC-DL
will go down to 1.4 GHz
processors). Is this incorrect?

Thank you for any help you can provide in getting this working! I am
quite disappointed that after all this money and effort it is not
working - I have often bought ASUS boards in the past and never been
let down yet!


The board was bought off Ebay (I think it was pretty new/unused), as
was the RAM, but the heatsinks and PSU were brand new.

As an aside to this, not to spark any controversy, but I don't think
it's too harsh to describe the Asus website as "pretty bloody
terrible". And the only way it seems possible to submit a technical
query - the form at - just
simply does not work. The first time you submit it it comes back with
"Server connection failure! please try again later" or something, then
the second time you submit it, it claims, in perfect Engrish, "Your
request already submit !". Ironically, this also means there is no way
to notify Asus about this webform problem (I have also tried emailing, which bounced back with "account has been closed"
message, informing you can only have techsupport if you live in the
States, and I've tried emailing - from which I've still
had no reply). If all else fails, I guess I'll have to try making a
long-distance call to their helpdesk, but I hate having to explain such
a technical problem over the phone!

Site Timeline