Asus P4P800-E Deluxe Ethernet Controller

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Hi all,

I have a very strange problem ... the Marvell Yukon 1Gbps onboard
ethernet on my brand new P4P800-E Deluxe motherboard simply won't
accept the drivers from the install CD.

This is the third system I have built with exactly the same motherboard
make/model and I've never had this problem before.  Indeed I've even
tried the driver CDs from those other two motherboards (the version
number printed on the CD was slightly different) but to no avail!

I have tried both pointing to the
\Drivers\Lan\Marvell\Windows\Driver\WinXP folder on the CD and
installing the Marvell Miniport Driver and pointing to the folder in
Program Files which contains the .inf but no joy either way.  I even
downloaded the latest versions off the Asus website for this
motherboard but in every case when I point to the relevant .inf it just

"The specified location does not contain information about your

Can anyone share any insights on this?



Re: Asus P4P800-E Deluxe Ethernet Controller

On 17 Dec 2005 08:10:08 -0800, ""

Quoted text here. Click to load it

I'll assume from a comment below that the OS is WinXP.  What
SP (service pack) level?

What, exactly, does "won't accept" mean?  How is this
manifested, apparent to you (the more details the better)?
Not trying to be pedantic but only you see this system.

Quoted text here. Click to load it

There are a lot of uknowns from our end at this point, so I
ask, are you sure the marvel controller is even enabled by
bios or jumpers?

Try removing all other cards and disabling other onboard
features, temporarily... any and all features non-essential
towards booting windows and using basic keyboard/mouse/etc
features .  Is there anything else in Device Manager that
looks wrong?

Quoted text here. Click to load it

Check Asus' BIOS update notes- maybe there's a bios that
addresses this.

You might also try the newest Marvel driver, not from Asus
but the chipset manufacturer.  The following appears to be
what you'd want,
or you can manually navigate through their driver selection

Personally, I wouldn't even bother with the older drivers,
rather trying newer instead.  Also see the *.txt and/or
*.HTM files in the ZIP file linked above for an installation

Site Timeline