Zip 250 USB drive not working under Win ME

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I have a Zip 250 USB external drive that I am trying to get to work. I
have a 1Ghz PC with Win ME and I tried using a Belkin USB hub at first.
I also dl'd IomegaWare 4.02 and the Win ME driver from the site. I
installed both and all my PC will do is show a Storage Device under
Device Manager. And in Device Manager there are no Settings for this
Storage Device so I can't manually assign a drive letter. I have
removed the Zip USB cable from the Belkin hub and inserted it via a USB
extension cable into one of my 2 USB ports. Still nothing. I have
removed the IomegaWare and reinstalled it but nothing. My other USB
accessories work so I don't believe that my BIOS settings are
incorrect. When my PC boots up the light on the Zip drive flashes and
the drive makes a brief whirring sound but nothing happens. I have
tried booting up with and without a Zip disk in the drive. I have
checked Control Panel repeatedly but there is no Zip icon there. At
first I was having trouble with my system recognizing my Belkin USB hub
but now I have all of the necessary drivers even though I no longer
have the Zip USB cable connected via the Belkin hub. I have also tried
the software that came with the drive but still nothing. That's why I
'upgraded' to the IomegaWare 4.02. Can anyone help? Bill  713-266-6518

Re: Zip 250 USB drive not working under Win ME

Kingwillard wrote:
Quoted text here. Click to load it
Win ME is notorious for being unreliable and unpredictable in handling
drivers for devices amongst other problems. Do yourself a favour and
upgrade to WinXP or even Win2k SP4, which is a leaner and more basic OS
than XP but very reliable and has full security facilities built in.

Re: Zip 250 USB drive not working under Win ME


Quoted text here. Click to load it
             Regards ,  SPAJKY ®
   mail addr. @ my site @
   4y - "Tualatin OC-ed / BX-Slot1 / inaudible setup!"

Site Timeline