xp professional doesn't shut off on Dell PC

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

Somebody gave me a Dell Optiplex GX 270 PC without a HD. I added a HD and
installed: XP  Pro + SP3 on it. Unfortunately, the PC doesn't shut off
automatically, as it should - also not after Restart. I opened the BIOS, but
didn't find anything useful to change or reset.

Any hints? Thank you very much.


Re: xp professional doesn't shut off on Dell PC

On 2/19/2011 5:57 PM, Petrus Tax wrote:
Quoted text here. Click to load it

A bunch of the GX270 were built with defective capacitors.  Inspect the
mother board for domed or vented capacitors.


Re: xp professional doesn't shut off on Dell PC

On 2/19/2011 5:57 PM, Petrus Tax wrote:
Quoted text here. Click to load it
As Grinder mentioned it could be a capacitor problem.

You may have a setting in the BIOS configured to tell the computer what
to do in the event of a power failure, remain off or power back on.  If
the last user had it configured as some kind of server application they
might have configured the motherboard to power back on.

If you have not tried it yet, a possible reset of the BIOS to factory
settings might clear out things as the Optiplex was not configured by
the factory to remain powered on after a power down.

You might also try booting a Live Linux distribution from CD like Puppy
Linux that can be found at:


If that can power down correctly then the problem is still in XP or a
combination of XP and a motherboard settings not yet identified.

Re: xp professional doesn't shut off on Dell PC

Hello Grinder and GlowingBlueMist:

Thanks very much for your suggestions. Not finding anything visibly wrong
with the MoBo, I checked the "add or remove programs" in Control Panel and
found that only SP 2 was there. Downloading SP 3 cured the problem (I don't
know why SP 3, not SP 2). This prompts another question to the specialist
like you: Is there a good diagnostics software program available that would
tell me about such hardware and/or software cases? (I am not a Linux user


Quoted text here. Click to load it

Re: xp professional doesn't shut off on Dell PC

On 2/21/2011 10:19 AM, Petrus Tax wrote:
Quoted text here. Click to load it
I'm not aware of programs that could diagnose a problem like yours.  A
software problem could cause almost anything imaginable to happen making
a good diagnostic program just about impossible to write.

Trying to duplicate the problem or symptoms using an alternate boot
source, like a Live Linux distribution or other operating system is one
way to help isolate a power on/off problem.  If a Live Linux CD can boot
and shutdown properly then the problem is 99% Windows software related,
if not then it usually remains to be a hardware issue.

I personally don't run a Linux system other than for training and for
correcting problems that appear to be Windows related.  I keep a couple
of Linux CD's around for testing problems such as yours or to remove a
Windows style virus using a Linux Boot CD with good anti-virus removers

Possibly in your case SP3 had tried to install and failed but did remove
or change something the system needed to correctly power down.  Running
the SP3 install again seems to have reset or reloaded the offending bit
of software.  While there might be log files that could indicate where
the problem was but at this time it's not worth the effort needed to
locate and go through them.

Just be glad you were able to resolve the problem with out having to go
through the time and effort of reloading the entire operating system and

Re: xp professional doesn't shut off on Dell PC

GlowingBlueMist wrote:
Quoted text here. Click to load it

The soft power function, is as far as I know, an item in the ACPI table
passed by the BIOS. If you disabled ACPI in the BIOS, then firstly, the
Windows installer disk would complain. The Computer entry in Device Manager
would say something like "Standard PC" instead of having the word "ACPI"
in the title of the HAL.

If you disabled ACPI in the BIOS, after the OS was installed, I bet
the OS wouldn't be happy about that at all :-)

If the GX270 wasn't ACPI compliant, we'd have heard about it by now.
Testing with the power button on the front of the machine (soft power button),
should tell you whether the PS_ON# signal is working or not. And if it is,
then it would be a real puzzle. Maybe the registry on the PC is scrambled,
and just the item for Soft Power is broken ? Or maybe the ACPI entry
in the BIOS is turned off ? Or maybe a "clear CMOS" with the power off,
is needed to clear any phantom bits in the CMOS RAM that are affecting
what the BIOS is passing ? Or how the BIOS behaves.

It's funny that installing SP3 would fix it. I would have thought that
a Service Pack wouldn't be an opportunity to change the HAL, or fix the
HAL, but maybe it can do that.

If I run the free version of Everest and get the hardware related report


this is an example of an ACPI entry. The BIOS passes a Plug and Play entry,
for the soft power function. What Windows actually does with this, from
a registry perspective, I haven't a clue. The values, like PNP0C0C are
standardized, and Windows is supposed to have a driver to connect to that
item. At least some of these, appear in the System section of Device Manager,
but with bogus names.

[ System devices / ACPI Power Button ]

     Device Properties:
       Driver Description                                ACPI Power Button
       Driver Date                                       7/1/2001
       Driver Version                                    5.1.2600.5512
       Driver Provider                                   Microsoft
       INF File                                          machine.inf
       Hardware ID                                       ACPI\PNP0C0C
       PnP Device                                        Power Button

In this thread, there is an example of things like that ACPI\PNP0C0C entry
for the GX270. The GX270 passes about 17 items in its ACPI tables.



ACPI Devices
ACPI\FIXEDBUTTON&DABA3FF&0                    : ACPI Fixed Feature Button
ACPI\GENUINEINTEL_-_X86_FAMILY_15_MODEL_2\_0    : Intel(R) Pentium(R) 4 CPU
ACPI\PNP0000&1506BB2E&0                       : Programmable interrupt
ACPI\PNP0100&1506BB2E&0                       : System timer
ACPI\PNP0200&1506BB2E&0                       : Direct memory access controller
ACPI\PNP0401&1506BB2E&0                       : ECP Printer Port (LPT1)
ACPI\PNP0501                                  : Communications Port (COM1)
ACPI\PNP0700&1506BB2E&0                       : Standard floppy disk controller
ACPI\PNP0800&1506BB2E&0                       : System speaker
ACPI\PNP0A03                                  : PCI bus
ACPI\PNP0B00&1506BB2E&0                       : System CMOS/real time clock
ACPI\PNP0C01                                  : System board
ACPI\PNP0C01\B                                  : System board
ACPI\PNP0C04&1506BB2E&0                       : Numeric data processor
ACPI\PNP0C0C&DABA3FF&0                        : ACPI Power Button
ACPI_HAL\PNP0C08                              : Microsoft ACPI-Compliant System
ROOT\ACPI_HAL00                              : ACPI Uniprocessor PC
17 matching device(s) found.

I think you could spend quite a while, trying to track down what's wrong.

Maybe somewhere between the Everest report and setupapi.log on the PC,
the answer is buried in there. Maybe if a PNP item no longer had a driver,
the setupapi.log file would have a record of the failure ?


Re: xp professional doesn't shut off on Dell PC

Hello GLowingBlueMist and Paul,

many thanks for your informative replies, which I will print out for later
reference. I check out, repair (if possible) and upgrade computers which are
being donated to a Caring Center in my church, then given for free to people
in need here in Chapel Hill, North Carolina (Go Heels!). Approaching the
(young) age of 80, I am getting very time-conscious so that I like solutions
to my problems that are manageable, especially time-wise. I am still
learning a lot, also from user groups, sometimes by osmosis. Any help that
this ACH group so generously provides can set me on a new track!
Occasionally I can contribute myself with some advice

Keep going and thanks!


Quoted text here. Click to load it

Re: xp professional doesn't shut off on Dell PC

Petrus Tax wrote:
Quoted text here. Click to load it

Sounds like you have more practical experience than we do :-) :-)

Good luck in your recycling efforts.


Site Timeline