Windows Installer SDK

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I am trying to install Activstudio for Windows software version 3.6.14
(Promethean software for an interactive whiteboard) on a computer with
Windows XP.  I get the following message:

Windows Installer
Invalid command line argument
Consult the Windows Installer SDK for detailed command line help.

I have never seen this message in the past when installing software on
this computer.  I would appreciate any assistance that you might
provide so that I can load this software successfully.



Re: Windows Installer SDK

Tom wrote:
Quoted text here. Click to load it

There is a component of it, that occasionally gets updated. For
example, I can see a version 4.5 offered here for Windows Installer.
This package would provide support for the third party software you're
trying to install. This might even get updated via Windows Update, so
you could be using the latest already.

But an "Invalid command line argument", means the parameters to some
program were detected by that program as being invalid. That probably
isn't an installer related issue, but a Promethean issue, and should
be taken up with their tech support.

On my computer, I can see C:\Windows\Installer, has some cruft
left behind by Windows Installer attempts. There are the .msi files,
which is presumably a Windows Installer file format. All the good
stuff, would be hidden inside the .msi. With my hex editor, I can see
that the stuff is not encrypted, and at least some text strings are
visible. But essentially it looks like code, so don't expect to
be able to figure it out.

In this article, they discuss creating a log file when the .msi is processed.

    msiexec /i MyApp.msi /l* LogFile.txt

So you can have some fun, while you wait for Promethean to
answer their tech support hot line :-) That assumes that
the installer is an .msi file.

I tried their KB.

This gives the usual kind of generic advice, such as checking the
Windows Installer version.

In a DOS box, I just tried "msiexec \?" to try to get a list of
command line options, and I got a dialog box instead, showing
the version of Windows Installer.

Using the version number, and running a search on the version number
string, I can see another site's suggestion for what to do. My
Windows Installer is ancient :-)


Re: Windows Installer SDK

I found a solution to this problem.  It was a software problem, not
hardware and nothing to do with what was actually being installed.  I
was able to solve the problem because I noticed some other symptoms:

I could not run Regedit.exe or Regedt32.exe (there was a message about
adding to the registry instead).

If I right-clicked My Computer ands selected Properties then nothing
happened (the System Properties Window did not open).

I found the solution to this last symptom here and this cured all my

'JSI Tip 5425. My Computer Properties does NOT invoke the dialog box
and other strange behavior?' ( )

In my case there was an extra " at the end of the exefile= response but
correcting the registry entry fixed all the problems including the
Windows Installer SDK error message.

Site Timeline