Wierd FTP interrupts

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Hi guys. I posted this in the Linux newsgroup and didn't get any joy.
To be honest I don't know if this problem is hardware or software
based, so I will try my luck here and see if anyone has encountered
this wierd problem before.

For some reason, a file transfer just stops dead after a while.
Sometimes it restarts itself after a random time. It appears to halt
transfer at random progress percentages.

I have tried WinSCP, WS-FTP and FileZilla. The latter two are unable to
establish a connection to my college PC. WinSCP can, but has the above

I've also downloaded pscp to try from the MS-DOS command prompt - same
problem with WinSCP. The download gets 'stuck' at some value and my
internet connection is 100% idle when it happens.

I get the same problem when I reboot my computer and use the "scp"
command from SuSE 9.2 (I have a dual boot machine). Connection starts
OK and then suddenly dies out.

Interestingly, I *still* get the problem while transferring files over
my home network's LAN. So I know it can't be internet traffic issues,
my ADSL modem or a dodgy network card.

I ran a continuous ping between my home/college PC and even though the
FTP connection stops, the pings continued OK. Occasionally though,
pings were lost (Request timed out). This happened about 1-2% of the
time. Not sure if the lost packets are related. My average ping time to
college is about 31ms.

This problem is driving me nuts, it I only managed to transfer a few
megabytes in two hours on an ADSL connection. The rest of the time the
connection is idle. If I want to download anything large I must babysit
the connection and keep on reconnecting.

Any ideas what might be causing the sudden stops of my file


Re: Wierd FTP interrupts

Random Person wrote:
Quoted text here. Click to load it

"...dodgy network card", bad ethernet cable, incorrect duplex setting on
the network card, bad router (if there is one, your description is
unclear).  My bet is the network card, but you imply that your lan is
separated from the internet - not using the same network card?

Re: Wierd FTP interrupts

Hi Quaoar. Thanks for your reply. I don't think it is the network card.
When I connect to the internet, I use an ADSL modem which plugs into my
USB port. On my home LAN, I use the integrated NIC on one computer an a
separate NIC on another.

If you have time, please take a look at my other post in the Comp Lang
Fortran newsgroup (another place I hang out). I posted more information
& pictures of the errors there. Seems people there are stumped as well


Site Timeline