Vostro 1520 notebook problem

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Dell Vostro 1520 notebook running Windows 7, worked fine around 2 years,
but today got problem: when tried power on, it not load windows, stay black
screen, and three active(On) indicators: numeric keypad icon(flashing),
caps lock and keylock symbols.
I tried unlock keyboard by by pressing keylock key, but this not help.
Laptop not load Windows, nor allow shut down it via pressing "Power"
button. I only can shut it down by unplugging power adapter jack.
Notebook was powered from AC power supply, as internal battery was removed.
I tried with installed battery, but after pressing "Power" button, it just
shut down after second or so.
Is this hard disk problem, showing hard disk failure?

Re: Vostro 1520 notebook problem

Quoted text here. Click to load it

Can you get it to boot into BIOS? On a Dell I believe that's by tapping F2
at bootup. Have you tried the F8 options like Safe Mode, Last Known Good
Configuration, or Repair Computer"?
Will it boot from an XP Recovery CD? A Hiren's Boot CD?

            -- I'm out of white ink --

Re: Vostro 1520 notebook problem

Quoted text here. Click to load it

No, I can no.
As notebook power on then off, just after a few seconds. No blue device
lights shown anymore, no post. But at first time, when this failure
happens, the device status lights showed LED error Codes in a no-POST
situation, which was FLASH-ON-ON, which described as possibly System board
error, according to Service manual:


Is there chance that this can be CPU failure, not motherboard?
How to determine exact Motherboard model Part number? Is it possible find
it without dissasembling laptop? I am wondering how much cost new
motherboard? Notebook was very light used, only at home.



Re: Vostro 1520 notebook problem

Binaryx wrote:
Quoted text here. Click to load it

The support page you quote, says this pattern...


is a memory error. Turn off the computer power, remove the battery, then
pull the SODIMM, then plug the SODIMM back in again, reapply power and test.

I don't believe in using abrasives on contacts like this. This is a
"gold on gold" contact system, where the computer industry standards
for gold plate thickness are woefully inadequate. You don't want to
scrape the gold off with an abrasive. If there was actual dirt, you'd use rubbing
alcohol and a soft cloth, and allow adequate time for it to dry, before
the module. The gold on some of these items is so thin, you can see pinholes in

It probably isn't an actual memory error, but you can remain optimistic,
and pretend that's all it is.

Be aware, that if some locations in low memory on the SODIMM are
bad, that may result in the system crashing and not being able
to flash the lights. I've had a desktop that did that, and
it wasn't until I removed the DIMMs and tested with no DIMMs
present, that I got a hint the memory was actually at fault.
(You can do that with a computer and it won't hurt it.)
The desktop can still sound the "bad RAM" beep pattern on the
internal speaker, if all the RAM is removed. So that's another
test case you can add to your tests. If removing the RAM
causes "ON-Flash-Flash" to reappear on the LEDs on the next
power up, then you'd have an inkling it's a bad SODIMM. If
removing the RAM and powering up, the symptoms remain the same,
then something else is wrong.

On my desktop DIMM, an entire chip was dead. Only garbage
data would come out of it, which caused the early BIOS code
some indigestion.

Some laptops have two SODIMMs, one under the RAM cover, but
another one hidden underneath the keyboard. Since you're good
at finding the tech info for your system, it shouldn't take you
long to find the picture with the SODIMM locations (in case there
is more than one). You'd want to remove *all* RAM to test - if
the system had two SODIMMs and you only removed the good one,
that would foul up your test result table.


Re: Vostro 1520 notebook problem

Quoted text here. Click to load it


No, diagnostic code I mention was FLASH-ON-ON, called "System board error",

I just shown notebook to repair service for quick advice, and he assumed
that it can be Northern Bridge faults, they can replace Northern Bridge,
but cost is not much different from new motherboard. He also tried to pull
out RAM then insert it back, but this not changed anything.


Site Timeline