usb stick recognized, but not accesable

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I have a Freecom Data-bar 512 mb USB stick, USB 2.0 flash storage device.
Until recently it worked perfectly. Since a few days it shows up in
Explorer, as removable storage (I guess that's the translation of the Dutch
"Verwisselbare schijf", but when I select the drive I get the error "There
no disk in the drive. Please insert a disk into drive" ("Dutch: plaats een
schijf of een ander geschikt medium in station ...").
I tried it on 4 different computers, all the same error. Win XP, Win XP Pro,
so drivers shouldn't be needed (and have never been, since the usb stick
worked fine before).
In the Control Panel, no error, the stick should work.

I tried several data recovery programs, but the usb stick just isn't

Is there anayway to retrieve the data on the disk?
Thanks in advance for your reply.

PS1: returning the stick to the vendor isn't an option, since it was a gift
and don't know where it was bought.
PS2: I already emailed Freecom Data-bar, but no answer so far.

The USB stick:

Re: usb stick recognized, but not accesable

Probably can't restore the data... but have you tried to format the stick?

For some reason I need to do this with my 256 MP3 player once in a while if
I load too much data up (224meg +)

Quoted text here. Click to load it
Quoted text here. Click to load it

Site Timeline