USB devices no longer detected, why?

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

MicronPC Millennia AMD Athlon upg to 2.13ghz
GA-7DX Rev 2.2
Windows XP SP2

Here is the chain events that led to the problem.  First, I have 2
different USB SAN disks and system always detected them when conn to front
of the tower.  I also had a USB Logitech web-camera and a USB Epson CX4600
all working fine.

The CX4600 had a known problem with the ink-cartridges, sw said it was low
or empty where it still have enough ink remaining.  I received a new
CX4800.  I then uninstalled all Epson sw, rebooted, and connected the
CX4800.  Inserted the new Epson CD sw that contained drivers & sw, but it
did not detect the CX4800.  Tried de/re-attaching the USB cable at the
printer end, system did not detect any new devices.  I also tried to conn
the USB printer to 2 other different USB ports, same problem.

I then tried to attach my SAN disks, still system did not detect any new
devices.  I detached all USB devices and only tried the SAN Disks, still
problem. It seems Plug n Play does not work or got disabled.

I checked Device Manager and it shows the following with no red/yellow:
  Universal Serial Bus Controllers
    - USB Root Hub
    - USB Root Hub
    - VIA Rev 5 or later USB Universal Host Controller
    - VIA Rev 5 or later USB Universal Host Controller

I then removed all 4 items above by clicking on it and choosing Uninstall.
 I reboot, it detects them but does not detect the SAN disk still
attached.  I tried the web-camera device alone, same problem.

What is happening, any suggestions??  THANKS!

p.s.  I attached the the SAN disks, Epson printer and webcamera to a
Gateway 500mhz system running Win2000 and it detects them.

Site Timeline