Unable to remove U3 software from a Sandisc Cruzer Micro

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Yesterday, I bought a Sandisc Cruzer Micro 8 gb USB 2.0 Flash Drive
(memory stick) at Walmart. The stick works good, but unfortunately it's
infected (as usual) with that miserable U3 virus. Well, that's what I
consider U3 to be anyway.

When I inserted the stick in my card reader, a message appeared
informing me that software had been installed.

WHAT??? I didn't give permission for anything to be installed! And there
is nothing on the sticks packaging to tell you that this would happen!

Specifically, the stick put the following files on my hard drive without
asking me:
C:\DOCUME~1\(my user account name)\Application Data\U3\

  C:\DOCUME~1\(my user account name)\Application Data\U3\(some long code
that I'm sure identifies the stick)\

        110,592  07-10-23  cleanup.exe
      3,493,888  08-05-02  Launchpad Removal.exe
      4,603,904  08-05-04  LaunchPad.exe
         58,842  07-10-23  Loading.gif
            328  07-10-23  Loading.htm
         78,576  07-10-23  LPHelp-ch.chm
         98,339  07-10-23  LPHelp-de.chm
        109,621  07-10-23  LPHelp-en.chm
         94,194  07-10-23  LPHelp-es.chm
         95,968  07-10-23  LPHelp-fr.chm
         94,331  07-10-23  LPHelp-it.chm
         90,017  07-10-23  LPHelp-jp.chm
         88,034  07-10-23  LPHelp-tw.chm
            475  08-10-30  lplog.txt
      2,129,920  07-10-23  LPSecurityExtension.dll
          1,901  07-10-23  LPSecurityExtension.dll.sig
         35,070  07-10-23  PelicanBusy.gif
             82  07-10-23  PelicanBusyPage.htm
        593,920  07-12-09  PelicanExtension.dll
          1,901  07-12-09  PelicanExtension.dll.sig
        544,768  07-10-23  SanDiskFormatExtension.dll
          1,901  07-10-23  SanDiskFormatExtension.dll.sig
         54,584  07-10-23  U3AccessGrant.exe
      2,600,960  07-10-23  u3dapi10.dll
        718,336  07-10-23  U3LauncherSetup.msi
              9  08-05-06  version.dat

  C:\DOCUME~1\(my user account name)\Application Data\U3\temp\

        110,592  07-10-23  cleanup.exe
      3,493,888  08-05-02  Launchpad Removal.exe

I tried going into the U3 Launchpad's Settings and then clicking on the
Uninstall tab and then the Uninstall U3 Launchpad button, but that only
started a process running in the background that did nothing and opened
no window.

I next tried downloading and running the uninstaller program from here:

http://www.u3.com/uninstall /

but it did the same thing.

I tried manually deleting the shit from the larger partition on the
stick, but almost immediately it got automatically restored!!!

There is NO WAY that I will insert this factory-installed-virus
containing stick into anybody else's computer.

My advice is to totally steer clear of any U3 containing sticks. The
software, if you can call it that, is IMO an insidious virus.

Oh yeah, if anybody knows of a way to manually remove U3 from a Sandisk
Cruzer Micro, I'm all ears. If I figure out a way to do it, I'll post it

In the mean time, I fired off a very nasty email to Sandisk support,
reminding them of Sony's DRM rootkit and how much damage that incident
did to Sony.

John Corliss

Re: Unable to remove U3 software from a Sandisc Cruzer Micro

On Thu, 30 Oct 2008 08:57:07 -0700, John Corliss

Quoted text here. Click to load it

I['m sure your concern is important, but did you google
search for this?


It's sad, and yet great, that google can substitute for real
live people.

I am curious though, why buy it if you have extra steps just
to use as you want to?  usually usb thumbdrives are a lot
cheaper online, 8GB now  under $16 AR.

Re: Unable to remove U3 software from a Sandisc Cruzer Micro

kony wrote:
Quoted text here. Click to load it

Of *course* I Googled my ass off before sending the OP. And I'd like you
to do me a favor... read your reply and try to look at it from my
perspective. How does your uncalled for sarcasm look now?

Googling (and I did the exact search that your link goes to about five
times at various points in my quest to remove U3) got this link (which
you snipped out of your quote):

   http://www.u3.com/uninstall /

It just happens to be the very first link in the list of hits your
Google query obtained and which was the very first link that I obtained
when I ran the *exact same Google* search you refer to.

Quoted text here. Click to load it

That's easy to answer. If you go to Newegg and look at the reviews for
sticks by other manufacturers, you'll see why I chose Sandisk.

Quoted text here. Click to load it

Here's NewEgg's page for the exact same drive:


You'll notice that they want $33.99 plus shipping and handling for the
stick. I got it at Walmart for $25 bucks yesterday, no wait.

Besides, the price of the stick has nothing to do with the topic of the OP.

Regardless, I just managed to sanitize my stick of U3 by using the file
listed here:


Apparently, it's a new version of the uninstaller program and it did the

However, be advised that if you put a U3 enabled stick in somebody
else's computer, you're not doing them a favor.

I'm out of here.

Over and out.

John Corliss

Re: Unable to remove U3 software from a Sandisc Cruzer Micro

John Corliss wrote:
Quoted text here. Click to load it

I found a removal download on the Sandisk site.


Holding the shift key, when inserting the thing, is supposed
to prevent Autorun from operating for that insertion. Which
may have stopped the installation. Then you could have
tried the Sandisk tool.

I tried looking at the Sandisk file with a hex editor, and
the software version is not evident. The launchpadremoval
tool appears to be heavily bloated. I guess that is consistent
with the U3 concept :-) To flip the necessary bit in the stick,
doesn't need a 3.33MB executable.


Re: Unable to remove U3 software from a Sandisc Cruzer Micro

Paul wrote:
Quoted text here. Click to load it

Quoted text here. Click to load it

U3 uses "fat bit" technology where each bit is in fact 3.33MBs.
Although an algorithm could be written to flip that fat bit, it's faster
to just do a bulk copy.

And yes, I did get hit on the head earlier today, why do you ask?

Re: Unable to remove U3 software from a Sandisc Cruzer Micro

Quoted text here. Click to load it

Just hand the disk over to someone with Linux and rm -f it. Bam :-)

Site Timeline