System Won't Turn Off

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

P-IV running Windows XP Home. Windows appears to be shutting down as
the screen goes dark, but the "turn off" has to be done manually. Any
help will be greatly appreciated & thanks ...

Re: System Won't Turn Off

Just Googled this and found many things that could cause this;
hopeless !...

On Tue, 08 Jun 2010 13:44:02 -0400, Steve Giannoni

Quoted text here. Click to load it

Re: System Won't Turn Off

Steve Giannoni wrote:
Quoted text here. Click to load it

Was it working at one time ?

There can be hardware or software reasons, and if it was all working
at one time, that might help eliminate the software reasons.


The hardware looks like this. The front switch is momentary contact,
and the motherboard logic converts the pulse from that switch, into
a solid continuous level on PS_ON#. If PS_ON# is zero volts, that
means the supply should come on. IF PS_ON# is at a 5V level, then
the supply should go off. Because the main cable of the supply has
a pullup resistor on it, that holds off the supply when no motherboard
is connected to drive that signal. That's why the PSU won't run by
itself when its sitting on the bench (jamming PS_ON# to COM starts it).

   Front_Switch ------ Southbridge/SuperIO -----------------> ATX PSU
                            ^                     PS_ON#       |
                            |  +5VSB                           |

In terms of hardware, it could be a (motherboard) driving end problem.
Or, it could be a problem with the thresholding of the signal by
the ATX PSU.

It's theoretically possible for a person to characterize the behavior
of both ends. You can check that the pulldown function of the motherboard
works. You can check that the pullup function on the PSU works. If
you don't know how to do that, you'd replace the motherboard and PSU
and test by substitution (which is a pretty expensive way to do things).
Since PSU failures are more common, you'd start with the PSU end.

Sticking a multimeter on the PS_ON# line, and looking at the voltage
levels, would give you a hint. If the line is swinging from 0.4V to
close to 5V when the computer is "supposed" to be off, then that
would tell you the PSU is likely having a problem reading the signal
level (bad PSU). If the line swung from 0.4V to 1.4V, then you'd have more
trouble guessing at who is at fault. That would require more
characterization of either end of the line. The motherboard end
can only pull down on the line, since the signal is open collector.
But when you see only a 1.4V level, is the pullup weak, or is the
motherboard driver still tugging on it ? That is indeterminate. You would
then need to separate the motherboard and supply, and test them separately.

These are ATX supply specs. I'll use the middle one, to discuss how
to use one of these. The third one is for 24 pin connectors.

On page 30 of ATX12V_1_3dg.pdf , you can find the main cable pinout. The
PS_ON# signal is green in color and on pin 14. The body of the main power
connector is open at the back, and you can jam the probe of your multimeter
in there, when the system is running. (That is easier to do, when the
system is removed from the computer case and sitting on your table.)
I connect the ground on my multimeter, to a screw on the back of the computer
in the I/O area. That way, I only need one hand to guide the red probe to
the main connector. That avoids shorting the meter tips together.
Setting my meter to the 20VDC range, allows me to measure 5V logic signals.

On page 20 is shown the behavior of the input. Normally, for a TTL
level circuit, the driving end might manage a swing of 0.4V to 2.4V minimum,
while the input threshold is set at 0.8V and 2.0V. Since 2.4V is higher than
2.0V, the input says "that's a logic 1". When the 0.4V level is seen, that is
less than 0.8V, so the input says "that's a logic 0". Values between
0.8V and 2.0V (like if you saw a 1.4V level), will confuse the logic
and the input will either guess it is logic zero or one. In some cases,
this failure to swing properly, causes the less than normal behavior.

I've even heard of cases, where a 1.4V level presented on PS_ON#, causes
the power supply to be "half on". The supply works, but won't meet full
load specs, and "falls over" easily. So the thresholding on PS_ON# on the
PSU end, isn't guaranteed to be "purely digital". In some instances,
the circuit on the end of the signal behaves in an analog way, so a half
way signal makes for a half-weak power supply. You're more likely to see
that on an older power supply.


Re: System Won't Turn Off

Thanks for responding. It never worked before.

Can't follow your response discussion ...

Quoted text here. Click to load it

Re: System Won't Turn Off

Steve Giannoni wrote:
Quoted text here. Click to load it

Check Device Manager. Look at the "Computer" entry.
Does it say "ACPI Multiprocessor" or "ACPI Uniprocessor" ?
Those support all the power control features.

I suspect your problem is hardware related.

If you didn't have working soft power control in the OS,
then you would have seen a Win98 style "it is now safe to
turn off your computer" screen image by now. Since
you're seeing a black screen, the OS thinks it has
turned off the power. And in that case, there is a
hardware problem with respect to the interpretation
of the PS_ON# signal on the main power cable.

There is a purported picture of the WinXP shutdown
screen here. This is what you'd see, if the OS knew
it could not turn off the power, and was relying
on the user to do it manually. When you see the
image in this picture, it means caches have been
flushed to disk, and removal of power won't corrupt
any file systems. .


Re: System Won't Turn Off

Device manager says Uniprocessor. I am a novice at this level and
can't follow your comments ...

Quoted text here. Click to load it

Re: System Won't Turn Off

Steve Giannoni wrote:
Quoted text here. Click to load it

OK. It's a motherboard or power supply problem.
Can you follow that ?

Knowing that, doesn't help you very much.
Someone still has to debug it and figure it out.

Not all problems have simple solutions, where one
component stands out as "the culprit". Sometimes
it requires a process of elimination approach.
Perhaps a shop can swap components and tell you
what is broken.

I'm going by your claim, that there is a black screen
at shutdown, as proof the OS thinks the computer
is turned off. And that leaves faulty hardware.


Re: System Won't Turn Off

On 6/9/2010 01:44, Steve Giannoni wrote:
Quoted text here. Click to load it

Did you try these registry hacks?

   @~@   Might, Courage, Vision, SINCERITY.
  / v \  Simplicity is Beauty! May the Force and Farce be with you!
/( _ )\ (x86_64 Ubuntu 9.10)  Linux 2.6.34
   ^ ^   13:40:01 up 21 days 16:51 2 users load average: 1.01 1.05 1.18
不借貸! 不詐騙! 不援交! 不打交! 不打劫! 不自殺!
請考慮綜援 (CSSA):

Re: System Won't Turn Off

Thanks for responding. Unfortunately the registry hacks didn't cure
the problem ...

On Wed, 09 Jun 2010 13:45:50 +0800, "Man-wai Chang to The Door

Quoted text here. Click to load it

Re: System Won't Turn Off

On 6/8/2010 12:44 PM, Steve Giannoni wrote:
Quoted text here. Click to load it

Like others have mentioned the problem could be hardware or software at
this stage.

I have had external USB devices, which had their own external power
source, feed 5 volts back into the computer's USB port and causing
similar shutdown problems.  One was a cheap manufacturer who left out a
protective blocking diode and another had a jumper that was to have been
removed when using an external power supply.

As for the software possibilities, I would boot a copy of one of the
Live Linux distributions in order rule out that kind of problem.  If the
Linux OS boots properly and powers down the PC correctly then the
problem has most definitely been identified as a software issue with
your present installation.

Live Linux software can downloaded at You
would need to burn it to a CD or DVD before using it.

If your motherboard supports booting from USB you can use the freeware
program UNetbootin and have it transfer a Live Linux distribution to a
Flash drive.  It is great for test booting a system when you suspect the
CD/DVD drive may be defective, provided the motherboard supports booting
from a USB port.  The program will download the Linux distribution for
you or it can use a Linux ISO you have already downloaded to load and
make your Flash drive bootable.

You can find the UNetbootin at: and
it is Freeware.

For this I usually use Puppy Linux as it is a rather small download
while still retaining the necessary software to recognize most systems.
  It has a graphic desktop that it boots into rather than just the
command line that many other distributions might present.  No need to
know Linux commands to boot or shut it down.

Last, I have seen a motherboard battery starting to fail that caused
random hidden changes on the motherboard setup.  As a last resort I'd
try replacing your motherboards battery and reconfigure the BIOS
settings, especially if the battery is 4 or 5 years old.

Re: System Won't Turn Off

Thanks for responding. How do I "boot a copy of one of the Live Linux
distributions"? Which item do I download? I am a novice at stuff at
this level, etc. ...

On Wed, 09 Jun 2010 11:12:53 -0500, GlowingBlueMist

Quoted text here. Click to load it

Re: System Won't Turn Off

On 6/9/2010 1:48 PM, Steve Giannoni wrote:
Quoted text here. Click to load it

Ok Steve.
Here is a link that will take you to the ISO file you will need to burn
into a CD for Puppy Linux.

Click on either of the two files listed called lupu-502.iso and your
browser should initiate a download of the file for you.  Go ahead and
download it.

Next you will need a program that will burn this image file into your
CD.  If you do not have one I'll include a link to a freeware one that I
use called CDBurnerXP, but don't let the name mislead you.  The latest
version of the program was written to work on Operating Systems: Windows
2000/XP/2003 Server/Vista/2008/Win7 (x86 / x64).  The link to the
program is: /
Click on the "Download NOw" choice and as before your browser should
begin a download of the install file.  Run it and the program will be
installed on your system for you.

Once you have CDBurnerXP installed on your comptuer and you start the
program just pick the option "Burn ISO Image" and use the Browse button
to locate the lupu-502.iso file you previously downloaded.

I leave the "Burn Method" option on "Choose automatically"
I also click on the "Verify data after burning", "Finalize disc", and
"Eject disc after burning" options.

Then after placing a blank CD into your CD burner click on the Burn Disc
button and wait for it to finish and eject the disk.

Then it's just a matter of making your computer boot from the CD drive.
It may already be set to look for a CD and boot from it if it finds on
so put the disk back into the drive and try booting.

If the computer still boots directly from the hard drive with out an
option to boot from CD there are other ways to get it to do it.

Some computers flash a very brief menu option on the screen, something
like "Hit F11 for boot selection" or "Hit F11 for BBS menu".  If you see
something like that hit the "F" key indicated by your computer and a
little menu will pop up that will list the boot devices your computer
knows about, scroll to the CD drive and tell it to boot from it.

If neither of the above gets the computer to boot the CD you may need to
enter your BIOS at boot up and change the boot order of your computer.
You will have to put the CD drive above the hard drive in the boot order
so the computer will be forced to look at the CD drive first during the
boot sequence.

When you boot the CD for this test just accept all default options.  No
need to choose high quality graphics or even pick the right time zone.
Then once the Puppy desktop comes up all you need to do is click on Menu
(lower left corner) and pick Shutdown, then Power-off.  When a menu pops
up asking if you want to save your settings, choose no and the computer
should then power off if things work properly.

Re: System Won't Turn Off

Prepared a boot CD per instructions. It appeared to be going through
steps of a boot process but finally hung on : Performing a
'switch_root' to the layered file system... Kernel panic - not
syncing: Attempted to killinit !

On Thu, 10 Jun 2010 07:44:06 -0500, GlowingBlueMist

Quoted text here. Click to load it

Re: System Won't Turn Off

On 6/10/2010 11:02 AM, Steve Giannoni wrote:
Quoted text here. Click to load it
<< snip, much removed for brevity >>

Drat, you ran into one of the problems with these small Linux
distributions, they only tend to leave in the drivers that are currently
in common use.  The larger downloads include many more drivers for
compatibility with more hardware.

Even though it is still even smaller you might want to try a download of
the version called Damnn Small Linux.

It comes in two flavors, depending on the age of the computer.

If the computer was built in the last 4 to 5 years give
dsl-4.4.10-initrd.iso a try.  For older computers they have an
alternative boot loader in the version called dsl-4.4.10-syslinux.iso
that might work better.

One link to the DSL downloads is: /

On my newer system I just booted the first version and while it was
starting up it scrolled almost continuously an I/O error that was
actively changing values.  I gave the program about 60 seconds or a
little more while the auto-configure program tried to figure out my
hardware.  It looks like this version has a little better hardware
checker in it.  Once it actually figured out my system the scrolling
cleared and the boot screen came up.

If you get the main boot screen the shutdown sequence is as follows.
Click on the "DSL" button on the bottom left of the screen.
Then Choose "Exit"
Then "Exit Options"
Uncheck the Backup option and then click on OK
The computer should then shutdown for you if all works properly.

If your system will not bring up the main screen you might need to
download the alternative version or choose one of the more complete
packages like kubuntu, that takes much longer to download :(, and give
that a try.

Re: System Won't Turn Off

7+ year old system; where do I get dsl-4.4.10-syslinux.iso ?

On Thu, 10 Jun 2010 16:24:36 -0500, GlowingBlueMist

Quoted text here. Click to load it

Re: System Won't Turn Off

On 6/10/2010 6:11 PM, Steve Giannoni wrote:
Quoted text here. Click to load it

Give this link a try for the syslinux version.

Re: System Won't Turn Off

WOW and OK !!!

My system shut itself down, all by itself!

Not sure what this means or what to do next ...

On Thu, 10 Jun 2010 20:21:38 -0500, GlowingBlueMist

Quoted text here. Click to load it

Re: System Won't Turn Off

On 6/11/2010 11:52 AM, Steve Giannoni wrote:
Quoted text here. Click to load it
< snip >

Well the good news is now that you find your computer can boot and power
down properly using the small Linux boot CD you have at least eliminated
hardware issues with your current system.  The bad is that the problem
is pointing to a misguided program or Windows update of some kind.

I think it's time for you to try and follow "Man-wai Change to The
Door's" advice and check out the link he provided from Microsoft
describing a possible fix.

Individual programs can interfere with the shutdown procedure by simply
refusing to shutdown properly while they are running, even while hidden
from view as in a firewall or other program.

Doing a control-alt-delete and bringing up the Task Manager you can see
the processes that are running just before you try to shutdown.  If one
of them refuse to shutdown properly your system may hang like you have

If you are lucky you can try to shut down non-windows operating
processes in the task manager (one at a time and then shutdown) and see
if the shutdown proceeds properly after that and then deal with the
individual program that was indicated, as in uninstall it or find an
updated version.  At the worst you might provide a list of the process
as listed in the task manager so people can advise on which one(s) might
be a good candidate for a manual termination test.

Anyway I think it's time to turn you over to Man-wai and see if his
advice can help you further.  His suggestion about the KB810903 at
Microsoft is a good one now that a hardware issue has been ruled out.

Re: System Won't Turn Off

Many thanks for all your help and note the new problem in the
subsequent posting below ...

On Fri, 11 Jun 2010 12:44:51 -0500, GlowingBlueMist

Quoted text here. Click to load it

Re: System Won't Turn Off

On 6/9/2010 01:44, Steve Giannoni wrote:
Quoted text here. Click to load it

Go Hardware -> Device Manager, Remove the ACPI device, reboot and let
Window$ re-detect it. Then try shutting down again.

   @~@   Might, Courage, Vision, SINCERITY.
  / v \  Simplicity is Beauty! May the Force and Farce be with you!
/( _ )\ (x86_64 Ubuntu 9.10)  Linux 2.6.34
   ^ ^   15:49:01 up 22 days 19:00 2 users load average: 1.04 1.06 1.01
不借貸! 不詐騙! 不援交! 不打交! 不打劫! 不自殺!
請考慮綜援 (CSSA):

Site Timeline