repairing Seagate disk ST3750330AS

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
My  Seagate disk ST3750330AS failed. It was unrecognized by Win or Linux, e
ven by special Seagate diagnostic software. By touching the drive I knew th
at plates are turning. After some reaserch on the Web and youtube I come to
 conclusion that the problem is PCB. I emailed
with description of the problem. I got an answer that the problem probably  
is not PCB but a firmware and they recommended: .
I checked the site. The video looked scary, but I decided to try it - what  
a heck - I can lose $50 and gain my pictures which were worth to me more th
an $50.
So I tried - AND IT WORKED!!!
The disk was repaired and I got all my pictures!
Some details - first attempted failed, somehow the terminal got stuck and r
efused receive any key entry. I don't want to mention what kind of curses I
 through on the company owners - now I am ashamed what kind of cruel death  
I wished they will die. After a cooling period and one beer I repeated the  
procedure - the 2nd try was much better, but although did not receive all r
esponse which the video showed I should get, but anyway I continued. After  
completion the procedure with my hands shaking I connected the drive - and  
voile - PC recognized it! I checked the folder with pictures - they were th
So if your disk crushes - maybe it is not end of the world...

Re: repairing Seagate disk ST3750330AS wrote:
Quoted text here. Click to load it

Seagate has had the odd problem, along the way.

As I understand it, the controller board has a bootstrap
firmware. Whereas more of the code is stored on the platter.
So changing the controller board, does not "fix" all the code.
A way is needed, to update the firmware on "track -1". I
don't think an ATA standard firmware update command,
does anything to firmware on the controller board itself,
which is just a bootstrap loader.

The bootstrap loader, and the track -1 code, have to agree
on data structures, where things are located, and so on.
Which is why, if you had an actual hardware failure on the
controller board itself, and swapped it out, there would
need to be some match between controller board and HDA.
If you look at the main chip on the controller, it has a
long long part number, implying there are many chips with
different mask ROM firmware loads.

By the way, I don't see a video link in your posting...
So I don't actually know what you did. Changing the controller
board is not likely to fix this particular issue, as near as
I can determine.

And due to the controller refusing to entertain commands
if the platter firmware doesn't load, at that point you
might need the TTL serial port interface trick, to issue
some kind of command to do a repair.

Just be careful you don't spend $50 for nothing. And also
check with Seagate tech support, to see if the model and
serial number, qualifies for free data recovery.


Site Timeline