Removing a dual boot OS from the MBR

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I am trying to make my Toshiba Portege 3440 CT laptop boot
from its external CD-ROM drive. I have already tried all of
the obvious things such as configuring BIOS to boot from the
CD-ROM before the HardDrive.

Since I upgraded this machine from Windows 98 to Windows
2000, it has retained the boot menu. Originally it could
boot to Windows 98 or MS-DOS. I am guessing that the Master
Boot Record may still retain traces of MS-DOS. How can I
remove these traces?

Re: Removing a dual boot OS from the MBR

On Sat, 12 Jan 2008 09:31:01 -0600, "Peter Olcott"

Quoted text here. Click to load it

When you installed Win2k, the win2k boot sector replaces the
Win98 one on the bootable partition, and the Win2k boot menu
points to two places, the partition you installed win2k to
and a file something like "bootsect.dos".

The bootsect.dos is needed to boot win98 now, but if you
wanted to be rid of win98 you could delete that file (or
leave it, the file would just be ignored after you next ...)
and edit the boot.ini file to remove reference to OS other
than win2k.

I'm saying that for boot purposes, there are no traces of
Win98 or DOS that are relevant to your goal of booting the
CD.  The only things that will matter booting from CD are:

-  Properly working CDROM/other optical drive, modern enough
that it supports bootable media which was before the win98
era (laptop would probably have to be a few years older than
win98 era to have a CDROM drive that old).

-  Intact bootable media.  See if the disc you're trying
boots ok in another system, and of course if it is a CDR or
RW disc, an old drive may have more trouble reading it.

-  Bios set to boot to it.  Generally in the bios menu there
are options for the first boot device to try, and sometimes
a list of what you do or don't want to exclude from trying.
Sometimes there is also a key you would press to access the
boot menu to pick which drive it would try but IIRC this
kind of option was more prevalent on newer systems.  

I suspect your problem is the last item, that the bios can't
be set to boot from it because the external drive isn't
visible to the bios due to being external instead of an
ATAPI (PATA connected) internal drive.  I am not certain of
this, I suppose it is possible if the laptop and drive were
connected to the appropriate docking station (I mean with
some laptops, I don't know about yours in particular) then
through the docking station the drive could be connected
logically such that the bios could see it.

There might be another way around your problem?  What do you
need to boot from CD?  Some things could simply be copied to
the hard drive then you could boot to Win98 boot menu and
"safe mode command prompt" or something like that to run
what you had copied from the CD, or if the CD is visible in
dos when the system is booted from a win98 boot floppy you
then have a dos environment to execute something from the
CD, for example an operating system installation routine for
Win98 or 2k can be started like this, though they run much
much faster if that dos/win98 boot cd is loading smartdrive
to catch files, and IIRC Win2k installer will even remind
that it will run much slower in the dos environment without
smartdrive loaded.

Re: Removing a dual boot OS from the MBR

Peter Olcott wrote:
Quoted text here. Click to load it

The option to boot from a CDROM is usually for an internal drive only. You will
probably have to use another option e.g. boot from a USB device.
Quoted text here. Click to load it

Attempt to start Win98. If it works there are still Win98 boot files and a Win98
directory that you should remove. After you have eliminated these files edit the
Boot.ini file to remove the Win98 items from the menu.

                   Mike Walsh
            West Palm Beach, Florida, U.S.A.

Re: Removing a dual boot OS from the MBR

hi peter, You can modify the boot.ini file. This "Boot.ini" file is a
secured hidden file in windows. It will be available in drive c:\
[mostly ]. But this file is hidden secured, so to see this you have to
go to folder option in control panel and uncheck "hide protected
operation system files" and also you have to select show all files and
In the boot.ini file you will see 2 menu, ie) windows 98 and then next.
now u can delete windows 98 line. your problem will be solved

Albin - Technology and Computer Troubleshooting Forums

Site Timeline