Power supply problem? Need input, bad!

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

This is about the Old Homebuild that boots and runs normally -- but you
have to wait 8 - 10 MINUTES first. A few good people offered advice and
I followed it, but no luck yet.

The thing is, NOTHING happens with this Celeron 400 homebuild for many
minutes. The fans run, but the FDD, HDD, and keyboard show no life or
activity and are silent.  Then there's a beep, the hard drive spins up,
etc. and *voilą* it's running like it didn't know anything was wrong.
The DOS routine on the monitor stops to tell me the CPU "is corrupted or
has been changed," meaning the BIOS went to its default settings
(300MHz;  A,C,SCSI sequence). But it runs.

I thought maybe I corrupted the BIOS in an aborted visit to a site that
had an updated version. But if that were true, the PC wouldn't boot *at
all* right?

Well, boot times grew longer until it really looked done for. I tore
everything down to the bare case, put back the minimum for booting.
Nothing. Found that I'd inverted the floppy connector and fixed it.
Still wouldn't get past the fans-whirring stage. The monitor (back to
the old Hitachi CRT) just blinked at me.

The system's plugged directly to a different wall socket now, and I'm
able to post this because it finally decided to boot. I just dared it to
live and went to get dinner so I don't know *when* it booted, but after
I powered down and re-assembled, it took a good THIRTY minutes.

So -- if you're still reading, bless you -- while I can still get
online, does this look like a problem with the power supply? Scott
Mueller's book speaks of a Power_Good signal that the PS sends to the
motherboard, meaning that the power supply can   "maintain outputs
within regulation tolerance...The system will not restart until the
Power_Good signal returns."

Sound likely?? Or bad BIOS? I don't have much confidence that it's the
different wall socket.


Re: Power supply problem? Need input, bad!

DemoDisk wrote:
Quoted text here. Click to load it

You probably have the bios and hardware configured to auto-adapt to
a drive that isn't there, and the adapt mechanism is timing out.
Configuring a master when there is no slave can do this.

"If you want to post a followup via groups.google.com, don't use
 the broken "Reply" link at the bottom of the article.  Click on
 "show options" at the top of the article, then click on the
 "Reply" at the bottom of the article headers." - Keith Thompson

Site Timeline