Poor quality copper in connectors of Acer Aspire E 15 (E5-511-P6VU) ?

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

This is Xposted.

After upgrading to cat6 Ethernet cable and Gigabit Ethernet switch, I am  
still having problems with an Ethernet connection that craps out at 1.0  
Gbps. Also at the same time, the filesystem connection to a 64 GB  
microSD (xSDHC) also craps out. The microSD is mounted in a an SDHC  
adapter. From my experience, I am inclined always to first suspect  
hardware fault. So as is my usual technique, I cleaned the contact of  
the microSD and its adapter first by rubbing with a pink pencil eraser  
and then with 70% isopropyl alcohol on a Qtip and then a dry Qtip.  
Neither the pink eraser nor the Qtip showed a grey stain as is common  
with oxidation. I also tried to clean the Ethernet connector

Since I started writing this, 1.0 Gbps connection has crapped out once  
but now it is re-established. The file system connection to the 64 GB  
microSD has held steady.



Re: Poor quality copper in connectors of Acer Aspire E 15 (E5-511-P6VU) ?

On 2015-12-27 5:36 PM, Norm X wrote:
Quoted text here. Click to load it

Now both are crapped out. Good thing I also have WiFi.

Re: Poor quality copper in connectors of Acer Aspire E 15 (E5-511-P6VU) ?

On 12/27/2015 6:05 PM, Norm X wrote:
Quoted text here. Click to load it

Are you sure your cables are wired correctly?
The connection from twisted pairs to the plug is counter-intuitive.
There's also more than one color standard.
Many of the cables I had failed to work at 1Gbps, but the system
did fallback to 100Mbps.
One turned out to be a swizzle cable.  Worked fine with the autoswizzle
in modern ethernet interfaces, but failed at 1Gbps.

Re: Poor quality copper in connectors of Acer Aspire E 15 (E5-511-P6VU) ?

Norm X wrote:
Quoted text here. Click to load it

A quick glance at the RJ-45 on my Acer laptop, shows 10u gold
plated contacts.

A look at my Ethernet cable, shows 10u gold on the contacts
on it as well. And my cable has a plastic block with channels
to guide the contacts on the cable end, so they cannot move.
Only the laptop end uses "beams" that could be displaced
if too much force is used.

Generally, you want gold-on-gold or tin-on-tin, when mixing
connector types. Gold on gold slides, tin on tin bites.
Mixing gold and tin would not work well, and it's possible
if you examine more pairs of RJ-45s you'll find they're
using gold.

I do not recommend pink pencil eraser for gold plated
finishes. The computer industry uses 10u gold, while
telecom parts use 50u gold. No matter what the thickness,
a poorly administered gold application can have pinholes.
Or, if improperly masked some portions may not get any
gold at all. Parts should be rejected, if the gold application
is not done properly.

Gold is not applied directly over copper. There is an electroplate
sequence, with the right materials coming in contact with
one another, to achieve the best plating finish and
performance over time.

When the motherboard PCB is on the soldering line, one
of the steps after double-IR reflow is completed, is
the wash cycle. The Ethernet connector on your laptop
has a rubber bung inserted in the connector, which
serves to keep wash water out of the connector. The wash
cycle removes water soluble solder flux. If the bung
is not water tight, or if no bung was used at all,
the washing machine can cause a little bit of flux to
coat the nicely prepared 8 gold plated contacts
in the RJ-45.

Using alcohol alone, should be sufficient to remove
this. No pencil eraser is needed, just a bit of

GbE consists of four pairs. The pairs are transformer
isolated, and hence differential (one signal goes up
when the other signal goes down). The re-routing of
signals on GbE, cannot move a defective contact of a pair,
so the pair ceases to function on a single open.

To make 10/100BT work, only takes two pairs. It's possible
the ends could re-negotiate to work with as few as only
two of four pairs. But I haven't tried that (tried all
possible pairs to see which are sufficient to make it work),
and don't recollect any complex re-negotiations being possible.
In other words, on a single contact failure, there
is every possibility communication can continue at
10/100BT speeds. But I don't know right off hand, what
happens if 1,2,3, or 6 are open (the pins on 10/100BT).

The signal path chip-transformer-cable-transformer-chip
can be tested with Marvell VCT. If you have certain
members of the Marvell ethernet chips, they have the
ability to "wring out" the connection (test your cable
for you). When my P4C800-E Deluxe straight out of the box
exhibited a GbE problem, I used Marvell VCT to determine
"one pin was open". That test uses TDR (time domain
reflectometry) to determine cable impedance. Down at
the transformer, the link is resistor terminated in
the characteristic impedance of the cable, so when a
pulse is sent down the line, there should be no reflection.
And that's how VCT can figure out "short", "open",
"correctly terminated", just by the waveshape or
lack of waveshape.

If something is crapping out, I'd be looking elsewhere
for an explanation.

The new GbE switch, will have power saving features
on unused ports. If you sleep the laptop while
it is connected to the switch, the switch port
may decide there is no electrical activity, and
it will go asleep too. This prevents Wake On LAN
packets from reaching the laptop. And the user
might conclude "something is busted". WOL doesn't
work with a lot of GbE switches, due to the power
saving feature.

My newest motherboard has a number of features,
some of which extend into the sleep state. It's possible
my Intel GbE could keep the port on the switch alive,
if I let it. I've turned all that stuff off at
the moment. All you might need, is something
like Heartbeat, to keep the switch happy.

So there's lots to consider before reaching
for a pink pencil eraser, or going back to Wifi.

With a pink pencil eraser, you can easily burn
through the 10u gold and ruin the future life
of the connector (require cleaning again and again
until there is nothing left). In terms of triage:

1) Insert and remove connector five times.
    Gold on gold relies on wiping, and see if
    normal insertion action will establish a connection
    on a virgin connector. Five cycles was sufficient
    to make my P4C800-E work properly.
2) If this fails to work, use alcohol and a swab.
    Make sure the alcohol is of decent quality and
    doesn't leave a residue when dried. Put a drop on
    a shiny clean surface, and see what happens when
    it dries.
3) Only if you've failed (1) and (2), have examined
    the connector with a magnifying glass or microscope
    and see no other choice, would you reach for any
    sort of abrasive. After all, there is supposed to
    be gold on some of these things, and gold is a noble
    metal. An abrasive might well be a temporary solution,
    until you unsolder the connector and install a
    new one or replace the cable with another.

Ethernet over CAT cabling, is one of the nicest
technologies going, in terms of implementation
and ability to function. Give it a chance.


Re: Poor quality copper in connectors of Acer Aspire E 15 (E5-511-P6VU) ?

Quoted text here. Click to load it

You changed both the switch and cable; the problem did not change, so
it'sprobably not the hardware. Are you seeing any error messages in the
Event Logs?
                    So as is my usual technique, I cleaned the contact of
Quoted text here. Click to load it

Be careful with that; modern connectors have a very thin layer of gold
compared to twenty years or more ago. It's easy to damage the coating
with abrasive cleaning.

Quoted text here. Click to load it

Try disconnecting the microSD and adapter and see if the network becomes

Quoted text here. Click to load it

All RJ-45 plugs will be gold plated; otherwise they wouldn't be
compliant with the Cat5 or Cat 6 specs.

Quoted text here. Click to load it

I'm leaning towards a bad driver or IRQ conflict. Checking Event Log
would be a good place to look for more clues.


Re: Poor quality copper in connectors of Acer Aspire E 15 (E5-511-P6VU) ?

Quoted text here. Click to load it

The 1 Gbps link speed sounds correct, so what does "craps out" mean? Have
you tried another Ethernet cable? Cat5, Cat5e, and Cat6 are all easily able
to link up at 1Gbps. Have you tried another switch, or another PC?

Does "still having problems" imply that you had a networking issue before
you upgraded?

Re: Poor quality copper in connectors of Acer Aspire E 15 (E5-511-P6VU) ?

On 2015-12-27 7:26 PM, Char Jackson wrote:
Quoted text here. Click to load it

Yes all problems with Ethernet were there with Cat 5e cable and a  
100Mbps swith. The OS reports loss of connection to DNS. Thunderbird  
Mail program reports time out with message containing a large enclosure  
or loss of connections to university mail server.

The interesting thing about the 64 GB microSD is that while it is lost  
to the file system, ReadyBoost still shows up in Resource Monitor.

All these selective failures now lead my to mistrust my version of  
windows 10. I had considered purchase of a version on DVD. The Win10 I  
have has been upgrade twice over the network. If the network cannot be  
trusted, bit errors might make it behave poorly.

I have Win7 on a desktop machine that I recently upgraded to quad core  
Q6600. Generally my Win7 gives no errors like my Win10 but the original  
install was from a DVD whose .iso was downloaded from the net. I that  
time I was not savvy enough to check checksums. I know that unimportant  
files are corrupted because Event Viewer says they are.

Re: Poor quality copper in connectors of Acer Aspire E 15 (E5-511-P6VU) ?

Norm X wrote:
Quoted text here. Click to load it

The only kind of download which is "unprotected", is a direct
download of the ISO for Windows 10 from the server. I had
two of these fail (I could tell later they were too small).
Direct downloads happen, if you attempt
to get a copy of Windows 10 using WinXP as the downloading
machine or use Linux as the downloading machine.

MediaCreationTool should verify the checksum and the size.
It should work on a Vista/W7/W8/W10 machine.

WindowsUpdate should be similarly protected.

Tools like WSUSOffline, or your average web browser,
may not deal well with the way the Microsoft servers
are set up now. And I don't understand the reason
why this is happening (both ends of the transfer
appear to be satisfied that the transfer is complete,
when the size is obviously not correct).

But rest assured, that if a Microsoft tool carries out
the download, it will be verified before usage.


Before using any computer for serious work, you
carry out a memory test, and a load/torture test
of the CPU. This is a way of checking that it
is working properly. Only then do you install
an OS on it. In particular, the Windows registry
can be loaded into RAM, and written back out
later, so there is potential for the registry
to help you spot corruption if the computer
itself is responsible. When people overclock Windows
machines, sometimes registry corruption is the
first sign their overclock is not stable.


It's more likely there is some interaction
between your various network interfaces,
than an issue with the physical network.

There were chipsets with particular issues
regarding networking. There was one NVidia
chipset (Nforce3 era?) with MAC in the Southbridge,
which would corrupt a 32 bit word every once in
a while. I never did hear whether NVidia was
able to fix this, or it was an unrepairable
network bug (via driver change). There aren't
too many issues like that out there.

You can carry out basic network speed tests
with something like this. It's a clumsy test
tool, requiring the receiving machine to be
set up first, then starting a sending program
pointed at it. But it's one way to get
an opinion about a network. And one slight
advantage of a program like this, is it is
multiple platform. You can repeat the tests
from a Linux LiveCD if you want.


I got mine here, according to my bookmarks file.



Re: Poor quality copper in connectors of Acer Aspire E 15 (E5-511-P6VU) ?

Quoted text here. Click to load it

So it's only a DNS issue, or is it more than that? Which DNS server(s) are
you using? Have you tried using other servers?

Do you have any networking issues if you bypass DNS, either by using IP
addresses directly or by putting entries in your hosts file?

What I'm getting at is that if this is only a DNS issue, then it suddenly
becomes relatively trivial to resolve.

BTW, here are a few DNS servers that you can try.
 - to
 - or
 - either of the OpenDNS servers

Better yet, download and run DNSbench or Namebench to find a fast server
near you.

Re: Poor quality copper in connectors of Acer Aspire E 15 (E5-511-P6VU) ?

Quoted text here. Click to load it
After 40 years experience of computing, my order of priority for resolving  
faults is:
1. The user (RTFM)
2. The software (ANY software)
3. The hardware.
Your tale of woe seems to be a classic example of the danger of tackling  
faults the other way around.

Site Timeline