PCMCIA cards crapping out on HP N5495 Pavilion laptop

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Hey all! Excuse the crossposting, but all the groups are related...

I have four wireless network cards. Only one works. The other three appear
to initialize and then die off. One of these actually freezes the laptop
solid when it is initialized by Windows, but the machine will continue to
work normally once I pull the card out as if nothing had happened.

It's an HP Pavilion N5495 laptop. This laptop uses a O2Micro OZ6933 cardbus
controller. I have Windows XP Pro SP2 installed. For what it's worth, my
wireless routers are a Netgear 802.11b, Hawking 802.11g and an SMC 802.11a

The working card is a Proxim Harmony 802.11b PCMCIA card, using the PrismII
chipset. This card cannot be configured using the Windows wireless network
configuration wizard.

The card that freezes the laptop is an SMC 2735W 802.11a 3.3v 23bit cardbus
card using the Atheros AR 5000 chipset.

The third card that initializes and then doesn't find any networks and/or
causes bluescreens is an Asante AL5410-G 802.11G card. This uses a  TI Texas
Instruments ACX 111 chipset.

The final card is a DLink DWL-AB650 802.11ab 3.3v cardbus card that uses an
Atheros AR5001X+ chipset. I've hacked together a driver that seems to start
the card and I can usually get an IP address via DHCP but the card dies soon

I had also tried an SMC 2335W 802.11ab card that I borrowed from a friend
and couldn't get it working either. It also uses the Atheros AR5001X+

It seems like he O2Micro chips are being overwhelmed somehow... too many IRQ
requests or something similar.

Can anyone make some suggestions what is happening here and how I can get
these cards working.


Site Timeline