Onboard Serial-ATA choice not showing up in Bios

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I hope this is the correct newsgroup for this post, I am having hardware
trouble with the new computer I just built.  If there is another, more
appropriate NG, please point me to it.

Anyhow, as I said, I just built a new computer.  The motherboard is Asus P5B
Deluxe WiFi and although I am following the instructions in the MB User
Guide, things are not working exactly as planned.

Here's the situation.  I have 3 identical Samsung HDDs that I want to set up
in a RAID 5 array. From advice I received on an Internet forum, I found that
I should set up the RAID array before installing the OS. I am following the
instructions in the motherboard documentation. As I mentioned, I have an
Asus P5B Deluxe WiFi and the User Guide that accompanied it lists 6 steps to

1 Enter Bios
2 Go to the main menu, select IDE Config and press Enter
3 Select the item "Configure SATA As" and press Enter
4 Select RAID from "Configure SATA As" and press Enter
5 Select the item "Onboard Serial-ATA BOOTROM" and press enter
6 Save changes, then exit Bios

Here I encounter my first problem. Steps 1-4 are no problem.  However, once
you choose RAID from the "Configure SATA As" option, the "Onboard Serial-ATA
BOOTROM" is supposed to show up as a choice.  But, on my screen, the choice
does not show up!

I tried saving and exiting and going back into the Bios, but it was still
not there. The choice of configuring the drives as a RAID array has been
saved, but no BOOTROM choice is anywhere to be found.

Asus says after doing all of the above, I need to go into the Intel Matrix
Storage Manager Option ROM Utility by hitting <Ctrl + I>. So I thought that
perhaps I could try that, notwithstanding the fact that the BOOTROM choice
never showed up in the Bios.

I tried hitting <Ctrl + I> until my face resembled the blue screen of death,
but nothing ever showed up on the screen. I do not know if this is because
of the failure to change the BOOTROM to enabled status or is an unrelated
headache, but I cannot get into the Intel RAID setup utility.

Previously, I used the Asus motherboard utility cd to create a set of
drivers for the array, so I *do* have the RAID drivers saved on a floppy,
but I understand that I cannot load them until the OS Installation process.
I have checked the BIOS and it sees the RAM and the CPU and when I look at
the boot section of the bios, it finds the 3 Samsung drives which it lists
as RAID drive #1, #2, and #3.

I have the Samsung drives plugged into the red SATA ports (if I understand
correctely, the black SATA ports are for use with the JMicron RAID
controller rather than the built-in Intel RAID Controller). I do not have
any jumpers installed on the drives, but from what I understand, that is not
an issue unless I was using these as standard IDE drives.

I am not sure where to go at this point. I could try and install the OS, but
although I do not understand a lot about RAID, I saw on the Internet that
the "Onbopard Serial-ATA BOOTROM" choice allows you to boot from a HDD that
is part of a RAID array. That implies to me that if I manage to install the
OS, I might not be able to boot from it unless the BOOTROM option was
already enabled prior to the OS installation.

Does anybody have an idea of what I should do next? Any idea of how to make
the BOOTROM choice show up?  Any idea of how to get into the Intel RAID

As things stand, I have a computer with an Asus 5B Deluxe WiFi board, 4gb of
OCZ memory, 3 Samsung T-Series 320gb HDDs with no OS installed and a Bios
that is not behaving in the manner the documentation tells me that it
should.  Do I need to load the RAID drivers or perform some other step?  I'm
really at a loss.

Thanks for any and all help.

Oh, in case you had not figured it out, I am a newbie and this is my first
computer build.

Re: Onboard Serial-ATA choice not showing up in Bios

The poster formerly known as Colleyville Alan wrote:
Quoted text here. Click to load it

The first thing I notice in the manual, is "Interrupt 19 capture" is
[Disabled] by default. That should be enabled. The number 19 is decimal,
and in hexidecimal that would be 0x13. The Int 0x13 service, is the BIOS
service that allows an OS to boot from a storage device. For those "foreign"
devices, like SCSI controllers, or RAID devices, the device registers its
boot ROM, so that the OS has a way of accessing the device, before a
driver is loaded in the OS.

If Interrupt 19 capture is enabled, then a BootROM should offer itself as
a boot option. What doesn't make sense to me though, is why the Sata BootROM
option is not present in the BIOS. AFAIK, that should always be present,
and is a simple minded selector. If the BootROM module was missing from
the BIOS, there would be no harm from having a setting like that not
doing anything particularly useful.

Another possibility, is the BootROM module is missing from the BIOS. You
didn't say which BIOS release you had. Sometimes, you can check the
inventory of modules inside the BIOS, using a hex editor. Other times,
you need a BIOS tool to get at the internal modules.

If you are still not getting anywhere, the next thing I'd try, is
dropping down to two sticks of RAM. By using 4GB, maybe you've triggered
some corner condition in the BIOS, where they actually ran out of
address space for some of the BIOS functions. Yes, the BIOS writers
make mistakes all the time (and don't seem to test as thoroughly
as they used to).

Another thing I don't see in the user manual, is any mention of memory
hoisting or memory hole function, for when you have 4GB or more RAM,
and wish to remap it. That would be appropriate if you had a 64 bit
OS. The manual claims the board can take up to 8GB of RAM, so you'd
think there would be a remapping function hiding somewhere in the


Re: Onboard Serial-ATA choice not showing up in Bios

Quoted text here. Click to load it

Some bios do allow that to be enabled/disabled, essentially because
it slows the boot to have it enabled when you dont have any sata drives,
because it has to poll for drives and there isnt any point in doing that
if you dont have any sata drives.

Quoted text here. Click to load it

Re: Onboard Serial-ATA choice not showing up in Bios

Quoted text here. Click to load it

I'll try pulling the 2 sticks of ram and see what happens.  I purchased the
MB just 3 weeks ago, so I assumed the BIOS was fairly current.  I went in
and checked it and it lists the following:
Version 0614
Build date: 09/05/06

There may be a more current BIOS, but the instructions in the User Guide
look to me as though they would apply to earlier BIOS versions, so perhaps
it is the memory issue.  Of course, the Asus website is up today except for
forums, tech support, etc.

I did find out that the Intel RAID utility will not be found unless BOOTROM
is enabled, so my inability to get to that via < Ctrl + I > is at least
understandable.  I can vaguely follow the Interrupt 19 information that you
gave, but I cannot understand why that would not be spelled out in the User
Guide.  Still, I will give the memory thing a try and see what happens.

Thanks for the info, I'll report back whichever way it goes.

Re: Onboard Serial-ATA choice not showing up in Bios

Quoted text here. Click to load it

I did try enabling Interrupt 19 and removing channel B ram so that the
system now has 2 x 1gb in the A channel only.  This did not make any
difference.  Since the Asus support website is not up and running at the
moment, I do not have a way of getting a new BIOS version.  Also, I recall
several years ago that I tried updating the BIOS on an old 386 computer and
that it would not run and that updating the BIOS can sometimes cause
problems.  Is there any way that I can be sure that a new BIOS will not
cause problems and will be able to be rolled-back if something does not

Re: Onboard Serial-ATA choice not showing up in Bios

The poster formerly known as Colleyville Alan wrote:
Quoted text here. Click to load it

Maybe there is a hardware problem, such as the BIOS module not recognizing
the chipset as being RAID enabled ? Perhaps at some point, you should
try returning the board to your retailer, and try another.

In terms of reducing the risk, not all the following ideas will be
practical. From least risk to more risk:

1) Buy a replacement BIOS chip from badflash.com . They can supply a
    replacement chip and program it for you, with whatever release file
    you want in it. The BIOS chip should be socketed, and you pull the
    old one out, and install the new one. With the power unplugged,
    you clear the CMOS with the jumper, and then the new BIOS should
    be ready to go.

2) Ioss.com.tw makes a device called the BIOS Savior. It basically
    has two BIOS chips on it, and a switch to select between them. You
    put the original BIOS chip in a socket on the device, and then plug
    the device into the socket on the motherboard. It costs about as much
    as a chip from badflash.com, but is reusable. You can keep a "good copy"
    of the BIOS on one side of the device, and use the other side for

    Unfortunately, the few times in the recent past that I've checked
    ioss.com.tw, they haven't been keeping up to date with the latest
    motherboards, and the size of flash chip they use. So this is
    not really a viable alternative.

3) In terms of flashing tools, using a DOS boot disk and flashing the
    BIOS in DOS, is the least risky method. It pays to back up the old
    image to disk first, before attempting to upgrade. Then, if a problem
    is detected before pressing the reset button, you have a chance to
    flash back to the old BIOS.

4) Asus offers "Asus Update", a Windows program for flashing while
    still in Windows. If you use this method, you download the BIOS
    file first and have it on a local storage device. This prevents
    a network problem, from ruining the BIOS.

No matter what tool you use, always check the support.asus.com download
page, as the BIOS files sometimes have warnings about certain BIOS
flashing options not working properly.

   Description      P5B Deluxe Release BIOS 1004
**Please update AsusUpdate to V7.09.02 or later prior making this update.**
**This BIOS does not support roll back to older BIOS**
1 Enhance memory compatibility
2 Support CONROE E0 CPU(FSB 1333)

I'd try flashing the board, and if you kill it, the results are
the same anyway - return it to your retailer, before the initial
return period has expired. It could be that the BIOS thinks
the Southbridge is ICH8 rather than ICH8R, and is refusing to
load the RAID BIOS module because of that.

There has to be some kind of explanation why the RAID module is
not showing.


Re: Onboard Serial-ATA choice not showing up in Bios

Quoted text here. Click to load it

Thanks for the info.  I have been trying for several days to send a
technical inquiry to Asus, but I keep getting an error message "Internal
Server Error - please try again later" and, of course, when I try again
later the system is still down.  I made a similar post in the Asus forums
and nobody there could answer this question, so I appreciate the reply.

Re: Onboard Serial-ATA choice not showing up in Bios

Quoted text here. Click to load it

p.s.  I found a phone number to call for Asus tech support.  The voice
recording told me of a website for live support,
http://livesupport.asus.com /
I saw at work that the hours of operation were 5:30am to 9:00pm PST.  So, I
waited until I got home to go back to that website and see about getting
some help.  At roughly 4:30 CST (2:30 PST), the website is offline,
nothwithstanding the notice of hours of operation right next to the icon
that now reads offline.  Amazing.

I was able to send the equivalent of an Instant Message - we'll see what
that brings.

Re: Onboard Serial-ATA choice not showing up in Bios

The poster formerly known as Colleyville Alan wrote:
Quoted text here. Click to load it

On the one hand, I don't think they really want to support the end user.
They make 4 to 5 million motherboards per month, and personal support
for each one of them is out of the question. Still, they could try a
little harder, because I don't get the sense that their tech support
organization has grown at the same rate as their motherboard output.

In terms of "why to file a report" - if they are not informed of
BIOS bugs, there is no way they'll put someone to work on fixing
them, unless their P.R. database starts to fill up. So filing a
report will not necessarily lead to instant gratification, but
with a little luck, maybe a BIOS update 3 months from now will
fix a problem found.

As for the "meat" of the report. Keep the report short, including
all necessary hardware details. And don't give them any material
to make up excuses - if they have a minimum of material to go
on, such as "your motherboard is broke and here is why", they'll
have little they can do, in terms of cooking up a purely useless
suggestion. If you mentioned the names of any third party
products, for example, it would be easy for one of their email
weenies to blame it on the other product.

And their vip.asus.com forum would have been an excellent way for
them to gather intelligence on how well their products are working
- but no one at Asus is reading it :-(


Site Timeline