NIC can't bind IP address...?

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View


I have a Dell Latitude D610 with an integrated NIC on the
motherboard. The OS is XP Pro.

I very frequently change network settings because I move the
laptop from place to place. I typically use software
(NetSwitcher) to make those changes. When in my office, I
use a static IP address.

For the last few weeks, I often have the following problem:

When I run NetSwitcher, the NIC hangs with the message
"Acquiring IP address." At that point, I had been able to
resolve matters by clicking on "Repair" in the Net

But now, even that technique often fails. "Repair" leaves
things just as they were, with the status as "Acquiring IP

If I run IP config I see that there is no IP address
assigned. Then, if I attempt either a "release" or a "renew"
I get a message telling me that the NIC is not in a state
that will allow the command to take effect.

I also get a System error telling me that there is a
conflict on our Lan because two systems have the same IP
address. I have checked very carefully, and there is, in
fact, no such conflict.

If I reboot, I can usually (but not always) assign the IP
address, and with that, all is well. On occasion, I must
reboot several times.

So, with all that as background...

The folks at Dell tell me that this situation is likely to
indicate that the NIC is flaky, and, they say, the (out of
warrantee) repair will require a new MOBO.

With what I have described, could anything else be the
cause? That is, might this be a software or driver problem?

And if so, how might I diagnose and repair the difficulty?

Many thanks for any help,

If you email... Please remove the "SPAMLESS."

Re: NIC can't bind IP address...?

Quoted text here. Click to load it

Dell is probably right, your problem does sound a bit like a hardware issue.
Try picking up a cheap USB to Ethernet connection interface dongle and see
if it works. Also take a look at the logs and see what codes are showing up.


Re: NIC can't bind IP address...?

On Tue, 13 Jan 2009 15:39:13 -0500, "rjk"

Quoted text here. Click to load it

Hi again,

Thanks for the good suggestions...,

If you email... Please remove the "SPAMLESS."

Site Timeline