New Logitech optical mouse does not work

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Here is a cut and paste I tried to send logitech support by form email, but
then it asked me for my name and street adress and passwords and to
register..... forget it.
Just to let them know they have a problem with one of their optical mouse

Short of it is their OLD optical mouse works fine on 3 systems I tried it
on. A newer model does not work on any.

Thought I would share....

I have used a logitech optical mouse for several years without problem.
Yesterday I bought one for my mother's computer. It failed to work or be
recognized (Dell dimension 2300). I thought perhaps the dell system was
being finicky. I removed the logitech optical mouse from MY system (Asus
A7V8x, winxp) in the ps2 port using an adapter (as usual) and installed the
new mouse and booted up.

MY system failed to recognize the mouse (cursor wouldn't move, same like my
mother's computer).

I removed the mouse from the ps2 port and installed it directly into the usb


Still the cursor does not move! The mouse led is on and very bright. It
stays bright. My other logitech mouse is bright when I lift it to look at
the light but goes dimmer right away. The new mouse stays bright.

I returned it to the store and got an exchange. They were able to get the
mouse working with no problem at the store on a new system.

I got home and tried the replacement.

It does not work.

The logitech mouse I have that DOES work is M/N M-BJ58 ,  P/N 830524-0000.

The mouse that does NOT work has a PID of LZ750A60CKA on a white sticker.M/N

I am sorry find that this mouse which should work with win98 to vista is not
working on 2 computers with XP and one with linux (I use the same old
logitech optical mouse on 2 different systems with dual boot linux and
windows, no problems.) Nor does it work on my mother's dell dimension
(winxp).  What hardware changes are you making that makes the newer products
fail to work lijke the older products?

Can you offer an explanation?

Re: New Logitech optical mouse does not work

Quoted text here. Click to load it
Quoted text here. Click to load it

Yes, you neglected to install the drivers...

Re: New Logitech optical mouse does not work

philo wrote:
Quoted text here. Click to load it
It should work without any drivers.  You don't have to reboot for USB
mice, just plug them in and you can do that even with another mouse

If you set up all the computers you are using, maybe there is something
in common with them that is causing problems, maybe some type of driver
for another type of pointing device.  Ask someone else to let you "plug

Would you please post what model the mouse is--Laser? What does it say
on the box?  I can I find it on the Logitech site?

I have never had a problem with a Logitech mouse.  The chances of you
getting two bad ones, and they both work at the store is pretty much


Re: New Logitech optical mouse does not work

Clark wrote:

Quoted text here. Click to load it

The problem mouse is called logitech optical mouse USB. It is a 3 button
mouse, the third button being the wheel.
A code on the box says Opt MS USB931369-0215. On the mouse itself is a model
number (?) M/N M-UAE96. The back of the box states that NO SOFTWARE is
necessary (no driver/software disc comes with it at all) and that it will
work with win 98 , 2000, Me, XP and c OS X . A sticker on the box states it
is Vista Certified.
The box states it is "best selling optical technology" and I do not doubt

I love my working logitech optical wheel mouse (different model number M/N
M-BJ58 and although older looks identical except for color).  I have not
had to install any mouse drivers since I moved away from windows 98 (to
Linux and Win XP). Besides, winXP is supposed to detect new hardware that
it doesn't have drivers for and ask the user how to proceed. I can't even
get to that state because I can't move the cursor to the proper win XP
login icon (multiple family user accounts) at start up!

It is going back today and I'm going to try to find an older model.

Re: New Logitech optical mouse does not work

alp wrote:
Quoted text here. Click to load it
Log in with an old mouse, and then plug in the new one on the USB port
and see if it works that way.

The only other thing I could think of is what type of surface are you
using it on?  Maybe the color or texture is bad.  I have a laser mouse
now and you can't even see the beam.


Re: New Logitech optical mouse does not work

Quoted text here. Click to load it


Quoted text here. Click to load it

That is a good point - the only surface I have found that my mouse doesn't
work on is one of my mouse mats - a very shiny mat.

Re: New Logitech optical mouse does not work

I used the mouse on my mouse pad (a dark grey fabric on sponge type base)
and on the top of the computer case and on a piece of white paper.
None of them worked.

No use further efforts, the mouse has been returned.


Quoted text here. Click to load it

Re: New Logitech optical mouse does not work

Strange.... have you checked thats its recognized in hardware manager,
no don't you removed the old driver and re-installed the new one should
any be required, you can check and update the driver in Hardware


Site Timeline