Intel quad upgrade

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I've been running Virtualbox and other programs that consume a lot of CPU  
power, so I've been thinking about a quad core CPU upgrade. My machine is  
quite old and partially home built. Installed is a dual core Intel E2160 @  
1.8 GHz with a max TDP of 65 W. The CPU cooling fan of this Acer looks quite  
competent. The CPU uses a 775 LGA. (OT: I built a 3 drive RAID 0 array which  
is too fast for the dual core CPU.)

This newsgroup is likely to have members who know about their Intel CPUs.  
I'm looking for a recommendation for an Intel quad core CPU that would be  
plug compatible and not much greater in TDP. I found it difficult to pore  
over Intel spec sheets.

I've noticed that eBay sells used working Intel quad cores for less than the  
cost of a case of beer. I don't care if the chip face has been defaced by  
heat just so long as the CPU has not been overclocked. eBay gives a 30 day  

(OT: I think my next  New compter will be a $74 Allwinner from China with  
Android Linux preistalled on flash. See:

Re: Intel quad upgrade

On 4/14/2013 11:57 PM, Norm X wrote:
Quoted text here. Click to load it

I would start by trying to find the CPU Support list for your  
motherboard.  That list will undoubtedly not be exhaustive, but can give  
you some clues.

Re: Intel quad upgrade

Norm X wrote:
Quoted text here. Click to load it

Retail processors, come with a heatsink/fan unit.
If I was selling one of mine, I would include
the Intel heatsink/fan when selling it to you. There's no
point in me storing old Intel coolers in my junk room.

OEM processors don't come with a cooler. In which case,
you can buy an aftermarket cooler (subject to the
mechanical details of your computer enclosure). There
are some monster coolers, that don't fit all computer

You could name the make and model number of the motherboard.

You could give us some idea what the current cooler is.
(In case it had some merit.) It's possible, it's no better
or worse than the cooler Intel would include in a retail
boxed product. If it doesn't have a name, find us a picture
of it, or post a picture of it (on

Well, there's some duals, and they're 65W.

And these quads, there's some 65W ones (-S), some 95W and 105W
(two different steppings). The ones with S on the end, are
specially selected for low power consumption, and are normally
more expensive (and obscure). Intel may have wanted an extra
$100.00 for them. Not everyone would buy one, as a result
(i.e. seems like a ripoff). These processors have different FSBs,
and not all motherboards run FSB1333 processors (my Asrock LGA775
with VIA chipset does not). That's why it's nice to have
some details about the motherboard.

And these quads are probably a bit too warm for you.

The motherboard VCore regulator, can have an upper
power limit. Some cheesy motherboards, for example,
might use a 95 Watt regulator design, in a world where
130 Watt processors exist. So that's another aspect
it's nice to check out as well. The "CPUSupport table"
on the motherboard manufacturer website, hints at such like.
Some manufacturers have just horrible tables, and all
they'll tell you is "it runs Pentium D and Core2 Quad",
leaving you to guess if there are deficiencies.

My current motherboard, takes just about anything :-)
Even FSB1600. And the CPUSupport page for mine is here.
Based on this table, all I have to worry about, is
cooling the thing. And I have an aftermarket cooler for that.
(The Intel stayed in the box for this build.) A real
enthusiast wouldn't buy this though, because it uses
DDR2 rather than DDR3.

Some boards, they might be missing a few entries in the
table, because there is no microcode support in the BIOS.
That probably isn't a problem in this case. But if
you have a recycled computer motherboard (a pull from a
Dell, HP, Gateway, Acer or whatever), just about
anything is possible with those. Since Windows has
a microcode loader that runs early in boot, that's not
a drop dead issue. But if the motherboard won't start,
with the new processor installed, that could be a reason
(BIOS wasn't updated to include support for it).

Some CPUSupport web pages, also list the *minimum* BIOS
necessary to make it work. If you have an old BIOS, you
use your existing dual core, to do the BIOS update,
and then there is microcode support and recognition
code for the new processor, ready to go.

Summary - I'd pick out an S for you, like a Q9550S would be
pretty sweet, but if you had an FSB1066 motherboard, that
wouldn't be a good fit for a FSB1333 processor. My Asrock
motherboard with the VIA chipset, running FSB1066 is already
an overclock of the chipset, and it just won't do FSB1333.
So I *can* run a Q9550S in my "board that takes anything", but
can't run it in my Asrock motherboard with VIA chipset.

Do they counterfeit those ? I don't know. Like, put a non-S
processor in an S box ? Electronically, there might not be
any way of detecting an S (the VID code range might give it
away, but the VID code values aren't documented in the datasheet,
so we'd need current owners of the two processors, to figure
that out). It looks like a Q9550 and Q9550S are both available
in E0 Stepping, so if I was "good with an eraser", I might
put a new SLxxx number on the lid of the processor, and try
and get a few more bucks for it. There used to be Ebay
activity of that sort, for Athlons. And you know just how
clever some of the sellers on Ebay are :-( Just look at
all the fake USB flash sticks sold on Ebay. If there's a way
to make a buck, they'll find it. If you actually got a Q9550,
it would just run a bit warmer.


Acer M1640 BIOS R01-C2 flash update, bad checksum

[snippage of a lot of good stuff]

Quoted text here. Click to load it

Thanks very much for the good advice and the links, Paul.

I ran into a problem with update of the BIOS of my Acer M1640. I was only  
able to run the downloaded flash update program using my Vista U-64  
partition. That seemed reasonable. I saved the old BIOS to a 1 MB file and  
loaded a .221 file that looked OK. The flasher program identified the file  
contents as the desired update BIOS. So I ran flash and watched the flash  
process which was slow. The flasher ran verify and all the flash cells  
showed green. I rebooted and hit DEL to run the BIOS program and checked  
everything. Everything looked OK and the new BIOS version R01-C2 was  
displayed. The RAID info was preserved. I saved one small change.

Now when I try to boot I am told there is a bad checksum and I am given two  
choices, F2 use old values, which hangs on the RAID or F1 which lets me back  
into the BIOS program. Now the BIOS setup program tells me the RAID setup is  
forgotten. For the life of me, I cannot remember which three of four drives  
I used.

Isn't this a kick in the pants? I can probably boot from a non-RAID drive.  
And maybe after a few days I will figure out how to set up the three drive  
RAID 0 storage array.


PS Booting from three drive RAID 0 storage array is MUCH faster than a HDD.  
Maybe a quad CPU upgrade would help.

Re: Acer M1640 BIOS R01-C2 flash update, bad checksum

Norm X wrote:
Quoted text here. Click to load it

Well, I don't know if I can interpret those symptoms or not.

The NVRAM can have a bad checksum. AFAIK, that's the contents of CMOS.
The CMOS is used to store motherboard settings.

If the BIOS had a checksum error, over the main code block, then
you probably wouldn't be getting any BIOS screen at all.

If you "Load Setup Defaults" in the BIOS, that will blow away the
CMOS contents and load a default set of values.

OK, now on to the RAID.

The SATA ports need to be set in some mode. This is used two ways:

1) At the BIOS level, the BIOS RAID module needs to know what is going
    on. To read sectors from the RAID, for boot purposes, it has to
    be in "RAID Mode". If the disks are in RAID Mode, the RAID module
    needs to be enabled, so it knows how to read from the disks (take
    interleaving into account).

2) The BIOS loads values into hardware, that when the Windows driver
    sees them, the RAID driver loads. And does its thing.

OK, so what the BIOS is contributing, is an annotation that the
Southbridge is in a soft RAID mode.

The hard drives themselves, each drive has metadata at the end,
that declares there are one or more arrays stored on the disk.
The membership is recorded (maybe, by serial number). No matter
which port you connect the disks to, the BIOS notes the information
about role, and makes sure the disks are used appropriately.

Now, if you flash the BIOS, mess up the NVRAM, then what is lost ?
The RAID mode setting is lost. Maybe the computer is in AHCI or
IDE mode. The three disks are now handled separately, and perhaps
the information is then not suitable for booting (or, anything else).

The metadata should still be on the drives. So nothing should be
lost from that perspective. It's still a set of RAID disks.
You have to get the motherboard back in RAID mode.

I wish there was an accurate way to record CMOS settings, but
there just isn't a guaranteed way to do it. Various brands and models,
may have come up with their own solution. One motherboard, for
example, had the ability to "store profiles". And a profile
could put back settings. The problem with this is, when you change
BIOS versions, the BIOS is not clever enough to rework the datafill
of the profile, such that the BIOS settings make sense with the new
BIOS. In other words, the profiles are only of use to a particular
BIOS version, and there is no guarantee the byte patterns can be reused.
If the info was stored in plain English, like "SATA 5 = AHCI mode",
then the new BIOS could load the appropriate value to make that happen.

I recommend going into the BIOS, and doing your best to put the
ports in question, back in RAID mode. If the board has multiple
storage chips, make sure your cabling and chip choice are still
consistent with what you're doing.

I'm hoping your checksum error, has nothing to do with the
BIOS flash itself (main code is bad).


When you flash a BIOS, sometimes the NVRAM no longer aligns with
definition of things in the new BIOS. You'd think if a developer
had half a clue, there'd be a wall poster over their desk that
says "don't screw with the definitions". Since they can and do
screw with the definitions, we're told as users that we should be
"clearing the CMOS", or, if the BIOS will come up at all, using
"Load Setup Defaults" to initialize the CMOS values. By doing that
after the BIOS flash, that allows the BIOS code to recognize that
the CMOS needs to be reloaded. That would include calculating a
new CMOS (NVRAM) checksum. The CMOS actually has two checksums,
one checksum over the majority of bytes, while the two BIOS passwords
have their own checksum. The CMOS is only 256 bytes of storage
in the Southbridge "CMOS Well", and not all of it is used. But
it's still important stuff, if it prevents the BIOS from
starting (or booting).

Some BIOS flasher packages, the .bat file includes an argument
to the flash tool, that tells the flash tool to reset the NVRAM.
In other cases, it's left to the user to clean up the mess on
their own.

If for some reason, the BIOS didn't start at all, you could
"clear the CMOS". But before you do that, remove all power.
A large number of desktop motherboards, have been designed
such that a certain diode on there, gets burned if you
clear CMOS with power present. Normally, this fact is
mentioned in the procedure for clearing CMOS (just not in
so many words - they tell you to turn off the power, but
don't tell you what the consequences are, of failing to turn
off the power).

Once you've reset the settings, using one of many methods,
now you have to go back into the BIOS, and put the
controllers back in their original modes. So the
Windows drivers will align with the hardware. On at
least one of my motherboards, there were two bad defaults,
and I can't count the number of times I've had to go in
and correct those. So any time the settings get reset on
that one, it's a teeth gritting experience for me (time
waster). For that one, the settings get reset, if
the BIOS "thinks" the computer crashed during its
last session (an Asus feature). So it's not like I'm
shorting the CMOS pins every day. It's a BIOS issue.
It's supposed to automatically recover the computer
from an overclock... even if it wasn't overclocked.


Re: Acer M1640 BIOS R01-C2 flash update, bad checksum

Quoted text here. Click to load it

[Much snippage]

I think I got a bad CMOS  BIOS burn, but not catastrophic. No need to worry  
the 3 drive RAID 0 storage array, so I disconnected power (keeping the SATA  
cables in place) replaced the DVD-RW with an identical single ST3250310AS  
HDD ( 3 partitions for backup of RAID via partition copy). I plugged in a  
USB flash drive with a bootable copy of BartPE. I can boot into BartPE but  
no matter what I do, in the CMOS program it always gives a bad checksum  
error. So I downloaded ->  
BIOS_ACER_R01.C2L_M1640_M1641_M5640_M5641, from the Acer support site. It is  
a flash burner runnable from DOS with BAT file, BIOS image, A7399NAEL.222  
and documentation in PDF for dummies. What can go wrong?

For now, I think I need to lie down and take a nap.


Re: Acer M1640 BIOS R01-C2 flash update, bad checksum

Norm X wrote:
Quoted text here. Click to load it

A nap. Now why didn't I think of that :-)

If something bad happens, this company offers a service to
program a new chip and send it to you. For this to work,
the chip on the motherboard must be socketed (so you can
remove it and replace it). Some motherboards, the BIOS
chip is soldered into place, and there is no socket.

One problem there, is the companies that offer that service,
offer it for (wide) DIP and PLCC flash chips. But serial
(8 pin slim DIP) EEPROMs might not be on the menu. So they
may not be staying current, with what's being used on motherboards
now. When the first serial EEPROM boards came out,
they were soldered into place, but boards since then
have seen the wisdom of using a socket for the part
instead. Some boards even included a 7 pin header,
for connecting a USB programmer, to program the serial
EEPROM - but the programmer costs $150.00.


Re: Acer M1640 BIOS R01-C2 flash update, bad checksum

Quoted text here. Click to load it

Overconfidence is the mark of a fool.

BartPE on a USB flash drive is a vital tool that you can make and avoid  
violation of MS license and copyright. Google is your friend. You will need  
1) your own WinXP install DVD, 2) some files extracted from a downloaded  
copy of WinServer2003, pebuilder3110a and PeToUSB_3.0.0.7.

BartPE is a free OS that boots a Windows environment for preinstallation  
(hence PE).

I was a wrong to assume that BIOS_ACER_R01.C2L_M1640_M1641_M5640_M5641,  
which is a DOS burner utility, would run under BartPE, because BartPE is a  
Windows environment and the command shell is protected from the hardware.

However, BIOS_ACER_R01.C2_M1640_M1641_M5640_M5641 runs as a Windows program  
under BarPE better than under WinVU-32, WinVU-62, or Win7-64, which I tried  
before on the partitions of my 3 HDD RAID 0 storage array, which is now  
offline for its protection. I'm trying to get a single HDD online

So I ran the CMOS BIOS flash burner for R01.C2 under BartPE but I ran it  
smarter than last time. This time I selected the option to burn the whole  
CMOS, 1 MB. Happy. I reboot into BIOS setup boot and select optimized  
configuration, save and exit.  No more BIOS CMOS checksum bad error  
messages. Into BIOS program for more tweaking. Detect and display HDD. BIOS  
is much more informed than before.

Can't boot into HDD. BartPE reports that it cannot see HDD. This is reminds  
me of situation in winter. Slow decline of 5 year old power supply. 12 V  
power supply to drives showed 10V on multimeter in contrast to CMOS BIOS  
health reports, so I replaced the power supply and system worked better that  
it did in 5 years.

This year I check 12 V power on HHD cable. It shows +12 V.

So now I have overcome CMOS BIOS bad checksum error, and have proven that  
new 500 W power supply has not failed in six months.

I can still boot USB BartPE, the CMOS BIOS setup program is burned  
successfully but I cannot boot HHD.

Time for another nap.

Re: Acer M1640 BIOS R01-C2 flash update, bad checksum

Norm X wrote:
Quoted text here. Click to load it

When you enter the BIOS, is the hard drive identified in the
BIOS screen that shows connected disks ? The BIOS should
directly show the disks on the Southbridge ports. There
should be an ID string for each disk, which is fetched from
the disk by the BIOS. It proves the connection to the disk works.

For peripheral chips separate from the southbridge, the BIOS does
a "clear screen", and then the code module controlling the
peripheral chip, does a status dump onto the screen. There is at
least one BIOS setting, which can affect add-in BIOS code modules,
and if you're having problems, you'd want to check that out.

For the BIOS to boot from the disk, it uses Extended INT 0x13 code.
The BIOS has to know whether the Southbridge ports are supposed to be
in IDE, AHCI, or RAID mode. When RAID mode is selected, RAID code in
the BIOS for the Southbridge, interprets the metadata on each RAID
disk, and figures out which disks are in an array. And the RAID code
also knows how the data is interleaves, so a request to "read sector Z",
is translated into an actual read of a block from the appropriate disk.

So that's part of the booting process.

Steps you can try:

1) Shut down, turn off computer, *unplug it*. Clear CMOS is
    only completely safe, if the computer is unplugged. Some
    computer brands are booby-trapped, such that a particular
    diode on the motherboard, gets burned if you don't have all
    power removed. Thus I have to give this conservative warning
    for everyone.
2) Use the Clear CMOS jumper. This will re-initialize NVRAM.
3) Connect power. Enter the BIOS.
    Set SATA or IDE ports, as is appropriate for the
    disk type you've connected. (IDE, AHCI, RAID)
4) Attempt to boot.

5) If steps 1 to 4 fail, try booting from a Linux LiveCD
    and see what it can detect. I don't see why BartPE can't
    do this, but the difference would be, BartPE would need
    drivers baked in, whereas a generic Linux LiveCD has all sorts
    of drivers baked in by default. (In fact, on a Gentoo DVD
    I've got, the idiots took great joy in turning on every
    conceivable driver possible, such that it takes 3 minutes
    to burrow through all of them, and finally boot up. I expect
    it was to prove they had lots of drivers... :-( )

If you want to test your RAID array, try the following.

a) Enter BIOS. Enable RAID on the ports you want.
    Save and Exit. Prove that pressing <control-I> or whatever
    the hot-key is for the RAID BIOS, actually takes you into
    the RAID BIOS setup screen. You want this to be working,
    before connecting the disks.
b) Shut down. Connect the disks. Start the computer again.
    Press the magic key combo (the one you just proved works),
    and examine the health status of the array in the RAID BIOS setup
    screen. See if the RAID setup screen is happy with what it's got.

The purpose of doing that, is to verify that at the BIOS level,
it sees the array, and the array is "Healthy" and not "Degraded"
or "Failed". If Degraded or Failed, verify that the cabling
to each disk is good. The disks don't have to go back on the
same exact ports, as the metadata identifies each disk. But
you can't move one of the disks, to a different peripheral chip - the
array is only going to work, if the disks are connected to the
same controller (the original controller). While there is at
least one RAID product which can span multiple chips, in
general motherboards don't work that way. Your RAID cables
probably all go to one clustered set of connectors.


Re: Acer M1640 BIOS R01-C2 flash update, bad checksum

[Much snippage]

Quoted text here. Click to load it

Everything you say is all good, but I am forced to the conclusion that BIOS  
upgrade R01-C2 does not support my MB. There are some interesting new  
parameters like CPU, PCI and SATA 'spread spectrum' that are enabled by  
default. This has to do with satisfying European EMI controls. So I disabled  
them all.

The situation I have mimics what I saw last winter with low 12V power on the  
SATA cable. The 5V was sufficient to enable the SATA drive controller but it  
was unable to talk to the HDD surface because it did not spin up to speed.  
Replacing the power supply solved the problem.

Here the power supply is OK. After some time for intermittent naps, I have  
been able to fiddle with all relevant BIOS settings, boot Windows-like  
BartPE from a USB flash drive, to boot a copy of Debian Kali Linux from a  
partition on a USB HHD, and to boot Partition Magic from a USB DVD/RW.

I only have one SATA drive connected; the three partition backup 250 GB  
Seagate. The RAID is an irrelevancy and I don't want to mess with it until I  
can read from one Seagate. USB BartPE was never able to see the Seagate but  
it always booted. USB HDD Kali Linux was installed on a netbook and I was  
surprised I was able to get it to boot, after disabling 'Windows OS' in the  
BIOS. It was never able to see the Seagate nor even the other NTFS partition  
on its drive.

Partition Magic is designed to 'see' hard disk drive partitions at the  
hardware level, and OSes, and it pauses for a long time trying to see them.  
I played around with BIOS HHD settings like 32-bit r/w  enable. But then PM  
would hang while trying to locate a HHD partition.

When one buys a computer it comes with a BIOS and a set of settings that  
ensure it will boot. As we are curious, we tend to 'tweak' those settings  
for some benefit. If some trial setting does not work then we reset the BIOS  
setting to what it was before.

Given that this BIOS has 'spread spectrum' settings that I have never seen  
before and since I cannot get it to read a good backup Seagate, I can only  
conclude that R01-C2 will not work with my motherboard.

I cannot find a listing of working BIOS settings for my Acer Aspire M1630,  
only a warning from Acer not to upgrade a BIOS without authority.

I'll need to reinstall R01-B4, using BartPE, after I have another long nap.

Re: Acer M1640 BIOS R01-C2 flash update, bad checksum

Norm X wrote:

Quoted text here. Click to load it

In cases where a controller supports RAID, and always uses metadata
(whether there is an array or not), it's possible for some portion of
the disk to be offset (hidden in some way). I had a case once, where
a disk connected to a Promise controller chip (378?), the first partition
would disappear. On that computer, moving disks around was "not portable".

You can use TestDisk, to search for partitions, but the disk must exist
for that to work. If the disk is not recognized at the hardware level,
the disk won't appear in the TestDisk disk selection menu.

Even if you were to run TestDisk, if the header of the file system on
a partition is not visible, it is unlikely any utility will be able
to synchronize to it. For example, if you just had a bunch of NTFS
clusters, and no file system header, could a utility tell they were
NTFS clusters ? Probably not. Maybe forensic software could, but
less capable free utilities, might not be able to. So while you can
run TestDisk (available for more than one OS), there is no guarantee
what it will find. Or, whether you'll be able to figure out, what
the BIOS has done. (Note - do not accept any prompts to write
stuff to the disk, unless you're absolutely sure it is the correct
thing to do! Press control-C to escape the tool.)

Have you verified your single disk is visible at the BIOS level ?
Is the "Seagate" part number shown in the BIOS disk screen ?
Note that, not all BIOS will show this info. For example, my laptop
has a grand total of one BIOS setting. (It's the most spartan
interface imaginable.) But, my BIOS does have a popup boot menu
(press F8, some systems it might be F12), and the popup boot menu
can be used as proof the BIOS sees the disk. Even if there is no
OS on the disk, the disk identifier will still show up in the popup
boot. This is an example of a popup boot screen, after pressing
the appropriate key a second or two after the system starts.

(Note - this site uses hot-linking prevention, so when I post
a link to a JPG, you may see the JPG flash and disappear. Try
hitting the back button in your browser, while they screw around.)


With regard to BIOS flashing, a good BIOS tool will check the
identifier in the main code block, and match it to the new
BIOS file to be flashed. Flashing will not proceed, if
they don't match. If you try to put an ABC BIOS in an XYZ
motherboard, the flashing tool will notice ABC is not equal
to XYZ. In cases where the user is absolutely sure the new BIOS
should be jammed in there, sometimes an older, more poorly written
version of the BIOS tool, has a "force" option. That's how you
escape from situations, where the boot block of the BIOS was
updated and no longer allows going backwards.

There have been cases, where the multiple available tools and
methods, can cause a one-way and fatal BIOS update to occur.
For example, on one Asus motherboard, the motherboard BIOS determines
the board had an "overclocking failure" (which happens to be bullshit),
the user is prompted at the BIOS level, to insert the motherboard
CD that comes with the product. What they don't know, is the version
of BIOS on the CD, will brick the motherboard :-( I nearly got caught
that way, but I switched to another computer and did the research,
before obeying the prompt. And saved myself some trouble. There
was actually nothing wrong with the system, that a Clear CMOS
would not fix. After the Clear CMOS, the BIOS came up with no
error dialogs, so I was back into the OS in no time. But they
nearly got me. I was tempted to shove that CD in the machine,
and watch the auto-recovery work. A computer can have problems
reading the BIOS chip, if the PCI bus clock is set too high
(the BIOS chip may be clocked at 33MHz for example). Clearing
the CMOS, helps return all clock signals to nominal values,
just like at the factory.


Your job now, is to seek confirmation that the BIOS lists
the Seagate model number. If there is not a regular screen
in the BIOS setup to list the disks, then look for the
popup boot hotkey, and verify the hardware disk identifier
that way. Most BIOS screens, the very first text screen,
will list two keys. Something like <F2> to enter BIOS setup,
and <F12> for popup boot menu. If there is no disk screen in
<F2>, then you resort to <F12>, which will have one entry
per storage device.

Good luck,

Re: Acer M1640 BIOS R01-C2 flash update, bad checksum


Quoted text here. Click to load it


I am happy to report that I made an error in judgment or logic, probably due  
to haste. I was able to go backwards to R01-B4 from R01-C2, given use of  
BartPE. Then I realized, ... I'd made an error because thing were as, or  
more difficult again. It took some time to realize that the new power supply  
I had installed last winter, was more intelligent than I. Since I was back  
with a familiar BIOS version I plugged in the power for the three Seagates  
for my 3 drive RAID 0 storage array. But I had disabled spread spectrum  
(CPU, PCI & SATA) and made other changes to the BIOS options. At one point,  
the CPU fan roared like a banshee but the PC didn't boot up even  into the  
BIOS setup program. At another point, even the power supply wouldn't boot  
up. I even used my multimeter to check AC line voltage to confirm what I was  
observing. Then I remembered that this was an intelligent power supply. When  
I first tried to install it, it would NOT boot up unless it was plugged in  
and could talk to the motherboard. After many naps and much thought I  
realized that the intelligence of the power supply & mother board BIOS was  
protecting the 3 drive RAID 0 array from my errors. I selected optimum  
settings again which enabled spread spectrum clocking. I set some BIOS  
options that needed to be set to support the AMD 8450 display board, etc.  
and after many failed attempts to "see" the RAID, finally booted the RAID.

At this point I'm back where I started but I've learned how the burn and  
reburn the BIOS flash. It will be a good idea to upgrade the BIOS before  
upgrading to a quad core CPU. The DVD-RW is plugged in and the backup  
Seagate is off-line. At no time did I read the single HDD either with  
BartPE, the Partition Magic rescue disk or Debian Kali Linux. I think maybe  
it is because it is in a slave position. I'm not reckless enough to start  
permuting SATA cables. It has been a year since I backed up the RAID. That  
will be next, after I have another nap.

I stuck my face into the system box at one point to have a good look. I  
discovered a jumper on the first Seagate in the RAID that should not have  
been there. Seagate's online docs said that jumper position was to slow down  
speed negotiations.

The moral of this story is that nVidia RAID support is very robust and that  
BIOS version R01-C2 may be good to use if you have the perseverance.

It would also be a good idea to keep a written journal.


Re: Acer M1640 BIOS R01-C2 flash update, bad checksum

[much snippage]

Quoted text here. Click to load it

This brings up an interesting point. The 3 drive RAID 0 storage array was  
intended to be a perfectly identical set of Seagate drives. The jumper that  
I missed when I purchased the drives was out of place. Seagate Inc. says the  
jumper reduces SATA link speed from 3 GHz to 1.5 GHz. Now the storage array,  
which was always fast, seems even faster. Somewhere on Usenet I documented  
DiskMark speed benchmarks of the storage array. Only a RAM drive can be  

Just for fun, I tried to boot a Live DVD for Debian Kali Linux 64-bit. Live  
boot crapped out trying to negotiate 1.5 or 3 GHz SATA link speed. I'm not  
sure what this means, but I do think it is wise to put on your spectacles  
and insure that such a jumper is removed if you don't want it. SATA link  
speed is also an issue WRT to spread spectrum. I set my system up with  
spread spectum (CPU, PCI & SATA) clocking enabled as a default. In guese  
there is no going back, especially with SATA link speed. This Intel CPU uses  
speed stepping at 1.8 and 1.2 GHz. In a square wave, the harmonics are most  
powerful. The first harmonic of 1.2 GHz is 2.4 GHz which is within range of  
the WiFi frequency band. When I cook with my microwave oven for 1.5 minutes,  
WiFi communications ceases for precisely 1.5 minutes. Spread spectrum  
clocking is an effort to reduce the EMF power density in any given band,  
hence reduced interference. However, CPU overclockers turn off spread  
spectrum CPU clocking because it defeats their intent.

Quoted text here. Click to load it

Now I'm all set to buy a good used quad core 775 LGA Intel CPU chip.


Re: Acer M1640 BIOS R01-C2 flash update, bad checksum

Norm X wrote:
Quoted text here. Click to load it

I've had this experience too, in that, I purchased two identical Seagate
drives brand new, and one had a jumper in the four pin jumper area,
the other did not. Hard to say what their "standard practice" might be.
I usually check for any jumpers, before installation. Especially, if
I can harvest the jumper and save it for later.


You would hope the emissions from the microwave oven would be pretty low.
Maybe the door seal isn't working very well ?

The motherboard, with CPU installed, is supposed to pass FCC part 15.
But there have been cases, where there were slight emissions failures.
One motherboard company, tried to draw attention to the failings
of another brand of motherboards. Otherwise, we might not have

Computers are a lot better than they used to be. I brought home a
prototype computer from work, to work on. And the emissions level
was so high on that unit, it wiped out TV reception in the house.
You couldn't watch broadcast TV, with that computer on.
Needless to say, that computer never went into production.
I took it back to work. (To give you some idea what era this
was, the computer had dual floppy drives :-) )


The only known case of a problem with Spread Spectrum, is on
a certain Macintosh computer. I don't think the Spread Spectrum
option makes much difference to other hardware products. You can
turn it on if you want.

As for the impact that setting has, for the most part, it's a cheat.
It exists solely to fool emissions test equipment. It can still
interfere with communications equipment. It's not magic or anything.
It broadens out what otherwise might appear as a spike on the
spectrum analyzer. And not every communications protocol and method,
tolerates it well. The effect is variable.


Re: Intel quad upgrade

One other small point: in the CMOS setup utility there is a a "PC Health  
Status" which reports various voltage and the CPU temperature. The CPU  
temperature is reported as 60 F. The CPU cooler works. No need to buy a  
better fan.

Re: Intel quad upgrade

On 4/23/2013 12:21 AM, Norm X wrote:
Quoted text here. Click to load it
If your setup is really reporting a CPU temperature of 60F then you had  
better do some serious checking unless your computer is running in the  
freezer. The CPU will always be warmer than the ambient temperature,  
usually by quite a bit even when idling, when under power and if that isn't  
being reported then the measurement is bound to be faulty unless you have  
some sort of phase-change or Peltier cooler arrangement in place.

Re: Intel quad upgrade

John McGaw wrote:
Quoted text here. Click to load it

Also, the error bars on the Intel temperature measurement, are largest,
when the chip is cool. It's only when the Intel processor is near
the throttle temperature, that the temperature readout is closest
to the truth. So if it reads 60F, it might not actually be 60F.

Example here, of some known cases.


Re: Intel quad upgrade

"Paul"  wrote


Quoted text here. Click to load it


Quoted text here. Click to load it


here's a picture at eBay:

As you can see, the motherboard still has value. On the other hand, the 200  
W power supply crapped out after 5+ years and I replaced it with a smart 400  
W power supply from Future Shop.

Quoted text here. Click to load it

The fan/cooler is fine. It may be Intel. When I replaced the power supply I  
needed to remove the heatsink, The heat sink grease looked dried out so I  
wetted it a bit with a small dab of vaseline.

Here is the spec sheet:

When the system was new I upgraded RAM to 4 GB. I played around with  
overclocking CPU, RAM and vVidia graphics chip using nVidia sofware.  
Overclocking worked but it was unstable over a time period of 24+ hours. I  
tried some faster RAM that had fin cooling and was garanteed to work dual  
channel, but since nothing worked better I returned the expensive RAM  
modules and still use standard DDR2 modules circa 2007/2008. I presume that  
dual channel RAM capability is a property of the CPU.

I've heard that  a good used Intel LGA 775 Q8200 is the cheapest quad core  
upgrade for this MB and doesn't tax the CPU cooler. I thnk I would like to  
stay with the old RAM that has woorked for 5+ years.

Quoted text here. Click to load it
Quoted text here. Click to load it
Quoted text here. Click to load it


Re: Intel quad upgrade

Norm X wrote:
Quoted text here. Click to load it
Quoted text here. Click to load it

Determining upgrade options, isn't an exact science. It is for things
like retail motherboards (Asus has pretty complete information for their
products). For a prebuilt computer, there can be very little useful
info for those. For some Dells for example, it's a real crapshoot
(buy processor, just try it).

When I look on your web page, I see:

Processor    Intel Core 2 Duo processor
              Intel Pentium dual-core processor

Does that worry you at all ?
They don't mention a quad.

I tried to find an example of someone running a quad, and I'm not
seeing an example where they actually describe having done it. I
could find one person selling a M1640 with a Q6600 in it, but
does that mean they actually did the upgrade or not ? There isn't
any information as to how it was done, whether they had problems
or not.

There is this doc, and it does a poor job of documenting things.

It says MCP73VE "doesn't support YorkField". Well, what does that
mean exactly ? Absolutely no hardware support (doesn't work) ?
No BIOS support in NVidia code module ? Or is it based on knowledge
of the recommended VCore regulator they put on motherboards
with MCP73VE. I presume the "V" stands for value, and it could be
that a value package (i.e. motherboard design), would use a
power-limited VCore regulator. Your motherboard has three phase power.
Which is fine, if we know for a fact it can handle a quad. There
have been three phase designs that can handle a quad. I'd be
happy with having one more phase though (less nervous, with
four phase power).

Summary: No definite info one way or another. I'd hoped to find
          an "analogous" motherboard, same design, and use info from it,
          but it's pretty hard to match these things. The 6100/7100
          family, at least in terms of docs on Nvidia, is pretty
          spotty. (There have been chipset SKUs, where I couldn't
          find info on them later. Like the chipset that only had
          x8 PCI Express for the video slot.)

For example, in this doc, there is no mention of 7050 with 620.
There are more SKUs, than are listed here.

Quoted text here. Click to load it

I don't recommend really pushing the RAM speed with NVidia chipsets.
There have been a few chipsets, where the RAM stability wasn't that
wonderful. If stock speed works, leave it that way :-)

I have one NVidia product here, and it took a solid week of
experimenting, before I figured out a way to make the
RAM stable. The solid week, was characterizing what settings
broke it, and what worked, as much as anything else. It took
CAS2 memory to actually fix it. These are the experiences
that don't inspire confidence. If yours works at stock, be happy.


Re: Intel quad upgrade

"Paul" wrote


Quoted text here. Click to load it

Thanks Paul,

I had a closer look at:

where it says:


Socket Type: Intel Socket T LGA 775 pin.
Processor Type: Intel Celeron Celeron D Pentium D Pentium Dual Core Core 2  
Duo Core2 Quad Yorkfield Wolfdale
CPUs FSB: 533/800/1066/1333 MHz CPUs.
Chipset: NV MCP73PV, NV MPC73VE.
Memory: Supports up to 4GB MAX, with 2GB per DIMM.
Memory Type: DDR2 533 667 800.


I guess that is why a 5+ year old MB keeps its value on eBay.


Site Timeline